1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

Active monitors very loud buzz, please help!

Discussion in 'Monitoring / Headphones' started by Maiken Hansen, Oct 3, 2014.

  1. Maiken Hansen

    Maiken Hansen Member

    Hi guys,

    I'm posting hoping you can help me with this problem. I am using a pair of Prodipe Pro 8s, active monitors. I've had them for 6 years with no problems. Suddenly one of the speakers is emitting a very loud buzz when powered on. I have tried unplugging all inputs, I've tried different power cables and in different outlets, and locations as well. Nothing changes. As soon as I turn it on, there is a loud buzzing, like a saw. I've tried searching for solutions, but I only find stuff on ground looping, but I don't see how it could be it. Has something broken inside the speaker? Any ideas would be great.

    Thanks
    Maiks
     
  2. Boswell

    Boswell Moderator Distinguished Member

    If it does this with nothing other than mains connected and if the volume of the buzz is independent of the level control on the back of the monitor, then it's either a problem with the internal amplifier or the power supply. However, the power supplies in these cheaper powered monitors are usually switch-mode type, meaning that the mains isolating transformer runs at 100KHz or so and therefore 50Hz mains frequency does not get through to the output. That should reduce the likelihood of it being the power supply and instead point to a stability fault on the power amp for that channel.

    If you feel up to a bit of experimentation, you could try opening up the boxes and swapping the amplifiers between the speakers to see if the buzz remains with the original cabinet. I don't know those French-Chinese units, so they may be un-openable, in which case I fear you may be having to look at replacements. Six years is not a bad run for items of that type.
     

Share This Page