1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

ART Tubefire8 - DELL laptop

Discussion in 'Recording' started by jam1394, Jun 18, 2009.

  1. jam1394

    jam1394 Guest


    I have just bought an DELL Studio XPS Lap Top and am running Window's VISTA Ultimate (64 bit) on it.
    I am trying to get an ART Tubefire8 to talk to it, but the DELL will not acknowledge the Tubefire through the IEEE1394 4pin firewire plug.
    Having heard that there may be some incompatibility with the DELL firewire chipset, I got on to a SONNET Firewire 400 D34 express card and have tried interfacing the two with a 6 pin firewire connection. No luck....

    Have installed the new driver from the ART website, but the PC still does not seem to want to recognize the unit.

    I am thinking now that maybe it is as simple as making sure that my firewall is not blocking anything???

    Has anybody had the same issues?
    Any advice would be appreciated.
    Maybe the DELL system is not suited for this application?

    (Melbourne, Australia)
  2. Codemonkey

    Codemonkey Distinguished Member

    Dec 11, 2007
    Scotland, UK
    "I am thinking now that maybe it is as simple as making sure that my firewall is not blocking anything"

    I'd hope not.

    Are you running the program in administrator mode?
  3. RemyRAD

    RemyRAD Guest

    Sep 26, 2005
    Stupid question. Are you trying to power the unit from the FireWire port? Or are you using an external power supply for the Art tube fart? Not all FireWire ports can supply the kind of current necessary to heat up & provide proper plate current for tubes. Vista is already a dead operating system. Just like Windows ME. It is a dog. It was a dog. Along with XP media center edition. Where are the computer hackers when we need them? Why hasn't anybody hacked Windows into its basic kernel. Most of us don't need the overbloated stupid stuff included in these operating systems that does more to hamper power attempts at professional production than to enhance my surfing, chatting, gameplaying download experiences which I don't need, don't want, get it out of here. So if hackers were really as smart as they claim to be, they would give us a basic Windows operating system that's lean, mean and ready to gleam. And I'm not talking LINUX. So even the hackers are not doing their jobs. If they're going to crack a program let them crack a program we all need.

    Bill Gates won't go broke
    Ms. Remy Ann David
  4. TheJackAttack

    TheJackAttack Moderator Resource Member

    Mar 20, 2008
    currently Billings
    Despite the ridiculous comparison with Win ME (which was a truly mind boggling ugly bad OS), Vista Ultimate is perfectly adequate for recording. More than adequate in fact. Windows 7 will still spank Vista without effort however.

    No firewire port will supply power for 8 tubes. The provided external power cable must be plugged into AC.

    If you in fact do have it plugged in and still no response from the XPS, then click Start->Control Panel->Device Manager. Look for something that is not in fact installed correctly. Right click and update the driver.
  5. jam1394

    jam1394 Guest

    Thanks for all the feedback.

    ***The bus on the Tubefire is powered separately (not from the lap top).
    ***Its not the firewall and I don't seem to have any issues with VISTA.
    ***Device Manager is OK.

    I have broken it down to the driver. The older driver that came with the system on CD throws an error at the end of the installation and although it will open up the ART control panel, it does not recognize the unit.

    The new driver of the ART website seems to complete the installation without saying it is finished and after reboot does not give access to the control panel. But, trying out of desperation to get it working I went into Cubase anyway (there is a control panel shortcut for the Tubefire under VST connections that I wanted to check - it did not work) and checking the inputs and outputs... it recognised the 8 Tubefire channels???. The driver must be working in the background (I could be talking s**t here) as the GUI is not accessible (everything (sample rates etc...) must be on default settings).
    Recorded my first track (what a relief).

    In summary, it has to be the driver (have contacted ART customer support again).
    Happy jammin' fellas,
  6. TheJackAttack

    TheJackAttack Moderator Resource Member

    Mar 20, 2008
    currently Billings
    Vista controls these drivers differently than prior win os. The Mackie drivers behave similarly in that the control panel gui's are accessible from within the various DAWs or through the Sound & Audio settings link in the control panel. It took a few times to get comfortable with this "new" way of accessing etc but nothing really changed from a user perspective. From a driver writer perspective however lots changed which is what caused the massive delays for lots of companies publishing updated drivers. They just didn't want to spend the R&D time/money.

    Win 7 is a much better implementation of what Vista purported to be and the drivers will have to be reworked again but several companies are already on the ball and have beta's available or imminently available.

Share This Page