1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

audio line-in on a mac laptop

Discussion in 'Recording' started by AnomalyAlecB, Mar 5, 2008.

  1. AnomalyAlecB

    AnomalyAlecB Active Member

    I'm trying to record my high school concert bands (winds) and I have an interface hooked up with mics and such but I can't get the laptop to receive the line-in signal instead of the built in mic signal for input. Just trying to get some mild recordings of the band. We went into system preferences and clicked on line-in for the input, but Garageband is still only using the built in mic.

    Any advice?
     
  2. hueseph

    hueseph Well-Known Member

    What software are you using. Regardless, you need to change the device in your Macs system settings as well as in the softwares settings. What interface are you using?
     
  3. Codemonkey

    Codemonkey Well-Known Member

    Sounds like he's using a mixer, running a line from that to the mac, and he's using Garageband.

    Check the garageband settings.

    If all else fails, get an XP machine and a hammer.
    Note: do not apply hammer to XP machine. Apply with gusto to offending mac.
     
  4. AnomalyAlecB

    AnomalyAlecB Active Member

    I'm in a school. This is not my set up. And yes, everything Codemonkey said was right about the set up.

    I was looking around in Garageband and I could not find where in the settings it determines what line-in it uses. I'm very unfamiliar with it. And Macs in general. But I did find it in the system preferences on the Mac, with no results despite what should have been an easy fix.
     
  5. peterhunt

    peterhunt Guest

    GarageBand menu -> Preferences -> Audio/MIDI -> Audio Input

    If there is nothing other than "built-in," reinstall your drivers for your interface.
     
  6. droc8705

    droc8705 Active Member

    it sounds like you're taking the line out of the mixer and sending it to the line input of the mac. if that's the case, then you don't have to change the preferences in Garageband; you actually have to go to the system preferences in the mac. Once there, click on the "Sound" icon and switch the input from the built-in mic to the line in port. that should do the trick.

    -d.
     
  7. Codemonkey

    Codemonkey Well-Known Member

    AnomalyAlecB said (twice):
    "We went into system preferences and clicked on line-in for the input, but Garageband is still only using the built in mic."
     
  8. droc8705

    droc8705 Active Member

    codemonkey: good call, i misread the post. i apologize.

    if that's the case, then is there a problem with the line out of the mixer? it should work if you've selected it in the system preferences and garageband is set to built in audio.

    -d.
     
  9. AnomalyAlecB

    AnomalyAlecB Active Member

    Peterhunt was right.

    But I just figured it out on my own about 4 minutes ago. But thanks for all of the help.
     

Share This Page