1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

Clicking While Recording Every Two Minutes

Discussion in 'Recording' started by Saikou, Jan 8, 2016.

  1. Saikou

    Saikou Active Member

    Hi, I record Let's play commentary for a youtube channel. I use Audacity to record my voice and until recently, I have never experienced a single problem.

    I recently bought a new computer, a HP Pavilion with 8GB RAM, and several sets of storage space, running Windows 10. I got all my recording software up; OBS for game capture, Logitech Quickcam for the face cam, and a Blue ICE Snowball mic recording on Audacity for the commentary; and started to go.

    Now I'm editing the footage, and I'm noticing that there are a few seconds of audio popping or clicking occasionally, littered throughout the recording. It's invisible when looking at the waveform; no peaks, gaps, spikes, or other signs of distortion; but it's definitely noticeable when listening to the playback, and distorts the sound quite unquestionably. The clicking can be heard even when no sound is made, but is exacerbated by any kind of sound.

    I experimented with recording with only Audacity, and found that the clicks occur consistently around the 1:58 - 1:58 mark, and reoccur every two minutes or so. This regularity is consistent when after restarting the machine, unplugging and replugging the mic, using alternative USB ports, having the mic as the only USB to plug into the machine, swapping USB cables, moving the mic do a different place, putting the mic at the lower sensitivity setting, and unplugging the AC adaptor.

    The clicking occurs when recording through the Snowball using Logitech Quickcam, so I don't think Audacity is to blame, and I can confirm that the mic records just as well as it used to on my older computer (3.4 year old Windows 7 Sony Vaio), so I don't blame the mic either.

    I checked recording using the Logitech Cam mic and the laptop's inbuilt mic and have not encountered this problem, it seems to only happen when using the blue mic.

    I have tried changing some settings in audacity, such as increasing buffer time to 1000 ms, but to no avail. I've included two mp3s in which you can hear the distortion. Both of them are snippets cut around the 1:57 mark. The timing is so consistent that I can predict quite accurately when the popping will start and end.

    I have never encountered a problem like this before, and any attempt to remove the distortion digitally results in more damage done to the audio and no real effect on the distortion itself.

    If anyone has any suggestions, advice, or even an explanation as to what might be going on, please let me know as I'm rapidly running out of ideas.

    Thank you



     

    Attached Files:

  2. DonnyThompson

    DonnyThompson Distinguished Member

    You need to increase the playback buffer, not the recording latency buffer.

    These playback buffers will likely appear in values of 64, 128, 256, 512, 1024, and 2048.

    The higher the setting, the less chances there are for "short-buffer" errors like clicks and pops, or in extreme cases, "stuttering" where the playback actually "hitches" and starts and stops momentarily.

    The general rule of thumb is to use the lowest buffer setting ( example, 128) for recording to avoid latency, and the highest setting ( example 2048) for post production and mixing where various processors ( FX, EQ's, Compressors, De-essors, etc.) are inserted into the tracks, and require larger buffer sections to run properly.

    Are you using the ICE Snowball as your default audio playback device as well as your default recording device? I'm asking, where is the playback audio being routed out of your computer.. what device are you using to monitor/playback what the audio that you record? Because that's the device that you need to change the playback buffers on. You may be able to accomplish this from within Audacity's audio settings, but maybe not, and you might have to get into the settings for your playback device in order for them to lock into the settings you adjust to.

    Also, make sure that all drivers and firmware are up to date for your current audio interface, ( ICE Snowball) and that this device is set as the default in Windows Control Panel, and that any other audio devices ( such as built-in sound cards like SoundBlaster, Realtek and Conexant) are disabled.

    If you are relying on a factory built-in sound card as those mentioned above, they will probably not be able to handle what you want to do; and you may need to look into either a dedicated PCIe audio interface, or, an external USB audio capture device.
    Your ICE may be fine, but if it won't allow you to set buffer settings as high as they need to be, then you need to look at other options. Those factory built-in sound cards are meant for gaming and internet streaming audio, and are not designed to handle the power and speed required by multi-track audio recording programs like Audacity, Reason, Pro Tools, Samplitude, etc.

    Try changing your playback buffers to the highest amount on your playback device, and let us know what happens.
     
  3. DonnyThompson

    DonnyThompson Distinguished Member

    Added note...

    If changing the settings on your playback device doesn't work, or it doesn't allow you to choose a block large enough ( 2048) you may want to try a global driver like Asio4all.
     
  4. Saikou

    Saikou Active Member

    Thanks for the response

    I'm having a lot of trouble finding out where it is I can change the Playback Buffers. I can't seem to find where this option is if it's on Audacity, nor does going into the control panel give me anything to go on. This is probably a really stupid thing to not know, but where exactly do I need to go to change these settings?

    According to Audacity, my recording device is the ICE Snowball, while the playback device are Speakers Realtek HD. The only other option for Playback devices in audacity is Microsoft Sound Mapper, and running with this option yields the same results.

    As far as I can tell, all the drivers are up to date. That is, the drivers for the Mic, the Sound card, and the Realtek Speakers.
     
  5. DonnyThompson

    DonnyThompson Distinguished Member

    Yup. The Realtek is what is giving you the problems - and it will likely continue to do so. As mentioned in my previous post, neither the actual Realtek hardware (or its drivers) were designed to do what you're wanting it to do.
    You're expecting more from it than it is able to deliver. In short, you're trying to tow a 3000 lb boat with a VW Bug.

    It's considered to be a "toy".... a cheap $ 19 consumer grade catch-all, to handle only the most basic of PC/Windows and streaming internet audio functions.

    You can try downloading and installing the Asio4all drivers that I gave you in my first reply - it's free, so you might as well try it... but there's no guarantee that it will help with your current built-in hardware.

    You may have to ( meaning that you'll probably have to) upgrade your audio interface to a model that is designed for what you want to do.

    -d.
     
  6. Saikou

    Saikou Active Member

    Something's not quite adding up here...

    Am I to understand that simply recording my voice on Audacity is beyond the capabilities of a standard bit of hardware?

    Why then does it work without a hitch when I use alternative microphones on my current laptop?

    My old laptop has exactly the same brand of hardware, if not older, and having just tested it now, does not experience these popping sounds when recording with the Snowball in Audacity. If the sound card was simply not up to the task, then why am I only experiencing this problem on my current laptop, and not the older one?
     
  7. Saikou

    Saikou Active Member

    Furthermore, if it was a problem with my Sound card, then why is it other applications, such as the Logitech Webcam Mic, and the Laptop's own built in Mic, are able to record without these clicks?

    I suspect this may be an issue specifically to do with the interactions between my new windows 10 laptop, and the Blue ICE Snowball.

    What other possibilities might there be, and how can I go about troubleshooting this further?
     
  8. Boswell

    Boswell Moderator Distinguished Member

    A USB microphone is a microphone and USB audio interface integrated into one unit. There is no separate soundcard involved in recording the microphone.

    My guess is that since you are able to record the dropouts, the problem is happening during the recording and not the replay. Does the time between clicks change at all if you alter the recording buffer size? Does it make any difference if you disable all the networking on the laptop?
     
  9. Saikou

    Saikou Active Member

    Hi, Putting the machine on Airplane mode makes no difference to when I hear the clicking. I hear it at around 1:57, then again at around 3:57

    As for changing the recording buffer size. I am unsure as to how to do this on Audacity. What I thought was changing the buffer size turned out to be just changing the latency buffer, so I'll need to be advised further on how to check that.
     

Share This Page