1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

Clicks and Pops

Discussion in 'Recording' started by Kunalgiri, Mar 28, 2006.

  1. Kunalgiri

    Kunalgiri Active Member

    Hi All

    I an fairly new to recording and I have been using Nuendo for recording my tracks. I wanted views on one of the very common problem everyone face, Clicks and Pops. Can anyone share their techiniq of using the plugins to reduce the chances of clicks and pops. How can anyone best utilise the power of the CPU any setting of your own? Does increasing RAM allow us to add more Plugins without resulting any clicks or pops? What is the best way to set up the buffer setting while recording and mixing?

    I am sure everyone has their own approach to this problem. I would really appreciate and request you all to let me know some of the techiuque.

    Kunal :)
  2. zemlin

    zemlin Well-Known Member

    One thing to check is whether your clicks and pops happen in recording or playback ... or both.

    Can you see the noises in the waveform display? Spectral view is good for tracking down noises - a click will be a bright line, usually from floor to ceiling on the spectral display.

    Also, when listening to clicks, if they don't always happen at the same spot, that's a playback issue rather than a recording issue.

    Just want to be sure we know which tree to be barking up.

    Also, details on your system, sound card, hard disk setups, etc will be necessary to help you track down problems.

    A PCI hard disk controller, for example, is a bad idea if your sound card is also running on the PCI bus.
  3. Kunalgiri

    Kunalgiri Active Member

    I generally experince Clicks and pops while I apply plugins on the tracks while mixing them. Because of the risk of having clicks I try to avoid routing Plugins through inserts and use them more on aux buses. I have P4 3.4ghz, 2gb Ram, 120Gb hard disk, Delta 1010lt. When ever I have some clicks and pops I increase the buffer that clears them. I dont use any Plugins till the time I record all the tracks and then I increase the buffer and start adding Plugins but It drains out my CPU. Is there any other better way to over come this?
  4. zemlin

    zemlin Well-Known Member

    So it sounds like you are recording clean data :cool:
    I'll let others familiar with Nuendo dig deeper, but a plug on an AUX bus should be more efficient that multiple instances on inserts. You should have plenty of power with that setup - it's far more power than I have. What plugs are bringing your system down?
  5. Kunalgiri

    Kunalgiri Active Member

    Its generally the inserts plugins for Dynamic effects (compressor, limiter, etc) and the equaliser for each channel.
  6. aztec

    aztec Guest

    If using a lower latency does not fix it, and it happens when using dynamics processing i guess its a denormal problem when those plugins are not accepting any input ...

    Denormalisation is an issue with some audio hosts that don't switch off the plugin's audio task when the song is stopped or a track contains silence (or with instruments: no key is pressed while a sound decays).

    The problem happens when the CPU (precisely: the floating point unit (FPU) inside of it) detects extremely small numbers and wishes to process them with the same precision as usual. Then it switches into 'denormal' mode which is another way of representing small floating point numbers with the available bit range.
    Converting between the two states takes a lot of time for the FPU and thus might cause heavy load jumps.

    Try normaliser and run some tests, monitor the cpu use ...


  7. aztec

    aztec Guest

    Btw, off topic, while you are there, try blockfish compressor, it's in my opinion one of the best freeware compressors:>
    It has both VCA and OPTO modes and you can get interesting results and tones(decent saturation algo as well) if you "open up the lid" and experiment.
  8. Kunalgiri

    Kunalgiri Active Member

    Thanks Aztec, does every one deal with the similar problem and is there any tweek that I can do on the PC to get rid of it......BTW I liked Blockfish compressor..........Thanks
  9. zemlin

    zemlin Well-Known Member

    Different effects require different amounts of horsepower, and different programs respond to over loading in different ways.

    Adobe Audition will skip and click if overloaded. Samplitude will have dropouts in individual tracks. There are plenty of tweaks you can do to your OS that might help. Do a forum search for


    select MATCH ALL TERMS - you'll get plenty of existing threads to get you going.
  10. Kunalgiri

    Kunalgiri Active Member

    Does increasing RAM increases the ability to add more Plugins on the mix?
  11. jcnoernberg

    jcnoernberg Guest

    having a lot of ram will help, but once you get up there around 2GB, anything more is overkill... and can sometimes even cause problems like parity errors since it's not ECC (server) ram. some things to try are:

    -play with buffer settings
    -edit/record to a seperate physical hard drive (critical!)
    -tweak your pc for audio, including disabling all useless services running in the background: http://www.dead-eye.net/WinXP Services.htm
  12. stanceyu

    stanceyu Guest

    Hallo 2 U all! This is my first post here :)

    Would it be a problem for you to put a few more lines about this issue:


    What if this applies only to some recordings, but not all? Are those mastered “too hot”?
  13. zemlin

    zemlin Well-Known Member

    Well, yeah - there many ways screw things up ...

Share This Page