1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

Cubase is playing my newly recorded audio tracks too soon

Discussion in 'Cubase' started by AKR, Dec 6, 2008.

  1. AKR

    AKR Active Member

    Cubase LE. I have been recording on this computer in this project just fine, and then yesterday, whenever I would record something, it would play the clip slightly too soon. Notice I say too "soon" and not too "fast." It's the correct speed and if I nudge it forward a hair, it right in sync, but it's annoying as hell. I haven't been able to google anyone with this issue.
     
  2. GeckoMusic

    GeckoMusic Guest

    It's called latency delay compensation. In Cubase LE the option to adjust for it is in the audio preferences... or was it Devices -> Device setup? ... or VST connections... Someone else will know. To measure it route one of the tracks you have recorded out your head phones and into a line in and record a 2nd track. Then zoom in and measure the delay.
     
  3. Groff

    Groff Active Member

    I believe it's - record placement offset. Device setup/vst audiobay/expert (in Nuendo, but should be similar in CB).
     
  4. AKR

    AKR Active Member

    Alright, but why is it doing this now when it wasn't before? I don't know what has changed. I'm on a super fast computer (quad core) with good hard drives (SATA II). It seemingly randomly started doing it.


    I took a look in the cubase manual and don't see any kind of latency compensation ability or record placement offset option. :(
     
  5. Groff

    Groff Active Member

    What is too soon? The whole event "container" or just the wav inside the container?
     
  6. GeckoMusic

    GeckoMusic Guest

    Did you add a VST that has a long delay? There is a VST delay compensation threshold. If the plugin exceeds the threshold Cubase doesn't try to compensate for it because it would though of real time monitoring.
     
  7. hackenslash

    hackenslash Active Member

    Tempo automation? Check the tempo track in the project menu.
     
  8. AKR

    AKR Active Member

    Sorry it's taken me a little while to get back to this thread. It doesn't seem to be doing it on every track. I think it's just that one track, even though I have delay set up on multiple tracks. I turned the delay off and that didn't change anything. I found something really weird when I looked at the audio up close.


    http://i37.tinypic.com/jj66u9.jpg

    These audio tracks look like the audio isn't in sync, right? Well, it is. For some weird reason, it's playing what looks like the later audio in sync with the earlier audio. So I think when I record something, it puts it visually in line with where it should be, but because cubase is reading that track at a slightly different time, the track has to be bumped .030th of a second back to make it APPEAR out of sync while the audio is in sync.


    My brain is melting.


    hackenslash, there's no automation in the tempo track.
     
  9. Groff

    Groff Active Member

    Looking just at the photo it's recording placement offset. According to your words seems it is not.

    It could be graphic card, ASIO driver or OS.

    What is your audio card (AD/DA)?
    What is your OS?

    Check the ASIO driver clock source in CB, it should be on - internal
     
  10. majormusic

    majormusic Member

    Check your latency settings, and then buffer settings. And then make sure you have over a Pentium 4. If not, that's the reason too.
     
  11. hueseph

    hueseph Well-Known Member

    This has little or nothing to do with latency or bufferes. The jpg looks to be a snapshot of an older version of Cubase. Likely SE, SL, SX or an older version of LE. All of which can function perfectly well on a 1GHz or better machine. That means P3 or better. In fact I'm pretty sure you could run it on a 700MHz machine with enough RAM, provided you don't have any other programs on the machine.

    Anyway. I know this is totally unrelated but you may want to check into it. Look in the steinberg folder under start menu/steinberg/cubase/ and look for a folder marked "ignore emulated midi ports". There is a file in that folder. Put that file in with the general population of other files. In other words take the file out of the folder and put it in that folders "mother" folder. If this is the problem, you will notice it even more with midi files. If it doesn't work, no harm done.
     
  12. hackenslash

    hackenslash Active Member

    ^^ It isn't that, I'm sure. Port emulation isn't connected with audio in any way. Further, simply moving that file doesn't accomplish anything except making the emulated versions of MIDI ports visible within Cubase.

    What specific version and revision of Cubase are you using? Have you activated 'musical mode' on any of the audio files? You can check that in the pool window.

    Post a screenshot of your pool window.

    The other thing it could be is that you have executed some range functions while one of the tracks was muted.
     
  13. hueseph

    hueseph Well-Known Member

    Meh. It was a stab in the dark. It fixed a midi issue i had that was similar to this audio issue. I don't know why and I don't care. It worked for me.

    Incidentally, I read back and apparently he's using Cubase LE. Probably pre Cubase 4.
     
  14. hackenslash

    hackenslash Active Member

    Yes, I got the LE, but he doesn't say which specific revision. There are quite a lot of differences in functionality between even the minor revisions.

    Your issue was obviously the famous 'two clocks' problem, that had to do with drift between two clocking sources. It's fairly common, but only when using Cubase in conjunction with specific MIDI devices, such as the Midisport series of MIDI interfaces. The Windows MIDI ports would drift, hence the need for using emulated ports and the later addition of the 'use system timestamp' option.

    Just in case you ever experience such issues again, of course.
     
  15. AKR

    AKR Active Member

    Musical mode? I can't even find that in the manual. I don't think that's something you can do in my version, unless it's general known by another name. Here's a cap of my pool. Below, are my specs.

    http://i38.tinypic.com/2002tg1.jpg



    Yeah, it's set to internal. I'll just give the whole shebang:

    DFI Blood Iron mother board. Pentium Quad Core, 4 gigs of Corsair DDR2, XP Pro (32 bit), Presonus Firebox, Cubase LE version 1.0.7 Build 94. Yes, I know. I have one hell of a PC for a such a little sequencer. :)

    I'll upgrade to C4 when I have some spare cash.
     
  16. Groff

    Groff Active Member

    A few basic things:

    Disconnect/disable any other audio card/device (ie on board).

    XP control panel/Sound & audio devices - select the FireBox (ASIO) as main device.

    The FireBox ASIO driver should be also selected in CB.

    Try to change audio priority settings in CB.

    Have you installed SP2? Have you read about FW chipset/XP problems and compatibility?

    http://www.presonus.com/media/pdf/hardware_compatibility.pdf

    I doubt this will fix your problem but it's good to know how to tune XP for audio:
    http://www.musicxp.net/dnn/
     
  17. majormusic

    majormusic Member

    Hey Hueseph, you're beginning to piss me off. Stop following me when I'm responding.

    You don't know a lot about music.
    If you don't have anything better to do? Get a job.
     
  18. majormusic

    majormusic Member

     
  19. StephenMC

    StephenMC Member

    Teehee.
     
  20. hueseph

    hueseph Well-Known Member

     

Share This Page