1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

Cubase SX 3 crashes with multiple Firepods (OS X, Quad-G5)

Discussion in 'Cubase' started by Indieguitarist, May 23, 2006.

  1. Hello Recording.org!

    We are migrating Cubase SX 3 projects (and all audio) from an older PC to a new Quad-core G5 with 2 Presonus Firepods, and of course the latest Mac version of Cubase SX 3.

    Cubase SX 3 crashes when trying to use BOTH Firepods that are connected and setup (as an Aggregrate Device) in Audio/Midi Setup.

    --Follow presonus's instructions on how to use multiple firepods in OS X.
    --Both Firepods are hooked up and turned on.
    --Fireware is updated (they require a firmware update in order to run multiples)
    --Connect, power-on and get the BLUE lights on the front.
    --Create the Aggregate Device in Audio/Midi Setup setup.
    --Open up Cubase and select the Aggregate Device in Devices > Device Setup > VST Audiobay
    --Open VST Connections (F4) and select Inputs
    --When clicking anywhere in Device Port area of VST Connections (Inputs) Cubase hangs (must use 'force quit' to close)

    When opening an audio project created on the PC, playback gets to anywhere around 10-20 seconds into it, then crashes.
    ** this happens with only ONE Firepod connected **

    When only ONE Firepod is connected, a NEW project file can be created with the single Firepod selected in Devices > Device Setup > VST Audiobay, and signals are received by the app just fine.

    When only ONE Firepod is connected, opening a project file created on the PC (copied with audio and other related files), 9 times out of 10, it crashes.

    When trying to use BOTH Firepods as an Aggregate Device (as configured in Audio/Midi Setup) it crashes.

    SPECS on the new Mac:
    2 dual-core 2.5 GHz CPU's
    8 GB RAM
    OS X 10.4.6 (Tiger)
    250 Gig system drive
    150 Gig Raptor audio drive


  2. Westex

    Westex Member

    May 24, 2006
    Home Page:
    I had a problem similar to this and deactivating my plugins seemed to cure the crashes. Have you tried this yet?
  3. Ah yes, we were able to open up older (created on PC) project files and remove/disable plugins. Forutunately, Cubase wasn't crashing when removing them, rather when trying to open VST Connections (F4) and clicking on inputs or outputs. The mac version of Cubase certainly does not like the project files created with the PC version.

    We took our copy of Logic Pro & dongle from the other mac in the studio, installed it, ran updates (to v7.2), created the Aggregate Device in Audio/Midi Setup (using the same two Firepods) and we are able to use the Aggregate Device in Logic Pro to record and playback. We ran muiltiple instances of various plugins (Amplitube 2, BFD) in a effort to give it a thorough work-over, and it worked rather well I have to say.

    It's very apparent that the project files that were created on the PC are problematic. Our install of Cubase still does not like using BOTH Firepods with a fresh project.

    We are waiting to hear back from Presonus and Steinberg. Also, Cubase hasn't been updated (latest version is -what we have) since Oct 20, 2005. Perhaps they are working a Universal Binary version. Maybe this may help with our problem.

    I'm left with the thought this might be our chance to move the entire studio to Logic. I can't say that I'm upset about that either. Will keep banging on it with a hammer :D

  4. Zoro

    Zoro Guest

    Have you tried lowering the sample rate to 4800 or 4100??

    Just a thought.

  5. gdoubleyou

    gdoubleyou Distinguished Member

    Mar 19, 2003
    Kirkland WA
    Home Page:
    SX itself is probably the problem. It is the least effecient of all the Mac DAWs.

    Because it shares codebase with the PC version, it very little OSX specific optimization. It doesn't really support the Quad, for better performance and satability disable multi-processor support.

    Logic is highly optimized for OSX and takes full advantage of the Altivec instructions. It runs fine even on old machines.


Share This Page