1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

DAW/Digiface glitches

Discussion in 'Recording' started by Tungstengruvsten, Jan 12, 2003.

  1. Tungstengruvsten

    Tungstengruvsten Active Member

    Hey All;

    I'm in desperate need of some help troubleshooting my system-I've spent all weekend setting it up and I'm still having glitches.

    I recently switched from a Delta1010 to a Digiface/Lucid 8824 setup-the computer has stayed the same, but now I get glitches every now and then when recording at 24 bit.
    I just tested the card out and for 1/2 hour of recording nothing(no inputs hooked up to 8824) on 8 tracks, 4 or 5 digital glitches appeared. After repeated tests at 8 tracks/24 bit, various #'s of glitches(always under 10) show up in seemingly random places-some tracks have now, others have 1, others have a couple or a few.

    I've reformatted the OS drive, tried ACPI on and off, USB on or disabled, and with or without the VIA drivers, but still I have these %^&#$ glitches! I've also turned bus mastering off on the Matrox, installed only XP and Vegas, Made sure DMA settings were right and done performance tweaks...and still glitches. I'm recording to a 5GB partition that's empty each time.

    Here's the clincher: 16 bit works fine with both 8 AND 16 tracks at over 1/2 hour....

    Maybe someone can shed some enlightenment as to recommended BIOS settings....or would putting the PCI card in a different slot work better?(I chose one that didn't share an IRQ with any other slot)

    As for the external gear-I'm using a GenX6 to clock the Digiface, ADA8824 and the Digimax-I am using 75ohm BNC video cables I had(are wordclock cables any different?? i was told these should work fine) that are all under 6 feet long. The HDSP is installed fine and it shows a lock to the incoming wordclock, as does the 8824. The buffer size in the HDSP settings is 512(i've tried others) and ADAT1 and 2 are locked to wordclock.

    I'm really hoping to use this system for a gig this weekend, and I want to iron these details out to make the system rock solid with 16 tracks-I have a Digimax I haven't even bothered to hook up yet....

    Thanks in advance,
    Eric Warren

    Here's my system:

    Hardware:
    Iwill KK240
    768 MB Crucial RAM
    2x 20GB HD's
    -ATA66 HD(IDE0 Master for OS)
    -ATA100 HD (IDE1 Slave for Audio)
    16/10/40 Plextor Burner (IDE1 Master)
    Maxtor G550 AGP (with dual Samsung monitors)
    Dlink 530TXS Network Card(PCI 5)
    RME Digiface(PCI 3) with Lucid ADA8824 on ADAT1, Digiface on ADAT2 and Genx6 as wordclock master

    Software:
    Windows XP Pro installed as Standard PC(no ACPI)
    Windows Update SP1 installed as well as security patches and Matrox driver from Microsoft
    VIA 4in1(newest Hyperion4.45) installed
    Using Vegas 3.0
    Performance tweaks from:
    http://www.nemesysmusic.com/support/W2k_XP_Optimize.pdf
    HDSP driver version 2.33

    in BIOS:
    RAM set to Fastest speed(5-2-2)
    Parallel/Serial/USB/Floppy Disabled
     
  2. Tungstengruvsten

    Tungstengruvsten Active Member

    I've been going back and forth with some others on this and they've pointed me in the right direction-since I can do 16 tracks at 16 bit and not at 24 bit without a couple glitches, this points to a PCI throughput problem...I'm going to remove the network card to see if that helps and if it doesn't, i'll try the Digiface PCI card in other slots...can you guys think of anything i'm missing? Maybe you guys have some insight into necessary BIOS settings? I'd love some help on this matter since it seems to be more PC related than recording system...

    Cheers,
    Eric
     
  3. Tungstengruvsten

    Tungstengruvsten Active Member

    ok so since this is turning into a monologue, i'm just gonna keep typing $*^t in the hopes someone will take a peek at this thread....

    so I removed the network card and ran a 16 track 10 minute test at 24 bits....still a couple glitches

    I then moved the RME PCI card from slot 2 to slot 6....still a couple glitches.

    So....my guess, since the only 2 cards in here are the Matrox 550 AGP and the RME one, is it's something to do with the video card(a setting i've overlooked??) or possibly the BIOS... I'm going to try the hardware acceleration slider in various positions and come back here to blather on some more...
     
  4. Opus2000

    Opus2000 Well-Known Member

    Eric
    Sorry about not getting to you...had to really read your post to think about it and gather some thoughts...
    One thing that I notice is that you have the CD burner on with the audio drive. I would personally not do this...I would put the burner as the slave to the OS drive on the primary IDE channel. Let the audio drive be by itself. Also what type of cables are you using? Do you see UDMA5 in the device manager under the ATA/IDE controllers? If not that will suffer some performance.
    The tweak guide you are using was written by Daniel Keller and is definitely a good one to use. You might also want to check mine out as well.
    http://www.opusaudioprojects.net/WinXp.htm

    In regards to the word clock..as long as it's a 75ohm cable you should be just fine. Length is good too. I'm sure each device is being fed seperate word clock from the distro box?
    Also when is the last time you defragged the drive? Have you turned off bus mastering for the Matrox card yet?
    In regards to the memory. Are all the sticks from the same manufacturer? How many sticks of ram to get that count? If from different manufacturers make sure to leave the BIOS alone and let the defaults be the master for it. Sometimes setting the BIOS to different speeds with mismatched RAM may cause problems. Also make sure that the largest size stick of RAM is on the first slot and then procede with lower sizes afterwards.
    It shouldn't matter what mode of install you have personally...it may depend on the motherboard as well...since you have a via chipset it may very well be that as the culprit...
    HTH
    Opus
     
  5. Tungstengruvsten

    Tungstengruvsten Active Member

    Thanks Opus-

    I've been testing and troubleshooting all day, both online with others and in the puter itself...

    To answer your questions-
    -3 sticks of 256MB Crucial RAM, all bought from Crucial at the same time
    -Bus Mastering is off on the Matrox Card
    -80 pin ATA100 cables, all DMA's check out
    -Newest VIA drivers installed after winupdate(and I checked the DMA's again then in case something changed)
    -Wordclock coming from Genx6 distro-all short 75ohm cables-RME app. shows sync lock
    -everytime i do the test it is to an empty drive(maybe i should reformat it-what's the settings for audio drive? bigger sectors or something...)
    -PNP OS turned off in BIOS

    I've even re-installed windows without ACPI(RME recommends using it) to see if that is the culprit, and have moved the RME PCI card around and removed the network card....i'm doing some more tests right now, but maybe you could help me out on some BIOS settings-soon as I get a chance i'll post the ones i'm fuzzy on-

    Thanks for the help-
    Eric
     
  6. Tungstengruvsten

    Tungstengruvsten Active Member

    Hmmm no one else eh? I'm dying to get this working as it's been narrowed down to a computer prob and not the converters/RME card...The MOBO is working great on tons of people's systems(it's the RYO2K MOBO from Prorec.com..) so someone has got to have some insight...any insight!!!
     
  7. Tungstengruvsten

    Tungstengruvsten Active Member

    OK Well here's my BIOS settings in hopes that some one is bored and wants to help me out...

    BIOS SETTINGS
    Award Modular BIOS v6.00PG
    KK266plus/35104A(May.15.2001)

    Advanced BIOS Features:
    CPU Internal Cache - Enabled
    External Cache - Enabled
    CPU L2 Cache ECC Checking - Disabled
    Quick POST - Enabled
    ...
    Gate A20 Option - Enabled
    OS Select for DRAM>64MB - Non OS2
    Video BIOS Shadow - Enabled
    C8000 etc... Shadow - Disabled(all entries like this disabled)

    Advanced Chipset Features:
    DIMM 0 - Fastest5-2-2
    DIMM 1 - Fastest5-2-2
    DIMM 2 - Fastest5-2-2
    SDRAM Cycle Length - 2
    Bank Interleave - By SPD
    DRAM Page Mode - Enabled
    Memory Hole - Disabled
    PCI Master Pipeline Req - Enabled
    P2C/C2P Concurrency - Enabled
    Fast R-W Turnaround - Enabled
    CPU to PCI Write Buffer - Disabled
    PCI Dynamic Bursting - Disabled
    PCI Master 0 WS Write - Enabled
    Delay Transaction - Disabled
    System BIOS Cacheable - Enabled
    Video RAM Cacheable - Enabled
    I/O Recovery Time - Enabled
    AGP Aperture Size - 64M
    AGP4x Mode - Enabled
    AGP Fast Write - Enabled
    OnChip USB Port 0 - Disabled
    OnChip USB Port 1 - Disabled
    USB Keyboard Under DOS - Disabled

    Integrated Peripherals:
    OnChip IDE Channel 0 - Enabled
    OnChip IDE Channel 1 - Enabled
    IDE Prefetch Mode - Enabled
    All PIO and UDMA set to Auto
    Init Display First - AGP
    IDE HDD Block Mode Enabled
    FDD/Serial/Parallel ports disabled

    PnP/PCI Configurations:
    PNP OS Installed - No
    Reset Config Data - Disabled
    Resources Controlled By - Auto(ESCD)
    PCI/VGA Palette Snoop - Disabled
    PCI's and IRQ's are all on Auto
     
  8. Opus2000

    Opus2000 Well-Known Member

    Personally I've never really seen a BIOS setting cause this...it's typically the chipset that causes it...is there a PCI latency setting in the BIOS? If so raise it from where it is...also try and set the video aperture to 256.
    The other people that are using that mobo...what audio cards are they using? If none are using RME maybe there's an indication there?! That's why i stay away from Via...you can't trust those chips. Plain and simple. It's not worth the hassle in the long run. Certain cards will work with them and certain ones don't get along with the at all!
    Opus
     
  9. Tungstengruvsten

    Tungstengruvsten Active Member

    Hey Opus-

    Yeah the mobo is the one recommended on ProRec.com for it's RYO2K system...lotsa others have it and use it with MOTU/DELTA1010/RME stuff...I figure the very last ditch effort will be to get rid of the mobo but damnit that's a bitch as I can't afford to upgrade processor/RAM and everything so I really couldn't switch to an Intel P4 or DDR etc...
     
  10. Opus2000

    Opus2000 Well-Known Member

    Just switch to an AMD based chipset motherboard than...this way all you are doing is swapping mainboards....but you will need to reinstall the OS as you can't just re add the hardware and expect it to re initialize the set up with a new BIOS and chipset config.
    Opus
     
  11. Tungstengruvsten

    Tungstengruvsten Active Member

    it's looking like that might have to be the case...I've had tons of help and suggestions on a few different boards and from you too and I've tried for 7 days, re-installing, re-configuring and retesting...I've been building computers for 15 yrs(since my first 8086) and never have I had problems like I have with this VIA chipset $*^t...I have an Abit KT7 RAID that sucks ass too, same chipset...it's relegated to internet and word processing...

    So any recommendations from you or others for a solid AMD chipset board? I'm all ears....
     
  12. Tungstengruvsten

    Tungstengruvsten Active Member

    well i decided ^#$% it i'm ditching this system...expensive choice i didn't want to make but holy christ i'm one stressed out tired Mo-fo from troubleshooting a piece of crap VIA/AMD combo for days...

    I tried everything, multiple installs of XP with every option, NIC in/out, RME card in every slot, Every option for the Matrox 550, with/without VIA4in1's, with and without tweaks...christ my studio looks like a PC repair shop....

    So, I've decided to put my money in your Anus, Opus(hehehe i feel better already)....P4PE/L, 2GhZ p4, 512MB 2700DDR coming my way tomorrow.

    It's funny, all my audio nightmares started when I switched from Asus/Intell PIII combo of a P2B/Gadgetlabs824....^#$%ing via crap. Headaches shouldn't last this long.

    If I wasn't throwing more money at the problem I'd pull an 'Office Space' and take the MOBO outside and stomp the $*^t out of it....
     
  13. Opus2000

    Opus2000 Well-Known Member

    Yup...it's better to work than troubleshoot I always say...that's why I stuck with Intel...
    Let us know how it goes man..you won't be sorry..that's for sure!
    Cheers
    Opus
     
  14. Kurz

    Kurz Guest

    I'm running a multiface on a Gigabyte GA-dx7R (AMD761 chipset)and have never had any problems.
    Your troughput problem is indeed probably chipset related allthough there have been very little probs with RME cards and chipset compability that I know of.
    Have you checked with RME for support?They are very helpfull and knowledgable about these mathers.It might just be that you need a patch or an update.

    Let me know if your new system provides proper performance.

    BTW,I hope you didn't forget to raise the latency buffer?
    You wouldn't be the first to look past the obvious. ;)

    Hope it works out for you.

    Cheers,
     
  15. Opus2000

    Opus2000 Well-Known Member

    Kurz is correct..the earlier chipsets from Via really sucked...I think the brand new ones they have out today are actually decent but it's so hard to trust em....AMD chipsets are very reliable and work fine with most cards...
    The thing about the buffer size...well...you should be able to work at any setting regardless.
    Opus
     
  16. Tungstengruvsten

    Tungstengruvsten Active Member

    I tried various positions of the recording latency in Vegas as well as the latency on the card at most settings-I'm looking at my MOBO(now that it's out!) and it says ver 1.0, so who even knows if that's the prob-could be an original mobo with an older VIA chipset....

    Anyhoo, i know watcha mean-I know lots of folks who have an AMD based DAW with no probs...that's why i'm extra pissed at all mine...

    Thanks again guys
     

Share This Page