1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

Digi 001 users can now use DigiStudio!!

Discussion in 'Recording' started by ednaroma, Apr 3, 2002.

  1. ednaroma

    ednaroma Guest

    Just a heads up:

    Digidesign have now released a new version of Pro-Tools LE (5.2.1) that allows collaboration via Rocket Network .

    I gotta say, being a Digi 001 user I've been waiting on this one for ages - tried it out last night and works like an absolute dream!!

    The 5.2.1 download is free if you are a registered 5.1 or 5.1.1 user.

    To download just click on link at

    Digidesign Site

    Basically you then are able to log into DigiStudio and collaborate globally. I'm pretty sure you can check it out for free, but there is a monthly fee if you want the full kahuna.

    Would love your reactions to using it - I know it has blown me away.
  2. Markd102

    Markd102 Well-Known Member

    Apr 24, 2001
    And as usual we PC users have to wait a little longer :roll:
  3. SonOfSmawg

    SonOfSmawg Well-Known Member

    Sep 10, 2000
    Hehehe, whadaya know ... maybe this 001 actually ISĀ useful for something! And as luck would have it ... I'm on a G4! :p
  4. ednaroma

    ednaroma Guest

    Oops sorry, yes forgot to mention available on Mac only


    Anyone checked out DigiStudio yet?
  5. Markd102

    Markd102 Well-Known Member

    Apr 24, 2001
  6. Markd102

    Markd102 Well-Known Member

    Apr 24, 2001
    I actually don't know whether I'll bother updating when the new PC version comes out. It's going to require Windows XP, and I don't like an OS that wants to go crying to M$ everytime something goes wrong! :roll:

    My Athlon Win98 system is rock solid, NEVER crashes. And PTLE 5.1.1 does everything I want it to.

    I supose I'll review the situation when it comes out and hear other people's comments.

  7. ednaroma

    ednaroma Guest

    Hi Mark,

    Have you checked out DigiStudio though? Once you get hooked on that sucker, 5.1.1 may not be enough after all!


Share This Page