1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

Don't really know what to name this thread... Potatoes?

Discussion in 'Computing' started by narcoleptic_zombie, Jul 19, 2009.

  1. I'd like to start off by saying thank all of you on this board in advance for helping me solve the following problem. If this thread is in the wrong place feel free to move it. I'm trying to be as specific as possible, so bear with me on the deluge of text.

    About a month ago, my two year old white Macbook completely died on me. It still runs, but barely. I'm not sure exactly what happened, I've tried every trick in the book, but basically it is running at .01% of it's ability when I first got it. But that's besides the point.

    I have a one-man black metal project that I'm extremely serious about. I do it just for the sake of doing it, at the moment I'm getting ready to start college in the fall and am working towards a degree in recording arts technology, so I don't really have the time to take the project to a professional level. It is a huge portion of my life though, and is pretty much my pride and joy.

    Because of the lack of the Macbook frying itself to death over the course of a couple years I'm sort of left without a means to record (sort of). I was using Garageband but supplimented it with Amplitube Metal, Amplitube Ampeg, and a lightweight but fairly powerful freeware maximizer/expander/weird-eq-thingy called UpStereo, which I would load onto the master track. I used ezdrummer on a seperate computer (Reaper) to keep keep the load on the Mac as low as possible. I recorded purely digitally, except for the vocals, which I used an sm57. I started out pluging into and old Tascam 464 multitrack, then into the Mac's line-in (this was before I got Amplitube, so I was using Garageband's amp simulator). After recording the first album my friend lent me his M-Audio Firewire Solo, which sounded AMAZING, especially compared what I was using before. I then recorded the second album. I then give him back his interface and recieve a Focusrite Saffire for my graduation.

    Right. So here's when my problems begin. I don't think it's the Saffire that did it, because I succesfully recorded one song with it, and it sounded really good. My computer all of a sudden kind of died after that. It's gotten to the point where I can't play more than 3 tracks at once without getting an error message saying "Too many tracks/effects to play in real time", at which point it stops. I can usually record, simply by muting other tracks, but I can't mix/master/whatever because of this problem. Recently it won't even record without glitching insanely and getting latency. I've done everything in the book to speed my Mac back up, and it just isn't happening.

    Speaking of which, this is the first time I've ever encountered any serious latency issues with the Mac. I'd get them on occasion, but it was easily solved by switching to a different track and hitting play, stopping it, then switching back to the track I was recording on. If that didn't work I could just restart Garageband and it would fix itself.

    Good news is this. I have a Gateway FX series gaming computer with the following specs (copy/pasting this from my XFIRE account, so bear with me on the useless info):

    Manufacturer: Gateway
    Processor: Intel(R) Core(TM)2 Quad CPU Q9300 @ 2.50GHz (4 CPUs), ~2.5GHz
    Memory: 6142MB RAM
    Hard Drive: 623 GB
    Video Card: NVIDIA GeForce 9800 GT
    Monitor: Gateway HDMI Monitor 1680x1050 4ms response
    Sound Card: Realtech High Definition Audio
    Speakers/Headphones: Audio-Technica ATH-M40fs monitor headphones
    Keyboard: Standard Gateway FX Keyboard
    Mouse: Standard Gateway FX Mouse
    Mouse Surface: A ^#$%ing mouse pad.
    Operating System: Windows Vistaâ„¢ Home Premium (6.0, Build 6001) Service Pack 1 (6001.vistasp1_gdr.090302-1506)

    So it's pretty damn powerful. I figured it would be great for recording, so I uninstall all the games and update my version of Reaper to the current one. I also had Cubase LE that came with the Saffire, hated it.

    Anyways. So I try recording with it. Basically my problem is when recording, despite the massive system specs, I somehow get extreme amounts of latency, to the point where if I lower the buffer size enough to make it bearable, it sounds like complete crap. I don't think it's the computer at this point... I think it's Vista. >_< There is no way that old Macbook could do it perfectly and this beast of a PC can barely do it at all.

    (Note: I have Amplitube Metal installed on this PC as well).

    Here are my audio preferences for Reaper (that are relevent... I'm missing something let me know):










    Once again, I'm almost sure the problem is Vista related. I was reading through other threads and got a lot of useful information on there. I do happen to have a pretty good external hard drive that I use for storing music, saved games, basically anything else I don't want bogging up my computer. I can easily convert that into one devoted for recording (the important stuff on there is the music, and that all came from CD's anyways).

    I'm fairly new at the whole recording deal. I've only been at it for about a year, and I've gotten decent at it, but most of that is from trial and error. I just started reading the Yamaha Sound Reinforcement Handbook, which is AMAZING! If you guys have any other reading material you could recommend, that would great.

    Here's the band myspace, just so you can get an idea of what I was doing sound wise:


    Thank you all so much for you help, really, if you guys can nail this (which I'm absolutely sure you can), you would really be saving my neck.

    Triple Thanks,

  2. TheJackAttack

    TheJackAttack Distinguished Member

    First, is this version of Vista 64bit? I presume from the amount of RAM but I hate to do that.

    Second, if you were not already recording to the external drive then you need to start by doing that. Internal OS drives are just for the OS and program files.

    Third, make sure all of your networking is turned OFF and disabled.

    Fourth, download and run DPC Latency Checker here:

    If you find latency spikes then you need to tweak your system until you find them. Vista can be used very successfully to record though the preferred versions are Business and Ultimate. The Home version has some limitations with regard to controls and what not.

    The Sapphire is far superior to anything M-Audio makes so I will concur with your conclusion that it is likely not the problem. That said, making sure the Sapphire's firmware is up to date (not just the driver) is a good idea.

    Lastly for now, you might as well download and install Vista SP2. It fixes a few more things left out of SP1.
  3. hueseph

    hueseph Well-Known Member

    First of all regarding the Mac: Am I wrong to guess that you were recording to the system drive? It sounds to me like you had the drive pretty full. The OS needs some slack to read and write from/to. Anything less than 25% free space is going to be pushing it. It's always better to have a secondary drive for audio only.

  4. Vista 64 bit Ultimate Edition, SP2. I'm downloading the DPC Latency checker as I'm typing this. Gotta go though, I need to get to work. I'll open up the Latency Checker and get cracking as soon as I get home though. I'm sure there are other threads on how to tweak Vista for recording. If someone could send me a link to the best one that would be awesome.

    Thanks again for your help.
  5. Yep, you're correct, I was doing that. I backed everything except for the project I was working on and then deleted it. There was absolutely nothing else on there either, I had even uninstalled all programs not pertaining to music. I think I had something around 80% free disk space. You're right though, from now on I'm switching to external drives. At one point I was bringing it into smokey clubs on a regular basis for this weird industrial thing I was doing... maybe the smoke and grime killed it (the body of the Macbook is actually kind of creamish brown colored now, although not noticable unless you get close to it). >_< I need an MPC if I'm ever going to do that again. >_>
  6. TheJackAttack

    TheJackAttack Distinguished Member

    The biggest problem with Vista has to do with the permissions on the hard drives. You need to change those permissions to allow everyone access. This applies both to internal drives and external drives. This has foiled many people inre Vista.

    I can't really help with the Mac. The last one I touched regularly was in 2002.
  7. TheJackAttack

    TheJackAttack Distinguished Member

  8. Before I get started though, are you sure it wouldn't be a good idea to just go into the study and grab the family's copy of 64 bit XP? We have it from when we updated our old computers from 98/NT to what was then the latest OS. Installation should take no more than 2 hours tops.
  9. Screwed up, I have Home Premium not Ultimate. Yeah installing XP seems unecessary, the the stuff on the last link you sent me doesn't seem that hard to do, I think I can pull it off. Thanks again.
  10. Space

    Space Well-Known Member

    :cool: :shock: :? :!: :roll:
  11. TheJackAttack

    TheJackAttack Distinguished Member

    Do not forget to set the permissions on all of your hard drives.
  12. Space

    Space Well-Known Member

    Win 7 is like that with permissions...but where in the wide world of sports did the XP comment come from?
  13. TheJackAttack

    TheJackAttack Distinguished Member

    I hired you people to lay a little track, not jump around like
  14. Space

    Space Well-Known Member

    I have GOT to get my eyeballs checked again...

    But in my defense...this post with all the setting graphics...it's a lot to run through at one sitting.
  15. Hahaha my bad. I had just seen so many other posts where people didn't post enough details and the people answering the OP had to ask all kinds of questions that could have been avoided simply by the OP being more specific. :D

    Ok, I totally f***ed up. I followed the BlackViper's directions on messing with the registry to speed up the OS, but instead of following his advice and using either the Safe or Tweaked settings, I decided to take a gamble and use the Bare Bones setting (which he explicitly said was very dangerous). So low and behold, I restart the system and get a blue screen of death, which will not go away. V_V So at this point I have to reinstall the OS (or just go with XP, which once again is sitting in a box in the other room). I'm more of a musician than a geek sadly, although I love computers and am learning more about them every day. Luckily I ran a backup before doing this, and I had transferred all of my files to an external hard drive as well. :cool:

    So yeah, I'm torn at this point. Reinstall Vista and start again (not a big deal), or just save myself the trouble and install XP (also not a big deal) which from what I've read won't have nearly as many of the problems Vista has. I have to get up at 4 in the morning tomorrow so I'm pretty much done for today, but tomorrow I'm get back to work on this. My apologies for mucking this up this badly. >_>
  16. TheJackAttack

    TheJackAttack Distinguished Member

    Restart your computer in Safe Mode. Do a System Restore to before your tweaking.
  17. Space

    Space Well-Known Member

    HEY! That's my line!
  18. LOL! I mucked up your line! haha

    I installed XP 64 actually, so um, basically a clean slate. I'm in the process of setting it up and reinstalling software and whatnot. Do I need to tweak XP as well?
  19. TheJackAttack

    TheJackAttack Distinguished Member

    Yes. Same website, just look for the XP link. The #1 key is to make sure all networking is disabled. Also, in XP you will see a 1394 networking icon in the Network Connections folder. Right click and disable that too.

    Ahem. Maybe don't use the extreme tweaks this time. (cough)
  20. Space

    Space Well-Known Member

    "Automatically check for new versions of Reaper on startup"

    This line is checked, rather, was checked in your configuration. That always leads to virus protection software, firewalls, screensavers, VirtualGirl popping up and the Weather Channel plugin...oh, and Vistas built in gadgets.

    There's your problem;)

Share This Page