1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

drifting system set up.

Discussion in 'Recording' started by reincarnation1, Apr 26, 2002.

  1. I have a hp pc with a p4 1.2 processor, 256 mb of ram and a 30 gig hd. The sound card I am using is the delta audiophile 2496. I am using Cool edit Pro 1.2 as my software and the Mpc2ooo as my sequencer. I also use the roland Mc303 as a sound moduale. I have from the Mpc midi out port a=sound card and midi out port b=mc3o3. I use the drum samples from my mpc2000 and the keys from the roland mc303 to compose a track. The problem I am having is that with in 3 minutes of recording I am hearing major drifting in my tracks, it seem to me that it is mostly between my snare and bass drum sounds. It sound find during the recording process, but at play back I experiece the drifting. I have already tried setting the latency on both the card and the software, and I have also adjusted the buffers from mozambeke africa to waallly washington and still no success. Can you guys pls help me? :eek:
     
  2. Opus2000

    Opus2000 Well-Known Member

    What operating system are you using first off...second what form of sync are you using between the MPC and the computer? MTC? Typically MTC is flaky and the sound card may not be helping with the drivers. MPC's work better on sync when SMPTE is involved..in fact anything will sync better to SMPTE than MTC. MTC is basically SMPTE but converted to MIDI...is not that stable as I said.
    Send a SMPTE output to the MPC and you wont get as much drift. Also it may be the program that has terrible MIDI implimentation.
    Opus
     
  3. I am using Windows 2000 and also I am using smpte 30fps. ps thaks for replying.
     
  4. Opus2000

    Opus2000 Well-Known Member

    So even with SMPTE you are getting drifting? That's odd....Something is definately out of whack if that is the case....
    Both computer and MPC are set to the same frame rate..correct?
    30 NON DROP should be used...
    I would suspect the audio card than at that point
    Do you have Service Pack2 for Win2k?
    Opus
     
  5. I set the software and the Mpc2000 to 30fps, I see where on the mpc you have 30fps and then 30dfps. I am not sure if this makes a differece of not. I also tried to set the latency on the sound card. I adjusted up the latency buffer and the drifting was worse so maybe I need to adjust my sound card latecy dwn.
     
  6. Opus2000

    Opus2000 Well-Known Member

    Yeah, try it at 512 and see how it is, with that system you should be able to set it at 128 or 64 without any problems...What do you have it set to now?
    Opus
     
  7. My sound card buffer is set from 2 to 28. I have tried setting it to 4 and I recieved some popping and then I tried setting it to 12 and recieved a slower drift with pops. I dont know what to do, this is getting very frustrating.
     
  8. knightfly

    knightfly Active Member

    You mentioned one unit set for 30 fps, the other possibly set for 30dfps. The "d" in dfps stands for "drop", as in drop frame timecode. If both units are set for that, fine - if the other is set for non-drop, as in "30 fps", then you will experience drifting as you describe. The other thing you didn't mention is which unit you have designated as the time code master. Unless you have one device, such as cool edit or the MPC, designate as master and ALL OTHERS set to slave, or external, time code, they will NOT sync to each other. You would experience a tight apparent sync on start, but each would go its own way without one unit being the boss. This should have nothing to do with buffers; if those were incorrectly set you should experience either long latency or stuttering, not drift.

    I don't have any of the units you mentioned, but most software and hardware released in the last 10 years or so should be able to act either as master or slave. If you haven't already done so, you need to check the manual for each hardware and software item that you're trying to sync, and find out how to choose a master and lock to it. Frame rates (30, 30nd, 29.97, etc , are not important as far as which you choose, unless you're trying to export projects to other studios or you are doing sound for film/video. What is VERY IMPORTANT, as Opus mentioned earlier, is that all units use the SAME setting. If one is set to 30 dfps, set them ALL to that, and make sure only one is set as the master. That should make things all better - if not, it's all Opus' fault... Steve
     
  9. Opus2000

    Opus2000 Well-Known Member

    Ya see, always trying to pass the buck my friend!! lmao!!
    :D

    Buffer settings from 2-4 or 2-12? Huh? :eek:
    What type of buffer settings are those? Typically you should see settings from 64 to somewhere in the 8000's....I dont have any experience with Cool Edit Pro so I cant tell you where to look..
    I think Steve may be able to help you there
    Opus
     
  10. Thanks guys, you guys are all wonderful and if I can help any of you guys with something dont hesitate to ask. I have my mpc set for midi out but I dont remember setting it as a master. I do have the program set for smpte slave enable. :confused:
     
  11. Thanks, you guys are wonderful. I have found what the problem was. what happend it that the software ask for the driver and latency. I had the driver in there and had the latency setting to 2. The sound card latency setting was 8, so there for I had a mis match in settings. So I set both settings to 8 and thats a wrap. :D
     
  12. knightfly

    knightfly Active Member

    Hey, glad you got things going. I too know next to nothing about Cool Edit Pro, but maybe different buffer sizes for different latency values were what caused the drift??!?

    Now, here is one more tip - Open Wordpad, or whatever you use to type crap into files, and generate a text file called SysBugFix, or something that will jump out and grab you. Do this while everything is still fresh in your mind. Cut and paste anything in our posts and yours that caused you to look where the problem turned out to be, and paste it into this new file. Type in any comments as to where you looked, what setting you changed, basically re-create the whole thing in type, and save it where you keep really important info relating to your audio system. If you don't have a folder for that, make one. Probably be better if you put a "1" as the last character of the file name, so the next problem can be "SysBugFix2", etc. This way, the next time something gets changed, either by you or the all-powerful computer gremlin god, you can re-read each of your "bugfix" files and maybe get up and running right away. If you happen to have more than 1 computer, like also a laptop, file it in the same place on both machines. Then, if the machine is the problem, you still have access to your notes. I've been doing this for several years now, and it really helps to keep from solving the same problem from scratch. Try it, you'll like it... Steve
     

Share This Page