1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

How to autocorrect latency in audition

Discussion in 'Recording' started by qazzyguy, Aug 9, 2009.

  1. qazzyguy

    qazzyguy Guest

    I have audition 3.0 and don't really know much about how to use it. I have this problem where there is always a 50 ms latency. In audacity there was this auto correct thing that fixed that, the problem is, in Audition, everything is set up with samples and such which I have no idea what that is. How would I go about making it so that after each recording session, Audition pushes back any recorded piece 50 ms?

    Thank for the help
     
  2. Guitarfreak

    Guitarfreak Well-Known Member

    Rather than fixing it afterwards why don't we truly fix the problem at the source? What is your recording setup? Let's see if we can't see what is causing this latency.
     
  3. qazzyguy

    qazzyguy Guest

    Ok, it's not exactly a recording pc but here are the specs.
    I have a Realtek 7.1 HD sound card (I don't know how to find out anything more specific)
    I have ASIO4ALL installed.
    I tried each setting and there still is a latency. I tried lowering and raising the sample buffer, (I don't know what the offset buffer is, is that a way to make it autocorrect?), I put a loopback cable in each config and there still is a 50 ms latency.
    Did I miss anything?
     
  4. Guitarfreak

    Guitarfreak Well-Known Member

    Mics? Cables? How are you getting the mic signal into the computer?
     
  5. qazzyguy

    qazzyguy Guest

    I'm using my guitars preamp (I know, I know), with an adapter to 2.5 or 3.5 I forget which is which, to plug right into my line in/mic jack. Ugly but it works, the sound is fine it's just the latency
     
  6. Guitarfreak

    Guitarfreak Well-Known Member

    The latency is most likely coming from your computer not being able to process the incoming signal as well as run the recording program efficiently at the same time. If you want to take the processing of the signal out of the equation, look into a digital audio interface. You don't have to spend a lot to get a lot, but it is a necessary appliance.
     
  7. qazzyguy

    qazzyguy Guest

    so you're saying there's no way to do it with any latency correction? I keep going back to that because audacity does a super job with that, the only problem with audacity is that it doesn't have any vst plugins (not ready to use and I have no idea how to set it up) and more importantly because it only records one track at a time, whereas I have to record my guitar and a mic.
     
  8. Guitarfreak

    Guitarfreak Well-Known Member

    It depends on what you want to do. If you want to just record and then fix it afterwards for mixing, then it is possible. Any recording software should be able to adjust the timing of the recording just by dragging the recorded area. If you want to record and monitor yourself with zero latency, then get that thought out of your head because it most likely isn't possible. From your experience as well, it doesn't sound like you are anywhere near that goal as of this moment. 50ms of latency is quite a lot.
     
  9. qazzyguy

    qazzyguy Guest

    All I want to do is to be able to play one track of rhythm, then another track of melody and have them line up automatically, I have no problem aligning them by hand, all I was wondering was if there was a way to have this done automatically built into audition, like audacity has so that I don't have to go through all that trouble after each track.
     
  10. apstrong

    apstrong Active Member

    Have you tried any/all of this yet?

    http://kb2.adobe.com/cps/331/331631.html
     
  11. qazzyguy

    qazzyguy Guest

    I tried all that, didn't help.
     
  12. TheJackAttack

    TheJackAttack Distinguished Member

    The problem is that you are not using an interface. You are using your built in sound card. The driver for this card does not have the ability to adjust for latency. If you were using any of the myriad of good two channel interfaces out there the ASIO driver would be able to then be more able to help you out.
     
  13. qazzyguy

    qazzyguy Guest

    I finally got it to work, heres what I did:
    I open up the control panel for ASIO4ALL by clicking (in Audition) edit->audio hardware setup->control panel, then I just played around with the latency setting. In my case I set in to 1024 samples and out to 256 samples. I used a loopback cable to do this to get it exact. Oh and now that I set that up, I cranked up the buffer size to 2048 samples. Everything is in perfect sync now.
     
  14. TheJackAttack

    TheJackAttack Distinguished Member

    My mistake. I guess I didn't understand what you were asking. You were actually asking about adjusting the sample buffers to remove digital jitter basically. The article Apstrong posted is exactly the solution then. If you are overdubbing ideally you'd want the smallest buffer your computer/soundcard combination can handle without dropouts or artifacts. If you are just tracking or mixing/editing you can push that buffer size way up.
     
  15. qazzyguy

    qazzyguy Guest

    In that manual, even on the smallest sample size there was still an unacceptable latency, considering I have an intergrated sound card without ASIO support this was to be expected. I think this is the only workable solution to my problem considering I tried everything else, even though this is more of a band aid then a solution.
     
  16. TheJackAttack

    TheJackAttack Distinguished Member

    A too small buffer setting would create clicks and pops or just plain drop outs on a sound card whether internal or external. Latency per se is heard in the headphones as a sort of echo-esque (poorly described to be sure) as the real time sound blends with the recorded tracks being simultaneously played-only they aren't lined up. Increasing the buffer count also increases the latency which manifests as more of this echo effect but decreases in most cases the amount of the digital clicks and pops. Sometimes if the buffer is too large this also can create digital artifacts but for a different reason.

    Your use of the term latency in other words is not entirely correct. Your problem was actually fixed by increasing the latency.
     

Share This Page