1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

How to hook up mixer/interface to Pro Tools 10???

Discussion in 'Pro Tools' started by caseysharp94, May 14, 2013.

  1. caseysharp94

    caseysharp94 Active Member

    Hey everybody! I've never posted on here before so not real sure what to expect...

    I work with Pro Tools constantly in school, but am having the biggest problem trying to get PT to recognize this interface. I have a Behringer X1204 USB Mixer/Interface. My question is, is this even compatible with PT? If so, how do I go about setting it up?

    What I've tried - (Ive tried all of this with and without the ASIO4ALL Driver) I have my interface plugged in and when I open PT, I go to setup and it's automatically set to ASIO4ALL v2. Then I go to the Playback Engine and the only choice it gives me is ASIO4ALL v2. Then I go to I/O setup, and it ins and outs are set to HD Audio input 1-2 and output 1-2. This is what I have on my laptop, not the mixer that I'm using.

    Thank you so much for the help!!!
     
  2. havana

    havana Active Member

    Hi caseysharp94,

    Protools will only communicate through asio drivers in windows so what you need to do is click on the asio4all icon at the bottom right side of your windows taskbar. The asio4all window will open up with all your audio devices listed. Choose your x1204 usb mixer and make sure you deselect all other devices. Asio4all should remember your settings so next time you launch protools you wont have to reset anything. Thats it!
     
  3. caseysharp94

    caseysharp94 Active Member

    Hi havana!

    I did what you said, but still cant get the I/O settings right... It's still trying to use HD Audio input 1-2 and output 1-2. But when I open the ASIO4ALL window to pick my hardware that is being used, it says the USB audio codec is active.... I'm not sure what else to try...

    Any help from here would be greatly appreciated!
     
  4. havana

    havana Active Member

    protools9.jpg Try pressing the Default button on left side then select your Default Output bus on right hand side.
     
  5. caseysharp94

    caseysharp94 Active Member

    Awesome! That worked perfectly! Thank you so much for the help!
     

Share This Page