1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

Hum Akg c1000s

Discussion in 'Pro Audio Equipment' started by djkandi, Apr 30, 2009.

  1. djkandi

    djkandi Guest

    Hello,

    I have a pair of AKG C1000s with which one of them has a hum. I've tried different cables and different inputs, but the hum is still there.

    Any suggestions?
    Thanks
     
  2. Codemonkey

    Codemonkey Well-Known Member

    Always on the same mic? And only on that mic?

    If so, I'd call it a loose connection inside the mic (or on the connector).
     
  3. djkandi

    djkandi Guest

    Thanks for the reply.

    Yeah its always on the same mic and only that mic. The head does look slightly skewiff compared to the non humming mic.

    Is it best to send it to AKG too look at or could i fix it myself?
    Thanks
     
  4. dvdhawk

    dvdhawk Well-Known Member

    One thing I'd check is the battery tabs, make sure they're clean and both making firm contact if there is a battery present. If you're using phantom power take the battery out. On rare occasions I have seen phantom power interact with the battery in a bad way when they don't make good contact.

    They have a 3 year warranty - any chance they're covered?

    The C1000 is obviously made to screw apart to change batteries and filters, make sure something didn't get pulled or crimped inside. The good news is, you've got a perfectly good unit to compare it to.

    If you don't see anything out of the ordinary, I'd take it to the dealer - unless you've fixed mics before. As a rule, mics are deliberately difficult to take apart and usually use rather small wires inside that are none too long - not for the average DIY type. Odds are you may do more damage just trying to get it apart.
     

Share This Page