1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

I'm trying to record Windows GM Sounds and nothing lets me!

Discussion in 'Recording' started by ulrichburke, Feb 1, 2009.

  1. ulrichburke

    ulrichburke Active Member

    Dear Anyone.

    I've got 1GIG Ram, AMD Sempron processor, ASUS Asrock motherboard, M-Audio Audiophile 2496 Soundcard. I DO have a perfectly legal copy of Cubase 4 (dongle a-go-go!!) but when I look at it I feel like Buzz Lightyear trying to fly the Starship Enterprise. I'm getting lessons in it from next week anyway, so I was just trying to write a couple of tunes using Windows GM sounds, to prove to the teacher I can write music! (He's asked us to bring in a couple of examples of the music we write.)

    And I can't make them record as soundfiles.

    I'm using a notation program to put all the notes in with - Voyetra Music Maestro. I can hear all sounds perfectly. I can also hear MP3s/DVDs etc., perfectly. Problem is, none of the recording programs can! They come up with empty files every time. I've got all the sliders on the M-Audio on full. I've tried playing a downloaded MP3 and clicking on RECORD on everything, still only get blank files. The paragraph after next is full of abbreviations, I don't know what the heck any of them mean, it's just what the things in the software are labelled.

    Here's a list of everything I've tried and all the error messages I've got. I don't understand any of them, someone here might? I hope!?!

    I've tried using MP3myMP3, NCH Wavepad, Mixpad, Audigy and Windows Movie Maker. Now the sound slider in Windows Movie Maker, labelled Line In, is greyed out - I can't turn the volume up. MP3myMP3 won't let me turn EITHER of its volume sliders up - you drag them, the numbers go up, you let the mouse go, they both slide straight back down to zero again. The turning up doesn't 'stick'. And the only source you're allowed to use is 'line in' - you click on 'wave' and it comes up 'Unknown Device'.

    So I downloaded Power Mixer, because I read somewhere you could use it as a diagnostic tool. Under M-Audio Delta AP 1/2, the Volume Control is greyed out and doesn't work. Under M-Audio Delta AP S/PDIF, the Volume Control is also greyed out and doesn't work. SPDIF Interface, a separate Recording Control in a tab by itself, a Wave control in a tab by itself and, under M-Audio Delta AP Monitor Mixer, the Recording Control button there, all the above are greyed out (have blue crosses next to them!) and don't work. I have no idea why, or much idea of what all the different bunches of letters mean - I think I can write the actual music, the techie side is KILLING me right now!!

    I've tried 3 different versions of the M-Audio driver, the above remains EXACTLY the same in all cases.

    If it's any help, when I go into Start/Accessories/Entertainment/Volume control, all the sliders are on Max. All the sliders I can find in the M-Audio control panel are also on Max! But there are only THREE sliders on evidence in the Accessories volume control and, from the dim and distant vaults of my memory, I'm sure I remember seeing FIVE sliders but I can't remember what the other two were, sorry. Maybe it's those two hidden sliders that need turning up - but I can't find them!

    Nobody on other forums has been able to help with this - please, somebody, help me out! I've only got 10 days before I have to turn up at class with a couple of pieces recorded.

    Pathetic, no?

    Yours hopefully

    ulrichburke.
     
  2. Let me clarify: You're trying to record sounds already on your computer through the M-Audio 2496? A weird question, I must admit. If I understand what you're trying to get at you'd need an output from your computer to go to an input on the 2496 then back to the computer.
     
  3. ulrichburke

    ulrichburke Active Member

    I've written pieces using the onboard GM Windows sounds, because we were told to take a couple of examples of the kind of music we write to our first class. I can't 'get' how to use Cubase - that's why I'm going to the classes - so I've output the MIDI files I've created through the WindowsXP built-in GM sounds - they're bad, but at least they make noises!

    But I can't take in the MIDI files, I have to take in MP3s. So I have to record the sounds being output in response to the MIDI file I've created as a sound file, so I can convert it to an MP3 and take it into class. In other words, I need to find a 'what you hear' setting that actually works!

    Now on my last soundcard, Soundblaster Live 5.1, it was easy, it HAD a 'what you hear' setting. So I just chose it and recorded MIDI files using the sounds on the Soundblaster (which are better than the ones on the Windows Synth!) This one doesn't! And I don't understand why controls and stuff are coming up as unavailable all over the place.

    Please, if you know the answer to all of this, tell me so I can record a couple of bad music MP3s to take to class!!

    yours hopefully

    ulrichburke
     
  4. Space

    Space Well-Known Member

    I appreciate all the information. It may be too much of the wrong kind, but, information matters.

    So if Cubase isn't being used...what, in particular, are you using for recording software. I wouldn't need a list of what you have tried...just pick one that you use right now, one.

    (forum reminder: you post would be better suited here http://recording.org/forum-53.html)

    I would suggest taking the sound card out of the machine and moving it over one pci space and re-installing it. That is a good idea for you. I must ask that you have to slow down in your expectation.

    Pushing buttons and playing this and signing that then moving cards around can have a way of coming back on you. So take care to do the one step, check for improvement, move to next step, check for improvement, etc.

    If you have on board sound this may need to be disabled at the BIOS level. This is going to take away the little "speaker" icon. But there can be conflict between the two sound cards, if there are in fact two sound cards.


    Then I would look into the Music Maestro software and see if it has a "EXPORT" function on the menu. If it does, then select that for the file you are trying to get record as audio.

    Once you have exported the song from Music Maestro, you have to import that midi file into the recording software, whatever that may be.

    If you can get this far then you may be able to have your demo for the class room. If not or if none of it works, let's try something else, maybe from the perspective of another user.
     
  5. hueseph

    hueseph Well-Known Member

    Great advice from space there. Also, make sure youdownload the latest driver from M-Audio's site. Make sure you set the right ASIO in cubase. Make sure your audio settings in windows are set appropriately.
     
  6. ulrichburke

    ulrichburke Active Member

    Dear hueseph and Space.

    For starters - hueseph, what the heck's ASIO? Apart from being another bunch of letters I've never heard of in my life? Every time I think I've at least heard of everything to do with sound recording, even if I don't understand most of it (relevant to this soundcard, anyway!) someone bungs something else at me!

    Dumbass question number 2. What would be the point of setting this mysterious ASIO in Cubase, as I'm not using Cubase yet? Just to get it ready for when the class starts (if that sounds facetious or anything, it's NOT supposed to - I'm not going to touch Cubase until the teacher tells me what to do with it, I've been batting my head against Cubase, Kontakt, Reason, you name it, ever since I discovered I could write tunes. So far they've won every round, they sit there sniggering at me and I've sworn off them until a teacher shows me how to use them. I've yet to get a SQUEAK out of Cubase, Reason plays EVERYTHING on 127 no matter what you set velocity/volume etc. on to, as does Kontakt. But that's not relevant to this - or it might be, what do I know! - I'm just letting off steam a bit.)

    I turned off the soundchip in BIOS before I installed the soundcard. I've only got two PCI slots on the motherboard and I've tried both of them. No difference. You can hear everything, you can't record anything.

    I have only one soundcard, the M-Audio Audiophile 2496, I'm sorry if I've wrongly intimated I have 2. The old one, the Soundblaster Live 5.1, was a WHILE back and is now part of history - I don't possess it any more. I wish I did, I actually UNDERSTOOD that thing!

    If I could wave a magic wand and make ONE recorder work, it would be the NCH Wavepad. It lets you add compression and reverb to the file after you've recorded it, you see. Why not record each instrument seperately, add reverb. etc. to each then record the finished composite? Because unless you start ALL the instruments at once and finish them ALL at once, I find it impossible to line the (censored) things back up again afterwards. If I was doing word-processing, I'd use tabstops to line things up. Unfortunately, none of these music software writers have thought of tabstops, so I don't know how the heck ANYONE lines anything back up. I expect I'll learn in class.

    I was just trying all the others incase there was something out there that actually WORKED!! Export function? Well, there's a button in Music Maestro that's supposed to record what you've written. Guess what. It doesn't record anything either. Surprised? I'm not! That's why I downloaded NCH Wavepad!!

    Everything was fine until I was told I needed a more professional soundcard, so I flogged the Soundblaster to get money towards the M-Audio. What a mistake THAT'S turning out to be.

    Thanks for your help thus far. At this rate, if I get any new stuff recorded before class starts it'll be by pointing a cassette recorder's mike at the loudspeaker very early in the morning, before the other flats wake up, then importing from that as a soundfile. If this card lets me do that, that is. I've thought of that, haven't tried it yet.

    Sorry if I sound a leetle frustrated!

    Yours respectfully

    ulrichburke
     
  7. ulrichburke

    ulrichburke Active Member

    Sorry, Hueseph, just noticed something else in your post I should have answered.

    When I click on the Windows Audio Settings in Start/All Programs/Accessories/Entertainment, I get THREE sliders. Now from somewhere in the distant recesses of my memory, I'm sure you should be getting FIVE sliders. There's two that only show themselves if you tick a box somewheres in the dim recesses of Windows. And I can't remember where that box is. Just can't find it.

    If you know where the box is that you tick to bring up the other two sliders, please, please tell me! I've been trying different Googles all afternoon but I haven't managed to find this back out yet.

    Also, the M-Audio control panel seems to take over from the Windows sounds control panel a bit, but that's not why the other two sliders aren't there, I've uninstalled the M-Audio (without turning the soundchip back on in Bios, this is true) but the other two sliders don't turn up when M-Audio is uninstalled. Hence the hunt for the mysterious box to tick!

    Yours respectfully

    ulrichburke
     
  8. Space

    Space Well-Known Member

    "When I click on the Windows Audio Settings in Start/All Programs/Accessories/Entertainment, I get THREE sliders. Now from somewhere in the distant recesses of my memory, I'm sure you should be getting FIVE sliders."


    Once this software is open; Select OPTIONS>PROPERTIES
     
  9. hueseph

    hueseph Well-Known Member

    What space said. Also, you need to make sure that the 2496 is your default recording device.
     
  10. ulrichburke

    ulrichburke Active Member

    Done that. The Properties panel in the Entertainment Volume Control has 3 things in it - Adjust volume for Playback, Recording and Other. Playback shows Wave, SW/Synth and CD Player, all ticked. Just those three, no options for any others.

    Recording just comes up blank. Empty white window. No controls there at all. Which is what I think everything's trying to tell me! Or am I wrong?

    Other lets me choose between Recording Control and Wave. Recording Control is blank, empty white window. As is Wave.

    The Mixer device is M-Audio Delta AP S/PDIF. There are other options in the box - all prefaced by M-Audio Delta AP - 1/2, MonMixer and Multi. None of them show any volume controls in Recording. Just the empty white window. Mon Mixer doesn't show any controls in Playback either. All the others do.

    That's where I thought the two missing sliders would be, but they just are not there.

    I know I'm being a pain. Anyone got any more ideas?

    Yours hopefully

    ulrichburke
     
  11. hueseph

    hueseph Well-Known Member

    Uninstall the card. Turn off your computer and make sure that the card is seated properly. Then turn on your computer. Windows should automatically recognize the card. If it doesn't, there is a problem. You took precautions against static right? Cancel window's installation and install the drivers directly from the file you downloaded from M-Audio.
     
  12. Space

    Space Well-Known Member

    Then, read the manual.
     
  13. xMannequiNx

    xMannequiNx Guest

    did you set up your vst connections in cubase? tools->vst connections->add bus->stereo->choose the two hardware devices you want to output to.

    if your trying to compose with windows sounds that are allready wavs or mp3s then why do all that extra stuff when you can just drag the audio files into cubase and compose them there?
     
  14. hueseph

    hueseph Well-Known Member

    http://www.m-audio.com
     
  15. IIRs

    IIRs Well-Known Member

    What software are you using to record the audio? I suggest you keep it simple for now and use windows sound recorder:

    Start menu -> Programs -> Accessories -> Entertainment -> Sound Recorder

    Now go to the Edit menu -> Audio Properties: set the Sound recording field to your soundcard's 'Monitor' output. (This is the output of the 2496's internal mixer, and is the equivalent of the 'what you hear' option on your old Soundblaster).

    Does that work?
     
  16. ulrichburke

    ulrichburke Active Member

    Dear Mannequin. I wish I could, but I can't wrap my head...

    ...around Cubase, hence the need for the course!

    I know this will sound pathetic to you because you're an expert, but I've been trying to wrap my head around Cubase ever since I spent wads of money on the thing, and I feel like a caveman trying to fly the Space Shuttle! Cubase is, at present, a complete frustration to me. I've got a whole bunch of sounds that have come with it, but I can't make any of them make any noise. I've set up the ASIO and everything like you kind people told me how to, Windows sounds make noise (but faintly!) but nothing else seems to want to.

    I just wanted to record a couple of crappy pieces using the stuff I actually CAN use properly so the teacher knows I'm not there on false pretences. I feel very dumb already as I seem to be the only person in the group who hasn't been using Cubase for ages. I could use the Commodore version well, but this PC version is a whole new beastie and I don't know what the heck's going on with any of it.

    I've got Reason 4 as well and that's even MORE frustrating! THAT thing won't even obey MIDI numbers. It doesn't matter what you put in, it plays everything on 127. Velocity/Attack, Volume, the lot, all stay on 127 no matter what other numbers you try to change it to. Doesn't matter what you slide, what you turn, what you look up, everything stays on 127. Unless you put velocity on zero, then everything goes silent. Put Velocity on 1 - not 127, just 1 - and EVERYTHING goes back to 127 again.

    I really, really wish I knew HOW to drag sounds into Cubase and make them play properly, but I just can't make it happen. Yes, I've read the books that come with it like a vicar reads a Bible. I know what SHOULD be happening. But when I follow the instructions, I either get no sounds at all (from any of the so-called Hallion built-in sounds) or only very, very quiet sounds (from the Windows sounds, with all the Cubase volume controls I can find on full blast). It's like trying to hear a distant radio station on an old radio set.

    When I try using all the Hallion sounds, I get lots of pretty lights flashing all over the place, but no noise coming out! I really wish I knew why, I've followed the text-books, but I don't. THAT'S why I'm trying to use Music Maestro to record a few pieces. It's the only piece of software that plays ball with me right now.

    Yep, pathetic, isn't it.

    Yours sadly

    ulrichburke.
     
  17. Codemonkey

    Codemonkey Well-Known Member

    *jumps on the bandwagon*

    What you want to do is turn an existing MIDI file into an audio file?

    I would, err...
    Can you just import the MIDI file onto a track in Cubase and then play that?
    I don't use Cubase, so in fact, I'll get off this bandwagon.
     
  18. ulrichburke

    ulrichburke Active Member

    Dear Codemonkey. I would if I could make Cubase work!!

    Dear Codemonkey.

    The whole reason I'm doing this ridiculous Windows sound thang, is that I can't make Cubase DO anything. That's why I'm going on the course. Right now, in spite of having read all the textbooks, it just sits there, sniggers at me and won't let me use any of its sounds properly.

    But the course master wants me to take in a couple of soundfiles, so I've written a couple using Windows sounds, because I can actually USE those! They're 'opeless, limited, but at least they're controllable. I just can't record them! I've got 4 programs that say 'WE RECORD EVERYTHING YOU CAN HEAR' but they only come up with empty files. That's the bit I don't understand. Presumably the people who wrote the programs tested them, so I'm assuming it's not the software's fault. I just don't know how to make my M-Audio Audiophile 2496 let them record the sounds!

    Can you help?

    Yours hopefully

    ulrichburke
     
  19. hueseph

    hueseph Well-Known Member

    The manual is full of step by step instructions. Don't get flustered by what looks like a lot of information. Go to the index. Look up midi in the getting started manual and follow the steps. It would be best though to start from page one which explains the basic setup which you will only have to do once.
     
  20. IIRs

    IIRs Well-Known Member

    Did you try this yet?
     

Share This Page