1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

Issues with my mixer

Discussion in 'Recording' started by happydrummer1, Apr 25, 2007.

  1. happydrummer1

    happydrummer1 Active Member

    I didn't know where to post this, since its more of a "technical help" question and I figured more people knew about mixer issues in this forum than any other...


    I have a crate CSX 12 mixing board, and it has been working great for the last year... I never had any issues with it until I decided to purchuse a Condenser microphone.

    I plugged the mic in, and tried to turn on the phantom power, but for some odd reason the red LED light didn't come on for the phantom power, I thought mabye it was a burnt out light or something like that until I noticed that the blue LED light on my mic wasn't coming on either...

    So I fiddled around with it for a bit trying to figure out what was wrong, and decided to take it back to the store (both the mic and mixer) to determin what was wrong.
    They tested it out and again were stumped as to why the phantom power was not turning on...

    I have turned the phantom power on once (to see if it worked) and it worked fine, the red LED light came on, but that was a year ago (i turned it off don't worry about that) but now it won't even come on...

    So the store also tried a different condenser mic to see if it was mabye the mic and that failed too...

    They gave me a website to visit, and a phone number to call (crate support or something like that)

    But Im wondering if this is mabye an issue with a fuse (I dunno I lack knowledge of whether or not a mixer would have a fuse)
    does the crate CSX 12 have a fuse for its phantom power?
    or is the wireing messed up or is it defective?

    Like I said I used phantom power once to see if it worked, and I have never abused the thing, I keep it clean, and in an almost dust free environment...

    Can anyone help me or am I doomed to waiting a few months for crate to get off there behinds and help me?

    Thanks
     
  2. Boswell

    Boswell Moderator Distinguished Member

    You don't say whether the PP light comes on now without a mic cable plugged in. If it does, try plugging in the XLR mic cable without the mic connected to the other end. It's just that you might have a faulty cable.

    If the PP is OK with a cable but no mic and then goes off when you have a mic connected, I think you have a problem with the phantom power supply in the mixer.

    Don't attempt to connect the mic to the mixer with the phantom power enabled. Always connect the mic and then switch the PP on.
     
  3. happydrummer1

    happydrummer1 Active Member

    I knew that... lol


    It doesn't come on regardless if I have the cable without the mic, the cable with the mic, or even without a cable...

    Tech support still hasn't gotten back to me either...
    How long do they normally take?
     
  4. dementedchord

    dementedchord Well-Known Member

    hard to say how long before they'll get back to you... crate has been swallowed up with mackie and some others by loud tehnologies... however any halfassed tech should be able to deal with this... there's no big deal to it...
     
  5. happydrummer1

    happydrummer1 Active Member

    Yea... I figured any "half-assed" tech should be able to fix it...

    the problem is I don't want to wait 3 months for a stupid little repair that if I knew what to do I could probably fix it...


    is there anything online that could help me (IE how to open the mixing board, inside pictures... ETC) I have a wiring diagram but its not really helping me any...

    not only that Im not sure if I void my warrenty if I do open it
     
  6. dementedchord

    dementedchord Well-Known Member

    warrenty is void if opened by anyone other than a n authorized tech... sorry...
     
  7. happydrummer1

    happydrummer1 Active Member

    Ok good thing I havn't done that yet

    Im on the phone now with mackie equipment,

    man I have been on hold for more than 10 minutes now, my phones about to die soon too!!
    oh and theres a site I can go, to request a replacement, should I just do that?
     
  8. Boswell

    Boswell Moderator Distinguished Member

    If it's more than a year old, it doesn't sound like a warranty replacement job.
     
  9. happydrummer1

    happydrummer1 Active Member

    Well, the guy over the phone told me to fill out a form to request a "replacement" its not actually a replacement, they send me a new mixer and take the old one away...

    I filled it out and they havn't told me that its the wrong thing to do, because I can't open it without voiding my warrenty, the store I bought it at, won't replace it, or fix it, and theres a huge waiting list at the shop that repairs Crate audio equipment, im not waiting 5 months to get something stupid repaired...

    I filled the sheet out, I hope that I don't have this stupid problem again... things shouldn't just stop working!
     
  10. happydrummer1

    happydrummer1 Active Member

    Ok so Im in the good now, thanks for your help though...

    they are sending me a replacement mixer, though its not a crate mixer, they are sending me a mackie MKII 12

    how is that mixer compared to my crate?
     

Share This Page