1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

keyboard controller delay - latency or key sensitivity? (reason 5.0)

Discussion in 'Reason' started by jbourne84, Nov 12, 2013.

  1. jbourne84

    jbourne84 Active Member

    Sep 9, 2010
    Win 7
    sonar x.1
    reason 5
    focusrite scarlet 2i2 (usb 2.0 sound card)
    Evolution MK-249C USB keyboard controller
    M-Audio Keystation 49e USB keyboard controller

    Starting with the MK-249c, I am trying to record over a mix ive put together but am experiencing a delay between hitting the key and getting the sound through reason (was running it as a softsynth through sonar, but to simplify my troubleshooting i am just running reason). After adjusting latencys, trying new ASIO drivers (asio4all) and resetting just about everything my thinking was that its the keyboard, the MK-249c is used but new to me.
    I found out how to adjust the velocity curve/key sensitivity on the keyboard but it still seems that the point i get sound is too far down in the key-stroke. As in, even at the highest sensitivity, I have to push the key down about 25% of its total 'travel' before i hear the sound, the delay is enough that i cannot play along with the song and find myself trying to compensate for it.
    Thinking that it was the controller, I tried an M-Audio Keystation 49e and though it was slightly better i still experienced a similar delay.

    Could this still be the controller or is it likely there is a setting or adjustment i can make on the computer or within the software?
  2. kmetal

    kmetal Kyle P. Gushue Resource Member

    Jul 21, 2009
    Boston, Massachusetts
    Home Page:
    do you have the latest drivers for the keyboard device? also i think sample rate effects latecney in reason, or it did in 'adaptded 3.0' when i messed w/ it. if i remember corectly, it was like 12 or 10ms for 44.1 like 7 for 96, and like 3 for 192. or maybe it was 3 or 5 for 96k. so i think besides your aisio(soundcard settings) sample rate, buffers are the only settings that really effect latency in reason on it's own. maybe the high resolution sample playback has to do w/ touch response, it';s worth a try.

    if both controllers are similar, it sounds like either a driver issue, or a settings issue, in the software. i've use a cheapo korg k49 controller w/ reason adapted 3 and i found settings that had no interfering amount of latency, just as fast as any other keyboard i've used. if you were constantly maxing out your velocities, or experiencing un-smooth crecendos i'd say look at the sensitivity, but to i really think it's a buffer setting of some sort, it sounds like latency, not sensitivity to me.

    reason (used to and might still) have a pretty straightforward preferences menu where you could address this stuff. i think if you get all the relative settings on the same wavelength, you'll experience better performance. so in this case your soundcard, software, and keyboard driver settings (if there is such a thing) should all read the same sample rate, and buffer. some do it automatically, some dont. but i think thats around the first step to getting this better.
  3. hueseph

    hueseph Distinguished Member

    Oct 31, 2005
    Vancouver, BC, Canada
    Have you got Sonar's engine in ASIO mode? You will see the Focusrite as your device but that does not mean that Sonar's engine is in ASIO mode.

    Edit/Preferences/Audio/Playback and Recording/Driver Mode = ASIO.

Share This Page