1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

Korg MS 2000 troubleshooting

Discussion in 'Electronic Repair Modifications DIY' started by joaquin, Dec 10, 2014.

  1. joaquin

    joaquin Active Member

    Bought a used Korg MS2000. Half the programs works fine, but in half of the programs most of the keys are silent. Any suggestions?
     
  2. DonnyThompson

    DonnyThompson Distinguished Member

    Are you referring to sounds? If so, they are referred to as "patches" "samples" or "presets", not programs.

    Being that it's used, it could be that some of the factory presets/patches have been dumped somewhere along the way.

    Do you have a manual for it?
     
  3. DonnyThompson

    DonnyThompson Distinguished Member

    http://soundprogramming.net/manuals/Korg_MS2000_Manual.pdf
     
  4. Makzimia

    Makzimia Active Member

    Something to check if patches were gone, is, see if the battery needs replacing. Common issue in 10 year old synths. There will be a watch style battery inside that helps keep programming in place when turned off. In my Kurzweil it actually uses AA or AAA batteries. And as Donny posted manual, or you can go to YouTube and watch how to make some too.
     
  5. joaquin

    joaquin Active Member



    Thanks a bunch for reply; appreciated !

    Yes, Im talking about the presets.
    In the "Mg bass" presets all the keys works fine.
    But in all of the other preset-banks the first 5-6 keys from left works, then some 6-7 "dead" keys, another 5-6 fine keys, then more "dead" keys.
    I've tried resetting to factory setting by holding down on /off ( mod secuence) and pitch #3 similtanously while turning on the power.
    All i get is is : MIDI LOOP check TimeOut ERR! accompanied by feedback sound.

    Sorry if explain this badly, but I'm kind of new to synths.

    i really appreciate you taking time for this.

    So if you understood any of this, thanks for all help in advance
     
  6. MrEase

    MrEase Active Member

    I haven't checked the manual but the MIDI loop test will require a MIDI lead from the MIDI out to the MIDI In. If this test fails then the unit may not go on to test other parts properly. Check the manual to see if there are any other tests you could do.

    The fact that some preset's work on all keys but others have gaps indicates that the patches have somehow been corrupted (and that the keyboard itself is OK). Again check the manual to see if there is any way to restore the factory preset's. If this all fails then you may need to find someone with direct experience of repairing the keyboard. I have a friend who, some time ago, worked in a repair shop. If all else fails I could try asking him if he's familiar with the problem as I need to get in touch with him sometime anyway!
     
  7. DonnyThompson

    DonnyThompson Distinguished Member

    I'm wondering if perhaps the battery needs replaced..

    Although most synths will give an error code upon boot-up saying as such.

    I think it's time to have this serviced - by someone who specializes in synth repair.
     
  8. MrEase

    MrEase Active Member

    The battery is only for holding memory when the power is off so I think there is another problem here. You're probably right that the battery needs to be replaced but, with the power on, a full factory reset should restore everything properly even if it all goes wrong after a power down. I agree that the whole thing may need a specialist service but making sure the reset completes (by fitting a MIDI loopback lead) will, with some luck, get things going.
     
    DonnyAir likes this.

Share This Page