1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

latency with outboard gear

Discussion in 'Recording' started by opie, Sep 25, 2004.

  1. opie

    opie Guest

    i have pro tools 002 rack and would like to be able to use a outboard compressor and reverb unit i have in my mixes. when i send the track(s) out and back in thru these units, i get a delay. the only thing that i can think to solve this problem is to record these tracks coming back in and then try and shift them to line up with the rest of the mix (or get a outboard mixer, but the 002 has only 8 analouge outs). i'm hoping that there is another way to correct this problem, because i would like to be able to make real time adjustments with outboard while mixing. also, what is a good starting point sample-wise to shift a d.i. track to line it up with one that was miked. i'm new to recording and any help would be greatly appreciated. :D thanks
     
  2. inLoco

    inLoco Active Member

    it's the clock...
     
  3. opie

    opie Guest

    thanks inloco. can i adjust it or do i have to live with it?
     
  4. inLoco

    inLoco Active Member

    there are a lot of companies out there that have master clock generators and alike! but i think the problem in your case is you have to assign the clock to the 002r...
    go to the digidesign site and i'm sure they have there the way to sync your gear!
     
  5. opie

    opie Guest

    actually i'm not sure this applies to me because the outboard gear that i'm talking about is analog not digital, so there isn't anything to sync to. am i wrong?
     
  6. kevinwhitect

    kevinwhitect Active Member

    You're right Opie. There is no clock to sync to w/ analog gear. What you are experiencing is direct latency from the digital hardware. From your description, it's the most likely source. You SHOULD be able to improve your latency via the host software, but not being an 002 user, I have no idea to tell you where to look.

    This info should be readily available via the manual and/or help.

    The tradeoff w/ latency is CPU usage. Low latency=high CPU demand.

    Many manufacturers allow you to listen/monitor the inputs directly...which results in 0 latency. Does the 002 have such capabilities?

    For if you listen to the inputs THROUGH the host software, then you will experience some form of latency. If you can bypass the host software and tap directly into the hardware then latency will improve dramatically. Hopefully I'll be able to sketch a quick diagram here to illustrate what I mean:

    Hardware (feeds) ---> Host Software ---> Listen here:Latency occurs
    l
    l
    V
    Monitoring direct = No latency

    Hopefully this will put you on the right path to your answer. Your best bet is to search the manuals for the answer.

    If you refer to the diagram above, the hardware immediately feeds the host software...it's a direct connect and there should be NO latency when recording on the way in from the hardware. So my best guess is that the host software is recording EXACTLY what it's getting from the analog unit...so therefore the latency is likely occuring ON THE WAY OUT to the effects unit.

    Again--refer to the above simple diagram. Do you have the host program sending the signal directly to the hardware outputs on the 002 (thus sending the signal immediately to the effects unit? Or do you have it routed out "funny" (listening THROUGH the software)...causing the latency to occur.

    Best of luck-

    Kev.
     
  7. opie

    opie Guest

    thanks for your response kevin! i believe you can monitor the inputs only, but i think only during tracking. i tried a few monitor input options with in pro tools and none seemed to help. there is a low latency mode but the lit. with pro tools seems to indicate that it is meant for tracking. i tried it but with very limited sucess. i thought about what you said about whether host is feeding the inputs or the software is and think it is the later and as of yet i have not figured out if i have the option of the former. if not i will be disappointed because i really wanted to use outboard gear while mixing and be able to bounce mixes down with it. i really appreciate you taking the time to respond. your info is very helpful.
    if anyone has anything more to add, i'd love to hear it.
    thanks :D
     
  8. guitarinfo

    guitarinfo Guest

    There is another solution unless PT has its own soundcard and does not need an external one. (sorry but I dont know squat about PT. However if you use a soundcard like most of the DAW's require you may want to look at M-Audio's FW410. The software that runs this excellent soundcard has a feature called "aux send" and much like any aux I/O it is specifically designed for connection to outboard gear and it is precisely how I use it. Zero latency...awesome you can also set up various submixes for Headphones, singers when tracking and more.
     
  9. kevinwhitect

    kevinwhitect Active Member

    Curious. It shouldn't be restricted only while tracking(?). That's a little odd.

    Try this Opie: Route all your recorded channels to a stereo bus output...use outputs 1/2.

    Make sure that the input of 1/2 does not route through to the output of 1/2 or feedback will screech.

    While listening to 1/2 out, record a dry "something" (guitar -- vocal) through input 3 or 4.

    Monitor that input "direct". Can you play along with the song w/ no latency? Is there a difference between what you're hearing going out and what you're hearing coming in (REMEMBER- figure out how to monitor the DIRECT INPUTS --like you mentioned you could-- of the hardware unit) .

    Listen back to the newly recorded track w/ the prerecorded tracks. Is there any delay problems?

    There shouldn't be. Post your results.

    Kev.
     
  10. opie

    opie Guest

    hey, thanks again for responding. that's a good suggestion, guitarinfo, but yes my pt hardware has it's own soundcard. kevin, i think i was wrong about monitoring inputs only during trackings, however i believe that i may have not been clear in my question.

    i don't have a problem with latency when i am recording or overdubbing. the low latency option that i was talking about earlier seems to do a nice job with that. my problem occurs when i mix a song. say i want to use an outboard compressor on a bass track instead of a stock plugin. i set up a send from that track to output 1 of my hardware, into the compressor, back into input 1, and route that to an auxillary track. when i solo the tracks together, original and compressed, or bring the compressed track into the mix, there is a delay with the compressed track and the other track(s). however, i tried monitoring just the compressed track, trying to get a sound i thought i was looking for, then using the afore-mentioned signal routing, (minus the aux. track) i recorded the compressed siganl onto a new track. when comparing the wet/dry tracks, i though i might have heard some "phasey-ness" but was other wise pleased. i used the wet track in the mix and was happy, if there were any problems, i didn't notice.

    what i would like to do is to be able to monitor the effected signal and the rest of the tracks together to make compression decisions that work best for the mix as whole and not just whats best for the individual tracks. i think that this might be more important with outboard eq and reverb, where i think parameter adjustments might be more dependant on the rest of the mix. my goal was to over time grow my minicule collection of outboard gear and be as independant from plugins as possible.

    if due to the limits of my computer, software or hardware that i have choosen i can't mix with outboard gear and not have latency, i'll deal with it and work around it. but i can't help but think that there must be some way around this or that i am doing something wrong. i apologize if i wasn't or am not clear. i appreciate your feedback and welcome any more advice/thoughts. thanks for helping out a rookie. :D
     
  11. redrabbit

    redrabbit Active Member

    After recording the wet track,( the one that was routed out of your 'puter, to compressor, then back in) , you can manually move that one back ever so slightly so it aligns with the origional "dry" one. There are ways to find out how much adjustment is needed , though I use Cubase, it should be similar.
    ----This is how I do it, quick explanation. Do a test and record something with a beat on an audio track or just import a drum loop. Then set it up as you already have, having the compressed signal recorded back in on a different track, so they start at the same point(at 0 bars perhaps). Now change your Ruler to read Seconds or Samples, instead of Bars or Beats.

    ----Make sure they are near eachother, one above the other, and zoom WAY, WAY in, and adjust the heights of the Waves so you can see some decent "humps" in them. You will notice that they don't match up, possibly 10ms off. Take any "Snap"setting off, and move the original foreward (drag) until they DO line up. (You can use the "Project Cursor" as sort of a visual guide to help you line things up.)

    ----Now zoom back out and put the cursor at the begining of the moved track (use some sort of "Snap to" tool). The Seconds or Samples will be in your time display. That is your latency ( basicly it is the difference between the two tracks). Every piece of gear will have a different latency, so keep a list handy, and adjust them accordingly as you work. There are easy ways to move a recorded part by #of samples, or in milliseconds, look in your manual.

    ---CubaseSX3 has a new function that does this automatically, but I have SL2. I don't know about PTools. Hope this helps.
     

Share This Page