1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

Lexicon Omega & windows xp... grrrr.

Discussion in 'Recording' started by UuBNijam, Sep 7, 2010.

  1. UuBNijam

    UuBNijam Guest

    I'm tryig to install this Omega on the kids pc and the drivers keep disappearing! anyone have any experience with this? It's an old Dell Dimension 4400 with windows xp. any assistance would be greatly appreciated.
     
  2. hueseph

    hueseph Well-Known Member

    No idea. Have you downloaded the latest drivers? A bit more info might help. Make sure you're not using a hub. try using external power if you have it.
     
  3. UuBNijam

    UuBNijam Guest

    Thanks, yes I've dowloaded the latest drivers and am using internal usb and the supplied power supply.
     
  4. hueseph

    hueseph Well-Known Member

    More info would still be nice. Have you turned off all the power saving options for usb?
     
  5. vttom

    vttom Active Member

    Have you browsed Lexicon's Knowledge Base?

    knowledgebase | Lexicon Pro
     
  6. TheJackAttack

    TheJackAttack Distinguished Member

    If that is the Dimension I am thinking of, it is a psychotic possessed mother board. There was a series right in that era that utilized RDRAM and all of those were loge, temperamental and difficult. And those were their good qualities. I had numerous issues maintaining USB and wireless networked devices that I could never account for. Now generally I am not a Dell hater and have many Dell laptops I work with. That caveat aside, if you find you have one of the versions with the RDRAM motherboard I would quit while you were ahead. There were many good reasons why RDRAM did not take off and was superseded quite quickly by DDR2.
     
  7. UuBNijam

    UuBNijam Guest

    Got itinstalled finally. Had to reset the piece duh... Now it just has this insane amount of hummmmmmmm ?
     
  8. TheJackAttack

    TheJackAttack Distinguished Member

    Two possible solutions. One, plug the computer and all the rest of the sound gear into the same source. Two, get a USB cable with a resister built into it.

    Also, when you are recording or editing, I would unplug any other USB device that are then lying there dormant. They can still cause interference.
     

Share This Page