1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

Logic Pro 10.1 released!

Discussion in 'Logic' started by gdoubleyou, Jan 22, 2015.

  1. gdoubleyou

    gdoubleyou Well-Known Member

    Available at the App Store, requires OSX 10.9 or higher.

    http://www.apple.com/logic-pro/whats-new/
    MAJOR update.

    Also major update for the live performance app Mainstage 3
    http://www.apple.com/mainstage/
     
  2. Makzimia

    Makzimia Active Member

    EWWWW shiny... one thing I do not like seeing, and I truly hope it is not a trend.. any emphasis on EDM... :-/. But hey, look VCA faders, who'd a thunk it??... and lots of other awesome changes!!

    Needless to say, I need to wait to see if it will work 100% with my MCUs.
     
    gdoubleyou likes this.
  3. Makzimia

    Makzimia Active Member

    One of the small?, changes, I LOVE, finally can arrange my plugins how I want them. UAD plugins are particularly annoying in that, whether you have 10 or all of them they are there... now I can move the ones I have into there own category and voila. Used to have it Sonar, not sure how I have lived without it.
     
    gdoubleyou likes this.
  4. Makzimia

    Makzimia Active Member

    I bravely dove in and installed it. Nothing blew up, Mackie MCU Pro, XT Pro and C4 Pro still working fine. Not spent a lot of time in it yet, took me a couple of hours of other updates all up (native instruments, not updated since last year sometime). And tonight is gig night :). It doesn't recognise the RME HDSPe card as an audio device in the new channel settings part, no major surprise I guess.
     
  5. Makzimia

    Makzimia Active Member

    And, I spoke too soon. Studio is now out of commission as far as my MCUs go. No warning, no difference, MCUs all went pair shaped. So much for a bug free patch LOL. What should I expect from modern day programmers... :(
     
  6. gdoubleyou

    gdoubleyou Well-Known Member

    You are braver than me, I'll wait a few weeks.

    I also keep a backup in case I have to revert to the previous version.
     
  7. Makzimia

    Makzimia Active Member

    Not braver, at the moment stupid :0. I wrongly figured something as old as the back end for MCU support should be safe. I am guessing digging in and adding VCA support for one has impacted it. I'll just fly without the MCUs for a while, or figure out how to get back to 10.0.7.
     
  8. Makzimia

    Makzimia Active Member

    New issues I have found in 10.1. Fade tool no longer works within tracks as expected. Fix for that is to use audio editor, then fade works as expected. Also, esc no longer brings up the tools, only T.
     
  9. Makzimia

    Makzimia Active Member

    Further update for those on Mackie MCU controllers. By removing them from Logic Pro X, resetting midi devices, refinding them, then restarting the Mac, it resolves the issue. Whether that is a permanent fix or not, remains to be seen.
     
  10. gdoubleyou

    gdoubleyou Well-Known Member

    Saw the MCU issue at http://www.logicprohelp.com/

    I just upgraded to Mavericks in preparation for 10.1, sort of dangerous while working multiple projects.
     
  11. Makzimia

    Makzimia Active Member

    Well the good news is, other than having to restart the MCU XT Pro a couple of times, when it was idle too long, all is working with MCUs on 10.1 now for me. I suspect this is a core issue. I also suspect it came about after the iOS instrument update.
     
    gdoubleyou likes this.
  12. gdoubleyou

    gdoubleyou Well-Known Member

    Upgraded, no issues so far all projects work so far.
     
  13. Makzimia

    Makzimia Active Member

    10.1.1 came out, new fixes. Display on MCUs is MUCH better.
     
    gdoubleyou likes this.
  14. gdoubleyou

    gdoubleyou Well-Known Member

    Hats off to the Apple Logic team they have been quite responsive with updates.
     

Share This Page