Logic Pro Delay When Software Monitoring Is On

Discussion in 'Mixing & Editing' started by JX21, Nov 30, 2009.

  1. JX21

    JX21 Guest

    I am using Logic Pro and I have enabled Software Monitoring to hear my self singing with some effects on, but I am hearing a delay when I sing. I have tried lowering the Buffer Size and Recording Delay and still the delay does not seem to go away.
  2. line6gigety1

    line6gigety1 Member

    Dec 1, 2009
    hey man new to the forum. i had this problem with my logic too and did some research and its not a computer problem or anything...

    prefrences....audio....general tab.... you will see a box u can check that says low latency mode check that... it turns off a few things but it makes it work how u want it. good luck
  3. ouzo77

    ouzo77 Active Member

    Jan 16, 2006
    Nuremberg, Germany
    Home Page:
    if you lowered the buffer to the minimum, then there might be one or more plugins that introduce the latency.
    do you have compressors, eqs and reverbs on your recording track?
    do you have a brickwall limiter in the master track?

    if one or more of these plugins have an activated lookahead function, then this is the problem.

    either you deactivate those plugins manually or you can activate the low latency mode, as line5gigety1 said. you can activate/deactivate it with the appropriate button on the right side of the transporter bar.
  4. jammster

    jammster Active Member

    Nov 30, 2008
    Lake Ki-Chi-Saga, Minnesota USA
    With Logic Pro a buffer setting of 128 is about as low as you typically can go.

    You may want to do some tests to verify your system can handle a low buffer setting.

    I have half the latency with the higer rates: 88.2+96K,


Share This Page