1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

Mbox 2 Mini Vista SP1 Compatability

Discussion in 'Recording' started by Dreamer, Jul 7, 2008.

  1. Dreamer

    Dreamer Guest

    Hey,

    I was just about to buy the Digidesign Mbox 2 Mini, when I noticed it says that its not compatible with Vista SP1. Now I have Vista Home Premium (32 bit) so thats fine, but I have upgraded to Service Pack 1 .........It says an announcment will be made in March 2008 ? and thats all there is on the website ?

    So does anyone know if its compatible with Vista SP1 yet?
     
  2. hueseph

    hueseph Well-Known Member

    Only Vista Business and Ultimate are supported with the Mbox2 series. No 64 bit OSes are supported. I'm afraid, you are SOL in that. Unfortunately Digi caters to people who don't upgrade for reasons of stability.
     
  3. Dreamer

    Dreamer Guest

    Bugger, looks like no Mbox 2 for me :(
     
  4. hueseph

    hueseph Well-Known Member

    There's other equally nice interfaces out there. Plenty of them nicer even. Check out the Presonus FP10 for around $400-500.
     

Share This Page