1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

Midi channels in protools 6.4

Discussion in 'Pro Tools' started by Trudy, Apr 22, 2005.

  1. Trudy

    Trudy Guest

    Hi browsers & helpers

    I have recently upgraded from OS 9 - protools 5.1.1 to protools 6.4 - OSX - on a G4)

    I have an audio cable connected..from digi001 analog3 to JW-50

    Plus midi out from digi001 to midi in JW-50 and midi in digi001 to midi out JW-50

    I have configured my midi studio to connect to an external device (ie Roland JW-50 keyboard), transmitting & recieving on 16 channels
    Ports = digi001 on port1 and JW-50 on port1

    When I click on test studio it works, but when I import a general midi file the channels defalut to 'none' they will work if I set each one up manually (ie drums = JW-50, Port1,channel 10)

    When I was running Protools 5.1.1 each time I imported a midi file the channels defaulted to the right one (ie drums on channel 10), since the upgrade this is no longer the case they default to 'none', I have been trying to fix the problem for quiet a while now, I would really appreciate any advice.
    Kind Regards
    Trudy
    :D
     
  2. o2x

    o2x Active Member

    This is likely to be the Sysex (System Exlusive) configuaration of PT.

    Have a look at this from the Digi site:

    Pro Tools SYSEX Download

    MIDI Menu
    MIDI THRU OFF (definitely)
    Beat Clock Out off (definitely)
    Input Filters sysex only (optional)
    Input Devices Particular Device Only (optional)

    Operations Menu
    Destructive Record Off
    Loop Playback Off
    Quick Punch Off
    Auto Input On (just in case)

    Setups Menu
    Hardware
    H/W buffer size 1024 Samples (good idea)
    OMS Midi Setup
    Select Run Midi in background (definitely)
    OMS Studio Setup
    unselect use Apple Serial DMA driver when available (definitely)


    Select MIDI Track with Sysex file
    Track View Size Large (optional)
    Track View Sysex (good Idea)
    Track Input Particular Device (shouldn’t matters)
    Track Output particular device (definitely)

    Playback Settings
    Transport Bar
    Locate Transport to Where you want sysex to start from

    Start Midi Data Dump from unit
    watch that LED meter on track should show activity
    verify in Unit that memory has been updated.
     
  3. Trudy

    Trudy Guest

    Thanks for your reply o2x...

    I have checked out my settings as you suggested although I now need to use AMS rather than OMS because I'm using OSX....I emailed my problem to digi design technical support and their reply was as follows:

    -----------
    Hi,
    what you are describing is normal under OS X and Windows XP. I believe it has to do with changes the occurred in QuickTime and the move from AMS to OMS. Under OS 9 .mid files would open with the correct QuickTime musical instrument. Under the newer OSs they open with the outputs set to none.
    Best regards,
    Digidesign Technical Support

    -------------

    This is really bad news for me, considering I use general midi files that I download from the net all the time for learning new songs for live work and recording, It is going to be a real hassle to have to try and work out which instruments to manually channel on each track.

    I did have someone say to me on another forum that their channels defaulted to the right ones each time they imported am idi file and they were going to check their settings, but they haven't got back to me yet.

    I really hope I can find a way around this, otherwise I have wasted a lot of money upgrading my system simply because I brought an ipod which required OSX or later.
    :( [/i][/b]
     
  4. o2x

    o2x Active Member

    A typically 'Helpful' Digidesign response.

    Have you configured all your Midi Devices correctly in AMS??
     
  5. Trudy

    Trudy Guest

    I'm pretty sure I have, I've tried almost everything.

    I have added a new device:
    with;
    PROPERTIES
    Manufacturer = 'Roland'
    Model = JW-50 (this was not on the list I had to manualy put it in)
    Receiving on 16 channels
    Transmitting on 16 channels
    No midi beat clock or time code
    Features = General midi No machine control

    PORTS
    digi001 = port 1
    Roland JW-50 = port 1

    I have midi out from digi 001 into midi in on my keyboard
    and midi in diigi001 to midi out on my keyboard
    + and audio cable from Analong 3 digi to keyboard

    In regard to the midi advice you gave me from from digidesign site, I didnt quiet get the following because I no longer use OMS and I'm yet to find where the DMA driver thing is
    ----------------
    OMS Midi Setup
    Select Run Midi in background (definitely)
    OMS Studio Setup
    unselect use Apple Serial DMA driver when available (definitely)


    Select MIDI Track with Sysex file
    Track View Size Large (optional)
    Track View Sysex (good Idea)
    Track Input Particular Device (shouldn’t matters)
    Track Output particular device (definitely)

    -------
    I did the above but could not work it out)
    --------

    Playback Settings
    Transport Bar
    Locate Transport to Where you want sysex to start from

    Start Midi Data Dump from unit
    watch that LED meter on track should show activity
    verify in Unit that memory has been updated.
    ---------------

    Thanks for getting back to me
     
  6. o2x

    o2x Active Member

    Yeah, the instuctions related more to performing a sysex dump from PT into a MIDI device or vice versa, but the settings should be the same to recieve sysex data in any .mid file. GM files are set up with sysex to kick your kbd/module into GM mode if its not already so. However, seeing as all your midi channels default to none, I realise how much of a pain in the derriere it must be.

    I think that the problem however lies with AMS, this is OS-X's biggest downfall, crap MIDI implementation. If you look at Apple forums there's loads of people with major MIDI probs out there. Not just in PT either, in Logic, Digital Performer - all sorts.

    You may need to make sure that the JW-50 entry in AMS has the appropriate .midnam file associated with it. This is an XML file which lists all of the the patchnames for your kbd. Pro Tools uses this for the patch select function of your midi device.

    You'll probably be able to download the file from the net. Google it ans see what happens. Not sure if it will rectify the problem though. Maybe you could send a stroppy e-mail to Apple tech support to see if they have any ideas??
     

Share This Page