1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

Midi Controller Madness!

Discussion in 'Recording' started by mikemcgibney, Mar 10, 2005.

  1. mikemcgibney

    mikemcgibney Guest

    Hi Everyone!


    I have having huge problems with my music setup. I am using a Casio CTK-691 keyboard as a controller keyboard through a Tascam US-122 into Cubase SX1.

    Here's the problem. Say I have several audio tracks and several midi (e.g. edirol orchestra). If I record a midi line, the very action of playing my keyboard and inputting a midi signal causes EQ's to wildly jump about, levels to shift, and panning to go crazy.

    Basically, after inputting any midi - e.g. piano, I have to reset all panning, levels, EQs etc - which is hugely annoying! Even just tapping the sustain pedal a few times does the same - I see a midi signal going in, and EQs and panning on audio tracks jump about. It can be quite disconcerting to happen mid song, while I'm recording!

    Can anyone perhaps suggest what might be the problem?



    Many thanks in advance!


    Mike
     
  2. yan_b

    yan_b Guest

    one of your devices probably sends midi controller data, and the software recognize it as a mixer control data.
    first make shure that all controllers in device setup are disabled / midi input not connected.

    using midi filters might help if you cant configure your midi devices not to send controller data.
     
  3. mikemcgibney

    mikemcgibney Guest

    Hi, thanks for your response! Could you clarify in a little more detail what parts of the device setup I need to look at. The only things I see activated (marked YES) is my Tascam US122 external soundcard, with which I use midi.

    Plus - midi filters - if you could point me in the direction of where to find/what to do with these, it would be greatly appreciated.
    Thanks again!


    Regards

    Mike
     
  4. yan_b

    yan_b Guest

    midi filters are in files>preferences>midi filters
    in the check box mark controllers.
     
  5. mikemcgibney

    mikemcgibney Guest

    Hi Yan.



    Okay, well I've looked and I'm at a bit of a loss. Here is what I have selected currently. Under RECORD and THRU - i have "sysex" selected on both. On "controller" it is set to BankSel MSB. I have tried to change this to "sustain" but it always goes back to Banksel.


    Any ideas?



    Thanks for your time!



    Regards


    Mike
     
  6. yan_b

    yan_b Guest

    after you select the controller press add, you will see it in the list below, don't forget to use the apply button in the end.

    how ever the preferred solution for your problem should be at the midi source.
     

Share This Page