1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

Midi madness in Sonar

Discussion in 'Sonar' started by lmu2002, Dec 28, 2006.

  1. lmu2002

    lmu2002 Active Member

    I have a problem setting up a guitar pre/effects thingy (Zoom 9030 from 1991). I'm trying to control the Zoom with Sonar 5. Patch changes, that's all. My desktop PC with Yamaha SW1000xg interface works fine with it. But my laptop with Alesis Io2 doesn't. All it does is change the patch to nr 01 every time I stop playback. Nothing else. The MIDI light flashes ok in the Io2. I know there's a good 15 years between the Zoom and Alesis but MIDI is MIDI, right? Any suggestions...
     
  2. Kapt.Krunch

    Kapt.Krunch Well-Known Member

    Hmmmm....

    The same file that works on one computer doesn't work the same on another?

    That would lead me to suspect that something might be set up differently in each computer. Go to "Options">"Project" and make sure everything in the laptop is set up the same as in the desktop...especially in the MIDI options.

    Did you save the file as a simple .MID file when you transferred it, or did you save as a .WRK or .BUN or soemthing else? If it was saved as a simple .MID file, some info affecting performance issues may be missing.

    I am assuming the file was created on the desktop with the Yamaha card?
    Is there an XG reset sysex message at the beginning of the file? If there is, then the Zoom may not respond to it, but would perhaps need a GM reset message instead? That's easy enough to replace.

    FWIW, I always insert a reset message at the beginning of every MIDI file. Then I take the time to make sure all tracks have a program/bank change message, and all the other pan, volume, reverb, etc. messages right before the first note is played on it's respective track.

    That way I know that everything responds the way I want. Sometimes, if you change a patch later on a track, and you don't have these messages, when you start the file again, it plays what was last seen. Sometimes.
    That doesn't sound like what yours is doing, since you say it's doing it when it stops. Look in the event list editor and see if there are any weird controller messages on that track.

    There's something else that is on the tip of my tongue that may cause something like that, but I can't remember what.

    Check all that stuff first, and see if any of it helps. May...may not. Just some 4:30 am thoughts.

    Good luck,

    Kapt.Krunch
     
  3. lmu2002

    lmu2002 Active Member

    Got it!

    Tried everything I could think of. Then I tried another USB port in despaire. That was it! Midi started working like a dream. The laptop mouse works ok in the evil bstrd usb port. I can't believe this...
    Usb is usb, right!? I think I wan't to go back using tapes and other slow but sense-making gear...
     

Share This Page