1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

MIDI on firepod and this keyboard I have

Discussion in 'Recording' started by andrewcubbie, Dec 19, 2006.

  1. andrewcubbie

    andrewcubbie Active Member

    Hello. I'm a bit new to MIDI recording so please go easy on any of my questions but..

    My step-brother has an ol' keyboard a Casio CTK-700 "http://www.zzounds.com/item--CASCTK700" and I was looking to use it for MIDI with Sonar Producer, hooked up to my Firepod's MIDI In.

    When I patch everything up and go to record though, the program receives nothing, the MIDI Input/Output Activity does not flash it's input light to show it's picking up my MIDI signal. What's wrong here? Is it that the keyboard is too crappy to use for MIDI or what?

    I have a 5-pin MIDI wire hooked up to the output of the keyboard into the input of the Firepod.
     
  2. CombatWombat

    CombatWombat Active Member

    You'll need to make sure that Sonar is recognizing the midi input and that it's activated. I don't know how to do that in Sonar though.

    The firepod midi ports are notoriously crappy though.
     
  3. andrewcubbie

    andrewcubbie Active Member

    k

    Alrighty, I'll try and figure that out, anybody else know?
     
  4. Kapt.Krunch

    Kapt.Krunch Well-Known Member

    Find out what MIDI channel the Casio can and is transmitting from. If necessary, change it. (Look in the manual).

    Confirm Sonar recognizes the Firepod as a MIDI device. (Options/MIDI Devices) and choose that.

    You'll need to know what is going to generate the sound, so choose the MIDI soundcard or module in Options/MIDI Devices. If you aren't using a MIDI sound generator, you'll need to load up some virtual instruments or something in the track you are working on. I don't think the Firepod is a MIDI module.

    Arm a track in Sonar for the Firepod MIDI recording enable, and choose the channel that matches what the Casio is transmitting.

    Look around in Options/Project and Options/Global/MIDI to see that everything is good in those.

    Hit "record", bang some keys, and see if it records.

    I'm writing away from my Sonar computer, so this is all from memory. Hopefully, the answer is in there somewhere, although I may have flubbed a thing or two.

    Kapt.Krunch
     

Share This Page