1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

MPX 110/100 FX - need your help !

Discussion in 'Recording' started by gbrand, Oct 8, 2004.

  1. gbrand

    gbrand Guest


    I just bought a MPX 110 FX (Lexicon) for vocal use and have this slightest problem.
    In ALL the presets containing a ROTARY effect (including "Special FX";Variation 5), I see a weird phenomenon:
    When using the "Adjust" knob or "Effects Lvl/Bal" knob,the "Edit" LED flickers (should only light) as if connected to
    some internal oscillator (malfunction?)

    All other presets behave normally...!

    I dig the manual all over and tried to figure out the issue with Lexicon representative, but with no success....
    I'm wondering whether it's something to do with the power supply, electromagnetic inductance or unit malfunction.

    If you still own a MPX 110(or 100, they should be quite similar), can you please help me solve this one out and do this Small/Quick test:
    -select preset "Tremolo/Rotary", variation 12
    -turn the "Adjust" knob and see if the "Edit" LED lights steadily or flickers.

    If not, do you know someone who has (100/110)?
    Can you send me his/her E-mail ?
    It will help me a lot !

    Have a great day,
  2. AudioGaff

    AudioGaff Distinguished Member

    Feb 23, 2001
    Silicon Valley
    I would say if you can't hear a problem, then you don't really have a problem. I suppose it is possible that the flicker is giving you an indication fo how fast your rotary effect is set? In any case, I would look at it as a quicj way to know when you have a rotary preset loaded from a distance.

Share This Page