1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

presonus 22vsl audiobox crackling and popping with midi

Discussion in 'Recording' started by poni618, Nov 1, 2012.

  1. poni618

    poni618 Active Member

    it was always crackling and popping, then i went through presonus's optimization for windows 7 page and it seemed to fix the problem, except when i try using midi (my whole reason for buying the product... sigh..)
    i thought it was just ableton, so i reinstalled, problem persists, then i tried it with samplitude... problem seemed ok, but now i realized its still crackling/ popping just isn't as noticeable.

    any recommendations?
     
  2. RemyRAD

    RemyRAD Well-Known Member

    You're going to have to specify whether you're clicking and popping is from your MIDI track or from your other recorded audio tracks? This is a doctor it hurts when I do this question.

    Every one of these programs sets certain buffers, certain ways. And even then, sometimes those buffers, the amount and the timing of the buffers needs to be increased or decreased. Frequently you decrease the buffers when recording, tracking, overdubbing. You increase the buffers for mixing. This is not always the case with everything however. I haven't heard about this problem from many of the PreSonus product lines? Which may also lead me to believe you may have other programs running in the background that shouldn't be?

    Sometimes it's difficult to combine a DAW, with a general-purpose, Internet, gaming machine. The solution to the problem is called pick one. I have over six computers that are dedicated machines, individually configured for particular applications. I have one laptop that I utilize as a general-purpose machine which has some very specific set of modifications from the average computers most everyone else uses. Such as not having any antivirus software running in the background and other scheduled events. This all needs to be modified from MSconfig, in Start/Run, menu. And not just in the startup tab but also in the services tab. Dynamic disk caching RAM needs to be set to a fixed 1.5 times your maximum solid state RAM, both as minimum and maximum. And your Windows GUI interface should be adjusted for best performance and not best appearance. This will cancel out all of the stupid animated menuing and make your desktop look more like Windows 2000 used to. Because these things are not our toys. They are our tools. Our way of making a living. So proper computer configuration is paramount. And if you're computer games don't work as well as they used to? Oh well. What's more important to you? Making a living with your computer or playing a stupid game? And I think that's a damned simple answer. No guesswork there.

    You are also dealing with reference clocking. And that's where my knowledge of MIDI, ends. Are you using computer VST synthesizers or are you trying to have your MIDI signal play actual performance instruments? You might also be having differences in sample rates and bit depths? Not all programs play well with everything. Some required tight alignment of like sample rates and bit depths. Other programs don't care about that at all. Again you've provided no real specifics for us to help you with.

    I'm quite certain others will be chiming in soon to help you better than I.

    I'm the unfortunate MIDIdiot
    Mx. Remy Ann David
     
  3. poni618

    poni618 Active Member

    i'm using vst's,
    all vst's with midi that i've tried with the 22vsl cause issues,
    as i stated, i've done all the windows 7 optimization reccomended by presonsus

    PreSonus | Articles - Optimizing Windows® Vista and Windows 7 for Music Production

    this includes disabling everything in startup menu/msconfig.
    old school GUI
    and no index page
    high performance

    one thing i'll note, if i have my wireless adaptor turned on, i get the crackling/popping constantly, when i disable it, it goes away except when using midi

    i've ran latency monitor:
    it says my cpu might be throttling, but after reading and searching the internet for 3 hours i have no idea how to mess with my acer aspire notebook's bios, i've tried f2 on start up, but it just brings up basic change menu stuff.
     
  4. BushmasterM4

    BushmasterM4 Active Member

    Wireless adapters AND onboard nic cards cards are the main culprits in noise. I see you disabled the wireless, how about the onboard wired network chips. Just right click them and disable them. Firewalls should be disabled also. I take it your using a usb midi keyboard for midi work ? Try using a different usb port on your laptop (if you have another). Laptops are hit and miss with audio work, more so than desktops and towers. Keep us posted
     
  5. RemyRAD

    RemyRAD Well-Known Member

    You still need an index page a.k.a. disk-based RAM cache. But hey, if you have 16 gigs of RAM you might not need it?

    As you indicated, when you turn off your WiFi, the clicking and popping stops. That's because the WiFi is always searching for networks. And it's interrupting everything you're trying to do. That's the throttling your seeing. And as also suggested, try changing around your USB ports. You also quickly discovering the art of system integration. And it's an art. Just like recording. While everything is supposed to be one-size-fits-all, we've all learned otherwise. And certain interfaces just perform differently with different computers. It's a frustrating and daunting hit and miss, roll the dice crapshoot. And another reason why people migrate towards Macintosh. If you're a computer geek, you can deal with PCs. If not? Macintosh might be a better bet? And many of us have been playing this fun system integration game since the early 1990s if not the mid-1980s. It's almost the same way I have found that building up your own computers can make you quite savvy over a period of years time. Dealing with notebooks is a whole other thing. It's there that some compatibility issues cannot be worked around. It's the way I've discovered that Hewlett-Packard computers have been more quick and responsive in comparison to Dell's, which I find slower and more stable. Great for office work. Even great for video work. They're stable, which can be nice but frustratingly slow. But that too changes every couple of years with the changes in chipsets. There's a reason why ProTools took so long to port over to PCs. That's because their initial window of compatibility was quite narrow. Now it's filled out a bit but not completely. That program is still finicky depending upon the computer that was chosen. And Avid chooses not to do any other R&D on the compatibility of their software with all the computers on the market today. This is just another money pit aspect of the recording business we're all in. It's never-ending and it ain't cheap. Recording studios of yesteryear were only available to the wealthy. Today, everybody and their brother is a recording engineer because they bought a box to plug into their computer with their hacked illegal software. And for those lucky dummies that picked the right computer (by accident) everything works. For you, the honest guy, you might need to try your rig on a different computer? And if all goes well on another machine, try matching those settings to the machine you want to use. Keep going to the task manager on both machines and observing what programs are running. Only then might you find where the culprit lies?

    I never lie.
    Mx. Remy Ann David
     
  6. poni618

    poni618 Active Member

    thanx remy and bush
    i have eliminated as many factors as possible, programs running, etc... and i always disable my wireless adaptor when recording.
    ethernet is always disconnected.
    ive had issues with reinstalling the presonsus drivers, so i dont really want to try a different usb, but if it comes down to it i will.
    like i said, i've ran latency monitor program and it says:

    your system appears to be having trouble handling real-time audio and other tasks. You are likely to experience buffer underruns appearing as drop outs, clicks or pops. One or more DPC routines that belong to a driver running in your system appear to be executing for too long. One problem may be related to power management, disable CPU throttling settings in Control Panel and BIOS setup. Check for BIOS updates.

    so yea, maybe i should reinstall drivers and cross fingers?
    i dont know how access bios on my computer, i hit f2 on start up and it only brings up general things. i've tried to update my bios but i have no idea how to do it.. ahah..sigh.

    i'll be going mac soon, but for now this is what i have to work with.
     
  7. BushmasterM4

    BushmasterM4 Active Member

    Also remember even though a computer should handle it, it doesnt mean it will. Case in point, I build my own pc's, have since the 386 processor days. All my DAW rigs have been built around Gigabyte motherboards. This last upgrade I decided to try an Asus board which was getting great reviews when paired with the i7 2600k cpu. Well,... This combo sucked for DAW use. Noises, glitches, etc... Just terrible. So I boxed up the motherboard, took it back to Micro Center and bought a Gigabyte board. And all my issues went away. And with Macs you need to research cpu/board combos. There are some Apple turds too. :)
     
  8. hueseph

    hueseph Well-Known Member

    Just curious. What are your audio buffers set to? Have you tried raising your buffers? Try 128 or even 256 samples. 128 should be enough though.
     
  9. RemyRAD

    RemyRAD Well-Known Member

    I've always had good results with the ASUS motherboards since I started building my own computers back in 1996. Never tried one of those Gigabyte motherboards? I always wondered about them? Thanks for the tip. Sounds like it's the ticket. The only pre-built desktop PC I own was a giveaway of a Dell, Pentium 4, 3.2 GHz. While it was stable, it was slow as slow could be. So great for office work and enough to tear your hair out with any other application. My 3.0 GHz, Pentium 4 on my ASUS motherboard actually ran quite a bit faster than the 3.2 GHz Dell. But hey it works great for labeling CDs/DVDs, watching movies, even surfing the Internet. But that's about all it's good for. So the performance factor really comes down to motherboards and their associated chipsets more than the CPU & memory. And that it plays nicely with all of the little friends you'll introduce your computer to.

    That error message you posted looks to me to be one of two things? That says perhaps your computer is not a chip off of the old block? I can also indicate some kind of Trojan virus? Or worm. A fishing program? CPUs don't necessarily take up any resources when they're not supposed to be doing anything. Yours is obviously working very hard on something that you don't want to be working on. Have you run a full virus scan, Mal ware scan, cookie cleaning, all that stuff? Cookies and other scheduled items are usually problematic. Check to make sure nothing is running in the scheduler. Applets are usually automatically loaded for Google update, flash update, all sorts of updates, which really have to be eliminated. You don't want the computer to think for you. You want to tell the computer when and what it should think about. And that's nothing on its schedule but instead, on your schedule. So ya cancel all of its scheduled functions. You'll find that in control panels. I hate all of these programs that want to continually check the Internet for current updates to their programs. Some you can't even turn off. I just like my computer to be a lean, mean, audio machine. I want my computer to be dumb just like all those audio engineers practice so hard at being. LOL, like me. I'm dumb enough for any computer to handle, thank you very much.

    I'm proud to be dumber than any computer.
    Mx. Remy Ann David
     
  10. hueseph

    hueseph Well-Known Member

    Usually you press delete to enter bios. What model Acer do you have? That can go a long way to troubleshooting your problems.
     
  11. RemyRAD

    RemyRAD Well-Known Member

    I think I've also found that F8 can also sometimes get you into your bios? You switch the computer on from being off, not from being in standby, while continuously pushing F8 over and over again. While on some of my other machines it's been the F2 button. You have to be able to get to the bios in every computer made since the early 1990s. Earlier than that actually. Sometimes it's just downright frustrating to get to. Try looking up the manufacturer of your motherboard and contact them via e-mail how to get into the bios. This section of the computer is absolutely imperative that you have access to. It's where you set all of its operational conditions. And when you do find the right way, it'll be one of those forehead slapping moments, Geez, that Fxxing easy?! What the...? It's OK, we'll only laugh behind your back.

    He'll get this going right. I can feel it.
    Mx. Remy Ann David
     
  12. kmetal

    kmetal Kyle P. Gushue Well-Known Member

    doesn't it say briefly during start up of windows what the bios hot key is? on my laptop it's f12. i also suggest a different program like reaper, to see if it is just software compatibility, which pt is a culprit of. surely the cpu has to be optomized by disabling the stuff you don't need. i don't build computers, but off the shelf stuff i've used exhibit various performance levels like remy said, they all have some quirks, macs included.
     

Share This Page