1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

Presonus Firepod, CH 3-8 LOW ! Help!

Discussion in 'Recording' started by marsvolta, May 3, 2005.

  1. marsvolta

    marsvolta Guest

    My newly puchased Firepod works pretty great with 1 and 2 channel, but from channel 3 to 8 it feels like the preamp is totally missing. I thought when i bought the Firepod, like it is showed on Presonus' website, that you only need your Firepod, your mic's + cables to record fx. drums directly into the application without any extra hardware such as preamps, but i guess I was wrong ?

    Really hope any of you guys can help me, 'cause if this problem can't be solved, I'm very disappointed.
  2. JBsound

    JBsound Guest

    Call Presonus at 225-216-7887. They are really good about support and if there is something wrong with your firepod they'll help you get it worked out.
  3. marsvolta

    marsvolta Guest


    I was gonig to call them, but just hoped that someone here could help me out first... but, I'll call them...

    What's the Area number for the US?

    I'm from Denmark and has to put a number ahead the phone number !

    Eg. If you call to Denmark it's and the number is 85753215, it'll be
    +45 85753215
  4. JBsound

    JBsound Guest

    I wish I could tell you but I don't know....sorry :cry:
  5. mds

    mds Guest

    They have excellent email support, so that may be eaiser(and cheaper). You should have plenty of gain from the preamps. What mics are you using?

  6. marsvolta

    marsvolta Guest

    Really? Then somethings wrong ! I use the cheapest junk atm., but a few SM58 like mics... I dont think the mic's are the problem, i've tried 4 different, and everyone works in the CH 1-2, and no one works in CH 3-8... it's strange....
  7. Midlandmorgan

    Midlandmorgan Active Member

    Jul 21, 2002
    Are the clip lights coming on when you open the gains up to max? If so, sounds like a problem with the gain structure inside the DAW...
  8. marsvolta

    marsvolta Guest

    No clip lights at all(on 3 - 8 ) !!! Only rarely on CH 1-2...
  9. Midlandmorgan

    Midlandmorgan Active Member

    Jul 21, 2002
    How about with mics needing phantom?

    (Just trying to help...perhaps indeed you got a lemon)
  10. marsvolta

    marsvolta Guest

    Thank you all, problem is solved !

    I of course want to use XLR's instead of jacks when jacks are line's in the 3-8 neutrik channels !

    Your're right, the Presonus email support works brilliant!
  11. Antho

    Antho Guest

    Thats exactly whaty I was going to suggest, as to the best of my knowledge, the Neutrik dual purpose jacks on many products recognise a JACK plug as being a LINE input signal, and an XLR as being a MIC signal.

    Glad you sorted it


Share This Page