1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

Presonus Firestudio 2626 asymmetrical clipping distortion positive side -6dbfs, bad units on Ebay

Discussion in 'Recording' started by David Dwyer, Jan 4, 2016.

  1. David Dwyer

    David Dwyer Active Member

    I wanted to find out if anyone has had a simiar problem with Presonus Firestudio 2626 asymmetrical clipping distortion issues. The positive side only of recorded waveforms clip at -6dbfs on some channels as can be seen and verified in my DAW(Sonar). I have two of these Firestudio 2626 units and one unit has the problem on every analog input channel and my second only has it on only one channel. It appears to be in the A/D conversion for the analog channels because the insert and aux analog outs do not have the asymmetrical ciipping as verified on oscilloscope.

    Very odd to have this exist on both of my units. Both were bought second hand. I have checked other forums and cannot find postings on this problem. Seems that if two different units exibit same issue it's probably a more widespread problem. I would go so far as to warn others from buying these on Ebay as that seems to be the place people dump equipment with hard to find defects.
    Pretty sure this is going to necessitate another expensive Presonus repair
     
  2. Boswell

    Boswell Moderator Distinguished Member

    I've seen power supply issues on those Presonus units where one of the supply rails sinks well below its design level, and that could explain the problem on your first unit where every channel is affected. It's probably a different effect on the second unit where only one channel shows a fault.

    If I had your pair of units open in front of me, I would measure the d.c. rail voltages in the two units. If the +15V rail is low (e.g. around 9V) on the first unit and is OK on the second, I would try swapping the power supplies between the Firestudios to see if that produced one correctly working unit. Without further information and possibly scope pictures, it's more difficult to give a diagnosis for the channel fault seen on the second unit.
     
  3. David Dwyer

    David Dwyer Active Member

    I checked both -+15 volt rails and they are both good. See picture of test points . Good guess though, as that is what I first suspected before I found only one bad channal on other unit indicating a it was not a common-power supply issue. Power supplies are part of main board. I wish Presonus would provide service schematics so I could troubleshoot further.
     

    Attached Files:

Share This Page