1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

Pro Tools LE Crashes on exit, Opus please help!

Discussion in 'Pro Tools' started by lorenzo gerace, Apr 6, 2003.

  1. lorenzo gerace

    lorenzo gerace Active Member

    My Pro Tools LE on 001 (vers 5.3.1 on Win XP Pro)works and runs OK, but lately I'm experiencing a very annoying problem: when I quit the program I get an error message like this:

    Microsoft Visual C++ Runtime Library

    Runtime Error!

    Program : F:programsDigidesignPro ToolsPro Tools LE.exe

    R6025

    -pure virtual function call

    and as I click OK on the message log, Pro Tools quits and I get a static intermitting signal (tic tic tic tic...) coming out of my monitors; then the system reboots, with all of the consequences we know...
    This only happens when I quit the program, when in use it runs OK except for a thing (see below).

    I tried to troubleshoot the system, but the problem happens randomly: sometimes if I just open a session and then close it, it works OK, but if I start working and do some editing or mixing then boom :mad: !!

    My system configuration:

    AMD Athlon 1800XP++
    Asus A7M266
    512Mb Ram
    Maxtor 30Gb ATA100 (boot)
    Maxtor 60Gb ATA100 (audio) IDE2 master
    Waitec CDrw IDE 2 slave
    Yamaha SCSI CDrw
    Matrox G450 Millennium Dual Head video Card
    ADAPTEC 2940 SCSI controller (PCI slot 5)
    Digi 001 slot3 IRQ 9 (or 10)
    Dual Boot system Win 98SE partition 1, Win XP Pro partition 2 (the problem only happens on Win XP Pro).
    no other cards or devices.

    Thanx

    L.G.
     
  2. llornkcor

    llornkcor Active Member

    is LE the free version of PT? if so, I think it only works on win9x
     
  3. Opus2000

    Opus2000 Well-Known Member

    Lorn

    When someone says 001 that means the full version of the LE software and not the Free....get it straight you Linux geek! lmao!!!

    Anyhue,
    Gerax..this sounds like you are in ACPI mode on a motherboard not set for the proper APCI mode.
    In the BIOS there is a setting for power management that lists PCI or APCI modes. Please check to see which one it is set to.

    I believe for that Asus board it's either in the Boot up page or the power configuration page.

    Because of this the OS is taking full control over your system and not allowing XP to do it's thing properly by giving you the extra IRQ's.
    If done properly you should see IRQ's in the 20's ranges.

    I would reinstall the OS and start over as this sounds like a system conflict, as Digi has stated.

    The one stipulation about XP is that it must be installed in a very specific way for it to work optimally. In order for this to work it should see the motherboard settings upon installation.
    Unfortunately it can not just be changed in the middle or afterwards.

    I know it's not what you wanted to hear but it's the truth. Because you tried changing IRQ's and saw that it didn't follow in XP, that's what tipped me off on this.

    HTH

    Opus
     
  4. lorenzo gerace

    lorenzo gerace Active Member

    Opus

    Thanx for the reply.

    I checked for this APCI (or ACPI?) function setting in the BIOS, but I didn't find it in none of its sections, neither in the Power or boot pages, and not in any other page of the motherboard's BIOS. What???

    If I try to start from scratch and reinstall Win XP, what guidelines should I follow in order to have a clean and right install? Last time I installed it it went OK apparently, just launched the CD and let it go from there.

    This is quite strange, do you think my dual boot setup can be of any concern with this problem?

    In the meantime I'll try to see if there's something else: the system didn't have any of these problems untill I installed a serie of updated plugins (the newer versions for Win XP), I'll try to uninstall them and see if I get any result, but the IRQ and drivers issues tell me I won't get much (I know, it's just that I want to try everything I can before reinstalling the OS :( ).

    Thanx

    L.G.
     
  5. Opus2000

    Opus2000 Well-Known Member

    Well, I just perused the manual for your mainboard and didn't see that option as well.

    Couple of things to look at then..Plug and Play BIOS set to NO.
    Power management, what is that set at? User defined?

    Yes, the install will go into ACPI mode automatically, which is the was to go.
    Check to see if you have the Plug and Play BIOS on or off...should be off.

    Removing the updated plug ins may not work as they're most likely still embedded in the registry.

    One word of caution...if the plug ins were working before updating them..why update them?

    If you are going to do an update when things are working, advise is to ghost the OS drive before doing so. This way you can roll back to the original state within minutes!

    Opus
     
  6. lorenzo gerace

    lorenzo gerace Active Member

    OK

    Plug and Play is and was set to No (or Off), Power Management set to User Defined.

    The Plug ins Update is because of the new version of some plugins made by Digi: PT5.3.1 only runs on Win XP so, new drivers and new version of plugins, you just download the updates from Digi's web site, but I don't think that could be the culprit ( but now I'm very open to other opinions...).

    So I can launch a new install of the OS? Should I let XP reformat the drive (right now the XP partition is NTFS)? or should I just overwrite the OS over the existing one?
    Can I leave the BIOS on its current settings or should I load the defaults and afterwards set it for optimum performance?

    Again, Thanx for your help, I appreciate it very much

    L.G.
     
  7. llornkcor

    llornkcor Active Member

    I stand corrected.
    :p:
     
  8. lorenzo gerace

    lorenzo gerace Active Member

    Hey Opus

    Do you think I should set the BIOS to its default and then install Win XP (and afterwards bring the BIOS back to its audio optimized settings), or it doesn't matter? and should I reformat the drive or just launch another install overwriting the existing one (file system is NTFS now)?

    Thanx

    L.G.
     
  9. Opus2000

    Opus2000 Well-Known Member

    Sometimes starting from the default settings are a good idea. Then do the necessary changes like disabling serial ports, if not using the parellel port disable that, make sure plug and play OS is set to Disabled or Off, disable onboard sound and modem if applicable or needed.

    After that reinstall the OS! Always format..never do an install on top of an existing OS.

    Opus
     
  10. lorenzo gerace

    lorenzo gerace Active Member

    OK

    I did everything from scratch: BIOS on default, complete format of the drive (NTFS again), reinstall of Win XP (it seemed to be a clean install), configure the system for audio performance. Results:

    The IRQ positions are still the same, several other devices share the IRQ 9 with the 001 PCI card, and I cannot move them from BIOS (I forced the 001 PCI slot n°3 to IRQ 10 and in device manager it stays in 9).
    :(
    However Pro Tools runs OK (after some buffer settings). At this moment it's the only program installed; the IRQ thing doesn't seem to be the culprit.

    Next I install the Wave Drivers again, the installation goes OK and all of a sudden Pro Tools freezes on exit. On top of this I restarted the system and a blue screen appeared with a "Corrupted Drivers" writing, and a lot of other space balls regarding uninstalling them and updating the version of the software. In the HW device manager they appear as installed but not working properly, and not plug and Play compatible. :mad:

    At this point, being Pro Tools the only program installed on a fresh OS install (no plug-ins at the moment)I start to doubt the Wave Drivers, since I just uninstalled them and Pro Tools is fine again.

    I downloaded them from Digi's web site, is it possible that something corrupted them during download? I'll try to get a new driver to see if it works.
    :confused:
    What's your opinion on this?

    Thanx for your feedback.

    L.G.
     
  11. lorenzo gerace

    lorenzo gerace Active Member

    And the funniest thing is that with this IRQ arrangement the machine runs like a dream :D

    Still I hope somebody forwards his7her opinion on the suposedly corrupted Wave driver file.

    L.G.
     
  12. Opus2000

    Opus2000 Well-Known Member

    Well, I have a tech call to go to tomorrow in which someone is having major issues with the 002 system they have.

    It won't run properly without saying there is not enough memory! they've got 512MB of ram in there too! lol

    When I go there and check it out and find anything out on it I'll post back

    Opus
     
  13. lorenzo gerace

    lorenzo gerace Active Member

    OK

    downloaded and installed a new Wave Driver and everything seems to be working fine right now; I had a couple of "cannot Acquire Hardware" when launching Pro Tools, but I remedied it following its directions, and allowing Pro Tools to be active in the background.

    So far it works great.

    L.G.
     

Share This Page