1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

Problem sending midi notes to external hardware in Ableton Live 9 Suite

Discussion in 'Ableton' started by detlef, Feb 3, 2016.

  1. detlef

    detlef Active Member

    I want to use Ableton Live 9 Suite to play some background tracks while performing live.
    One track is configured to send midi notes to an external drum machine. This drum machine have a built in bass line that plays through a bass amp. I'm just interested in the bass line, wich is triggered on channel 8 of Ableton (and other sequencers).

    The midi port (midi to USB device) is visible and set up as output on the track that I want to play through the bass. Everything seems set up correctly.
    I can see the lights in Ableton when notes are playing, but the drum machine is not receiving this notes.

    If I close Ableton, open Cubase SX (a 2004 version) and perform the same task everything works fine.
    Then I close Cubase and restart Ableton and the problem is solved, Ableton is capable of triggering notes in the drum machine.

    What's going on?

    I know this is quite a basic task. I did it for years with Cubase without any problems.
     
  2. detlef

    detlef Active Member

    Please do not reply all at once...can't follow you guys
     
  3. pcrecord

    pcrecord Don't you want the best recording like I do ? Well-Known Member

    Hi Detlef,
    It's very hard to figure out why it would work only after you used the midi port with another DAW.
    At first glance, two things pops in mind.
    1. The drivers arent fully compatible with the OS or Ableton
    2. Cubase may be sending a midi reset via exclusive sys when it fires up and Ableton may not.
    What's the interface/midi device ?
     
  4. detlef

    detlef Active Member

    Hi pcrecord
    It's an Icon midi port 2 (2 ins 2 out) and it comes with its drivers.
     
  5. pcrecord

    pcrecord Don't you want the best recording like I do ? Well-Known Member

    I'd check for firmware and driver updates :
    http://support.icon-global.com/hc/en-us/sections/203652207-Audio-MIDI-Interfaces
     
  6. DonnyThompson

    DonnyThompson Distinguished Member

    Have you checked your drum machine's midi menu/setup section to make sure that it's either receiving midi data (Rx) on the correct channel, or, set for omni to receive on all channels...
     
  7. detlef

    detlef Active Member

    The drum machine is from the 90s and it hasn't much midi parameters to set.
    Note that I don't need to play the patterns through midi clock, I just want to trigger it's internal bass sounds with
    a midi track inside Ableton or Cubase.
    The bass sounds are triggered when the midi track is set to play on channel 8 (each other channel trigger different sounds).

    The track in ableton displays midi activity but no midi command actually get out ( I drove the midi into another synth and it does not play either)
    Everything seems to works only when I open Cubase, set up a midi track, close Cubase.
    Only then when I reopen Ableton everything works fine.

    It seems that Cubase somewhat activate the midi port, when Ableton can not.
     
  8. DonnyThompson

    DonnyThompson Distinguished Member

    what model drum machine is it? If it has midi, then it's going to have to have some kind of Midi RX and TX channel parameters...
     
  9. detlef

    detlef Active Member

    It is a Zoom rhythmtrak 234
     
  10. DonnyThompson

    DonnyThompson Distinguished Member


    http://www.manualslib.com/manual/515703/Zoom-Rhythmtrak-234.html?page=57

    At the bottom of the troubleshooting column:

    "Use the [FUNCTION] key and pad 13

    (MIDI) to change the setting from "Int"

    (MIDI receive disabled) to "Midi" (MIDI
    receive enabled "


    Is your Midi set for "On" and is it set for "INT" or "Midi" ?
     
  11. detlef

    detlef Active Member

    Thanks Danny for your answer, I know this function and it tells the drum machine if it must receive midi clock or not.
    I don't need to play songs/pattern in synch in the traditional way.

    I did this in the past, and then realized that
    1. patterns/song programming is very time consuming
    2. patterns runs out soon

    What I'm doing is programming a midi track in Ableton (or Cubase) that is set to send midi notes to the bass line of the
    drum machine (no patterns/songs hassels like the old days!).

    My guess is that Ableton can't activate the midi port properly, when Cubase can.
    I tried to send the midi notes to a synth (instead of the drum machine) and problem persist.
     
  12. DonnyThompson

    DonnyThompson Distinguished Member

    So Cubase works fine with sending midi data to your drum machine, but Ableton can't - then yeah, obviously it's a "tic" in Ableton, something that needs to be engaged/turned on/adjusted.

    Unfortunately, I'm not an Ableton guy, so I can't help you with that, but this might:
    ( @ :58)

     
  13. detlef

    detlef Active Member

    The weird thing is that after Cubase is opened, perform the same exact task, close Cubase, open Ableton, then Ableton send the midi notes like it was supposed to do.
     
  14. DonnyThompson

    DonnyThompson Distinguished Member

    Now THAT... that sounds like a driver issue to me... for your midi interface... or perhaps there's a conflict there with another device that you may have resident but don't know about?

    Are there any other midi drivers resident on your system, anywhere? Perhaps old ones you no longer used, from an older interface? Or, even General Midi...
     
  15. detlef

    detlef Active Member

    No old midi interfaces, computer is 5 months old.
    This Icon port is supposed to be plug and play. At the Icon site I can't see any software for the Midi port 1 and 2.
     
  16. DonnyThompson

    DonnyThompson Distinguished Member


    Man, I don't know Detlef... It may be time to talk to someone at Ableton support and see if this is maybe a tic in their software?
    I'm sorry I wasn't able to help you. I hate it when I can't help a colleague. I just don't know what else it could be... I'm sorry :(
     
  17. detlef

    detlef Active Member

    On the troubleshooting section at the Icon website they says that the Midi port can act weirdly if plugged on different ports, they suggest to reinstall the interface.
    I think it has something to do with the fact that I plug and and unplug often. On the weekend I'll go to the studio and try to reinstall.
     
  18. Sean G

    Sean G Well-Known Member

    Are you running a Mac?

    - Macs' tend to do this when you unplug and plug something back into them.

    I bet you are running a Mac....if you are I'd put my money on that being it. (where you state "the fact that I plug and and unplug often...")

    I found out that when I was running a mini-mac, I'd unplug the USB and when I plugged it back in it would never detect the audio device that only moments before was working fine. I found when I rebooted the system it would detect it, sometimes it would take many reboots for the mini-mac to detect the audio device again.
     
  19. DonnyThompson

    DonnyThompson Distinguished Member

    Yeah... you might have mentioned that little tid-bit earlier... LOL
     
  20. detlef

    detlef Active Member

    No mac, Compaq laptop with Windows 8.1
    Yes I unplug the Midi port whe not in use, USB is made to move stuff easily, if this is a problem I will never buy another USB to midi interface
     

Share This Page