1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

problems with MTC in Magix Studio 2 w/Samplitude 2014

Discussion in 'Samplitude' started by joemariani64, Jan 29, 2016.

  1. joemariani64

    joemariani64 Active Member

    Hi all,new here so go easy on me....I'm running Music Studio 2 w/Samplitude 2014 in conjunction with a Tascam 2488 Digital Porta studio with the tascam as master.The problem is when I start the tascam,Studio 2 doesn't start.It shows that it's getting sync signal and all appropriate boxes are checked in the sync settings menu.If any one has any knowledge of this problem and could helo I would apprecia it,thx.By the way I also have the much older Magix Studio deluxe 12 which follows sync but not very well and I also use Logic 5.5 which follows great but due to hardware constriction doesn't do the audio reliably.All above programs are running on Windows XP.Thanks again!
     
  2. audiokid

    audiokid Staff

    You aren't the only one. I'm on Sequoia 13 is the MTC is a lot more stable. I also use Mark of the Unicorn MTP and slave to it, use it to route all the controllers. That works well.

    Basically Sequoia and Samplitude is impossible when it comes to be the master MTC and is lame as a slave
     
  3. joemariani64

    joemariani64 Active Member

    Thanks for the insight.I'm about convinced that both Magix programs are lame when it comes to slaving to Mtc.Of course it would be nice to see studio 2 respond at all!I tried sending midi clock from the tascam but it's sloppy in both magix programs and only slightly better in logic.It's a shame really because the magix programs play audio back well and its fairly easy to manipulate samples and loops.The only other thing I can think of to alleviate the problem is to strip out all midi controller and program and put them on a seperate track.But if it won't sync reliably then I have I have to work with them in my sampler,whose disk drive is shot!Yes I need new equipment...lolMy next experiment is to generate Smpte from the magix programs and stripe a track on the tascam and then see how it locks then.Thanks again!
     
  4. audiokid

    audiokid Staff

    i feel your pain.
     
  5. DonnyThompson

    DonnyThompson Distinguished Member

    Hmmm...

    Not sure what to say here...

    About two months ago, I found an old file/sequence in Sonar that I'd worked on many years ago, and since I don't work in Sonar anymore and work exclusively with Samp Pro X Suite now, I wanted to transfer the external midi info from a Proteus Sound Module to audio tracks in Samp for further production.

    I imported the midi tracks into Samp, made sure tempo was set correctly, set Samp as the master for MTC, made sure the external midi tone mod was set to receive the data; ( I also allowed two measures at the top of the sequence due to past experience with MTC "chopping off" the first few notes of a sequence if started precisely at 01:01:00) - and everything worked fine... no drift, no pauses, no glitches...

    I was able to do 8 different passes for 8 different/discreet tracks, and I didn't have any issues at all.

    The thing is, because I've only ever done it one time with Pro X Suite, ( it's just not something I do much of anymore in my production workflow), I don't remember exactly what I did, or how I had things set - other than what they would "normally" be set for when working with MTC.

    (I'm using a Presonus 1818VSL as my main midi I/O).

    I'm just throwing this out there....

    If you are having the same issues in Logic too, I think I'd be looking at your interface, or even perhaps your external midi device as more of the source(s) of the issues. If you've tried three different DAW platforms, and none of them are able to get your midi to respond to the sync code, then I'm not sure the DAW's are the problem...

    Are you using USB-based Midi? Or "standard" midi?

    Have you made sure that your versions of Samp//Magix are all up to date, patch and bug-fix wise?
    Have you made sure of the same thing with your audio/midi interface drivers... not just software, but firmware, too, if applicable...
    Have you made sure that your external midi slave device(s) are set to Rx and sync to the incoming MTC?

    Finally, have you contacted Magix about this? You should file a support ticket. They really are very good with helping to resolve issues... if for nothing else than to perhaps determine that maybe it's not your DAW platform at all, but instead might be your midi I/O or your external midi device(s)...

    FWIW
    -d.
     
  6. audiokid

    audiokid Staff

    If it worked for you, that's awesome, Donny. I'm thinking it must be the other way around, that Sam or Sequoia masters better but doesn't slave well then. Especially when you are expecting dead lock and start/stop features as well.
    I have read others begging for improving this numerous times. For sure Midi works great via ITB and VST but when it comes to syncing midi tracks along side of audio in real time its not solid like it is in Sonar, Ableton, Reaper or the old days with keys and example, an MPC 60 mastering external gear. It could be improved.

    I bought an MPC Renaissance to control more things these days and went back to the external MTP and it works better for me now. I'm certain each persons chain is also subjective to your external gear because the MPC Renaissance is stunning tight where my MPC 60 was a total dog with Sam and Pro Tools.

    To reiterate your good fortune @DonnyThompson , can you sync say, an external drum module with samplitude while tracking it at the same time? And/or continue with that in a production style of working and get the punch ins to lock up 100% of the time?
     
  7. joemariani64

    joemariani64 Active Member

    Thanks for the input!Actually Logic syncs perfectly to MTC that's my main mode of recording the midi tracks.As far as
     
  8. joemariani64

    joemariani64 Active Member

    Sorry hit the wrong button!As far as the Magix programs studio 12 deluxe is old and out of date...lol but useful for my live gigs.Studio 2 is only 2 years old and I registered it when I got it but when I,went on Magix website they told me I,would have to buy a service voucher!U'm gonna try calling them this week but I'm not hopeful.
     

Share This Page