1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

Reason 5 unknown exception

Discussion in 'Reason' started by sepulchre, May 27, 2013.

  1. sepulchre

    sepulchre Active Member

    Hello,

    First post here. I may be out of my league from the looks of some of the posters here but I'll give it a shot.

    I've been using Sonar and Reason together and separately for years on my desktop (PC). Works fine. Got laptop last year (also PC) and they work there too albeit within limits, but good enough for where I use them. But about a month ago when I tried to use Reason I got a message box: "unknown exception". That was when Sonar tried to bring it up as a rewire. But the same thing happened when I rebooted and tried it on it's own - click the icon and instantly the message box comes up without Reason ever showing its face. I cleared it off the PC and reinstalled it with exactly the same results.

    Anybody got any ideas? Am I going to have reformat or something drastic like that?

    Thanks in advance - this is by far the most knowledgeable place I've found.
     
  2. DonnyThompson

    DonnyThompson Distinguished Member

    Hmmm... dunno. A few things you could try...


    Have you tried temporarily deleting Reason from your Sonar plugs library/organizer? See if that fixes things and allows you to open Reason as a standalone program. If it does, then try reinserting and rescanning it in Sonar's plug organizer.

    Have you downloaded any new programs or made any changes to your computer? Any updates? Any shareware that you have recently downloaded and installed?
     
  3. hueseph

    hueseph Well-Known Member

    Try running as administrator.
     
  4. sepulchre

    sepulchre Active Member

    hueseph - I tried that to no avail. (thought sure that would work)

    DonnyThompson - I'm not sure if it's actually in Sonar's plug file library. I don't recall putting it there but I'll certainly try it tonight and get back with results. Yes, I'm sure I've installed various things since but the question is What. Maybe I can do a restore back to some early point and try it, but I'm not holding my breath.

    Thanks guys for the response. If necessary I will eventually resort to reformatting. Seems like I have to do that every so often with Windows. Fortunately it's very easy on the laptop but then I'm faced with reloading everything. So I'll keep trying.
     
  5. hueseph

    hueseph Well-Known Member

    Before you reformat, check at the propellerhead's user forum. See if there is a similar issue. Likely you will need to clean your registry from any stragglers. It shouldn't be too hard. You could even try using Eusing Free Registry Cleaner, but it's likely that you will have to delete a few entries.

    The above quote is in reference to Reason 3.02

    You may want to check that you have the very latest versions of your software. A little more info might help as well. Windows version, Sonar version, Reason version.
     
  6. sepulchre

    sepulchre Active Member

    Tried the registry cleaner (thanks for that). The problem is still there. I tried to register at Propellerhead's forum. It asks for "Image Verification" but there's no image there to verify, nor is there a place to enter such verification. I tried contacting them about it but had the same problem. (Hrmph!)

    I've got Reason v5.01 and Sonar versions 8.5, X1 and X2. I tried going into Sonar's Plug-in Manger in all 3 versions but could find no place for rewires. I'll have a look at the files themselves but I doubt there's a slot for them. If I make a new project and add a synth there are no rewires available. (Reason is my only rewire)

    I will continue to see if I can get a message to Propellerhead about the registration problem. Perhaps they want me to upgrade to 6.5. Not just now, I think. v5 has worked very well for me since I got it . . . . that is, until now.

    I will also try a restore to some point when I'm certain it worked.
     
  7. hueseph

    hueseph Well-Known Member

    Try iobit uninstaller. Make sure you choose "advanced". After the uninstall, it will scan for any leftover files. Incidentally, I had a very similar issues with Samplitude and Movie Edit Pro. Neither would start up. I had to do a complete uninstall and clean the registry. I had to physically go in and delete the files. After a reinstall, everything worked fine. This also happened after the install of a new SSD.
     
  8. sepulchre

    sepulchre Active Member

    I just tried uninstalling, then cleaning the registry and then reinstalling - no luck. I'll try this uninstaller. Thanks!
     
  9. sepulchre

    sepulchre Active Member

    Okay, I tried all that - no luck. I will have to find a way to contact Propellerhead. They've always been good before, I'm sure they will respond. Who knows, maybe there's some magic bullet. But for now I guess I'll just do without Reason, at least until I decide to format for whatever, uh, reason.

    Thanks a million for your help. Now I have a nice registry cleaner and uninstaller! If I discover something that fixes this problem I'll certainly report back here so that anyone else facing this dilemma will have some answers.
     
  10. I just was reading through all these replies because I am having pretty much the same problem except im only getting the unknown exception box pop up when I try to open a certain beat. I use Reason 5 for making beats and it's worked fine since its come out but all of a sudden when I try to to open this one beat it gives me the "unknown exception" box and wont let me open it. All my other beats open fine. Anyone know what I can do to fix this?
     
  11. sepulchre

    sepulchre Active Member

    I've had similar problems with specific files, not with Reason but other apps. A few times I was able, by various methods, to 'fix' the problematic file. But unfortunately I usually had to rebuild whatever file it was from scratch. I hope you have better luck. If not, if you do have to rebuild your beat, well just be thankful that your Reason is working. I have not been able to use mine ever since the original problem cropped up. It works fine on my desktop at home but not on my laptop. So I cannot use it at work where I need it most. If I could afford it I would get the latest version - Seven, is it? But kids, grandkids, car payments, and on and on . . .
     

Share This Page