1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

recorded audio is always off tempo on playback! Latency?

Discussion in 'Recording' started by mikel33, Oct 5, 2008.

  1. mikel33

    mikel33 Active Member

    Hello..

    I am new to recording and Cubase. I am using a Tascam US-122 Audio/Midi interface, Cubase Studio 4 and a Athlon 3400+, 2 gig ram and Sound Blaster X-Fi.

    I have my guitar running to a digital FX unit, which runs to the Tascam, which goes to the PC through USB. My headphones are in the out of the soundcard (obviously),,

    When I record a guitar track, I am listening to the drum track in my headphones. Every thing is in time. When I play it back, the guitar is slightly after the beat.

    I know it has to do with processing the audio, but I don't know much more from there. I assume it has to do with latency which I don't know much about.

    If anyone can help me to simply lay some tracks down that are in time I would really appreciate it!!

    Thanks!

    -Mike
     
  2. pr0gr4m

    pr0gr4m Well-Known Member

    BAD. Use the Headphone ouput of the Tascam. If you are recording with it you should also use it to monitor. Computer sound cards are not really the best thing to use for any sort of audio recording and if they don't have ASIO drivers, you are definitely going to have timing problems. On to the next thing...

    What you are experiencing is latency. In Cubase go into Devices/Device Setup and click on VST Multitrack. Click on Control Panel and look at your Samples per Buffer setting. The lower the setting the less latency you will experience. However, you can only go as low as your system will allow. For example, you can set it to 96 but when you play back, your system may introduce clicks, pops, pauses and other undesirable effects. What you need to do if find a happy medium where you can have a low setting but still be able to record with little latency.

    I hope this helps...and get the computer's audio card out of the chain. Use it for computer audio but not for recording audio.
     
  3. mikel33

    mikel33 Active Member

    I am adjusting the input samples per buffer, I've tried 96, 512, 1024 and 1280... 1280 is not as bad as the lower, but it still has the pops an clicks... The default 2048 seems to work fine... except for the fact that I can't get the recordings in time. It seems that I need a better PC?
     
  4. GeckoMusic

    GeckoMusic Guest

    When you say "sound card" you mean the Tascam US-122 right? Just don't use the sound card on your computer. Make sure you have the latest drivers from Tascam, and are not using the Windows default audio driver.
     
  5. mikel33

    mikel33 Active Member

    I did mean sound card. But I have since changed it to the Tascam. But I am still having this latency issue. I think I need to upgrade my PC. I can't get anything decent below 2048.
     
  6. GeckoMusic

    GeckoMusic Guest

    The latest drivers should fix the issue. If not you can still compensate. I don't use Cubase, but most programs have a way to compensate for delays in the record path.

    Turn off the direct monitoring, and monitoring in Cubase. Then take the line out of the Tascam, and connect it to the line in. Load a drum loop or a sample with a nice sharp transient, and record it though your Tascam. You should be able to visually see the latency from the sample to the recorded sample. Measure this with the cursors, and put this into your latency compensation.

    Hope you don't have to go the measuring latency route.
     
  7. mikel33

    mikel33 Active Member

    I can't say I really understand.
     
  8. Brien

    Brien Guest

    What you need are manuals, reading time, understanding and at least 12 months of experience.

    You are trying to do too many things with dissimilar hardware. Maybe you are thinking that a simple "do this, don't do that" will correct your issue.

    It will not.

    Don't blame the computer...yet.;) Most often these latency issue can be corrected but NO one can know what it is you are doing on this computer unless you slow it all down and give pertinent information.

    Using a computer that is running nothing else but your recording software is important. All other things, internet, VirtualGirl, messenger services, Networked video games, VirtualGirl, etc must be terminated!!

    If you are going to do this recording thing and ask these good people to give up time then you have to give them an error free, clutter free system for them to opine from. Mostly people assume that the OP is running a clean system. Mostly I have seen, they are not running a clean system.

    Good luck.
     

Share This Page