1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

Setting up MIDI keyboard in Cubase 5

Discussion in 'Cubase' started by guava91011, Feb 24, 2012.

  1. guava91011

    guava91011 Active Member

    Hey guys, I'm stuck and would very much appreciate some help.

    I have a:

    Yamaha PSR 350 keyboard
    Yamaha UX16 MIDI/USB cable (connects keyboard to computer)
    Cubase 5

    I know that the driver of the UX16 is installed because I can eject the "Yamaha USB-MIDI driver", by accessing one of the icons in the bottom right corner of the computer screen.
    When I open up an empty project and play the keys of my keyboard I can see that Cubase picks it up, but there is no sound. I tried recording though and nothing is picked up. I went under "MIDI Devices Manager" and under "Install Device", my keyboard isn't listed.

    What steps do I need to take? Please advise.



    I've added two pics Untitled.jpg Untitled_1.jpg

    For the first pic the "In" is the "Yamaha UX16-1" (my keyboard isn't mentioned)
  2. Kapt.Krunch

    Kapt.Krunch Well-Known Member

    It may not being seeing the keyboard because it doesn't know it's there. The USB device may know it's there, and the computer knows the USB device is there. The computer isn't talking directly to the keyboard, so the computer doesn't know who it is. The USB device is just passing along the info, I suspect.

    Apparently, the USB device needs drivers, from a quick glance at Yamaha's page. Did it also come with some small application to recognize and set up any of a number of keyboards? I doubt it, but it's worth wondering. it says it works on ANY keyboard (probably also output to any outboard module that's able to recognize GM/XG MIDI), so I imagine that once the drivers are installed, it just translates any ol' MIDI data to pass through USB. I know you have the drivers installed, because Cubase sees the device.

    Now then...getting them to meet.

    1) The keyboard MIDI Out Channel must be set to a channel you choose to transmit. If you just play one thing at a time, and want to trigger sounds in the computer, just set it to Channel 1 (unless you are triggering drums, then set it to Channel 10, because that's the normal MIDI drum channel.)

    2) You must set the MIDI In channel in whatever software you are using to receive the data sent by the keyboard by setting it to the same channel as the MIDI Channel Out that you set on the keyboard. In your case, it's Cubase, so choose a track, and assign its input to receive the MIDI from the USB device, and set the track's MIDI receive (MIDI In) channel.

    3) You must assign a sound for the keyboard to trigger, or it won't make a sound, (though, if you've done the preceding properly, you likely could actually record MIDI data and it will show up in the track, but since it's not triggering anything because it doesn't know WHAT to trigger, there will be no sound). On the Cubase track that you just set up, assign an instrument of your choosing. It could be anything that receives a MIDI input to trigger sound...an internal soundcard, a virtual instrument (VSTi), an outboard sound module, or even another keyboard. NOTE: (Any external device will also have to be set up to receive the same MIDI channel.)

    You MAY want to start out with MIDI In to the keyboard disconnected, for now. See if you can get the keyboard to trigger a sound, and record MIDI data, first. The reason for that is that if your keyboard MIDI In is also set to the same channel as you set everything else to, and it's connected, most programs (I believe Cubase included) will automatically send that data back into your keyboard, causing a MIDI loop. That will cause, possibly, stuck notes, double-notes or even a complete program hang. The first goal is to get the keyboard to trigger a sound.

    When you accomplish that task, then you can go in and set Cubase, or the keyboard, to NOT retransmit the input back to the keyboard. Once you have that figured out, you could leave both cables connected, so you can have the computer sequencer (Cubase) triggering the keyboard sounds, if you want. You don't NEED the MIDI Out (from computer into keyboard) at all, if you never want to have the computer play the keyboard. In other words, it won't hurt to leave it disconnected, at least for now. The keyboard-to-computer should still work fine with the other cable disconnected.

    I haven't used Cubase in years, so I don't remember what the setting is, or where it is, to prevent it from looping the MIDI back out. That will be in the manual, or maybe someone here will throw in that little nugget. It'll likely be in one of your "Settings" menus.

    Anyway, try all that first, then if you have more questions, revisit the topic and update us.

    Basically, set MIDI out channel on keyboard.

    Set up track in Cubase, and set MIDI input channel to match.

    Assign instrument to track.


    Good luck,

  3. JohnTodd

    JohnTodd Well-Known Member

    When I use MIDI in Cubase 5, I always add a "Instrument track" rather than a MIDI track. Then Cubase asks me what instrument I want, and boom! It plays.

    I have never been able to get a MIDI track to play sounds triggered from my KB.

    Of course I have to select the MIDI input on the instrument's Inspector, and all that.
  4. guava91011

    guava91011 Active Member

    Thanks for the detailed advice Kapt.Krunch, you've been very helpful.

    Now, I added a MIDI track and can pick up the sound directly from the keyboard but, there is a slight lag between the instant I press the keys and the sound I hear.

    How do I fix this?

  5. Kapt.Krunch

    Kapt.Krunch Well-Known Member

    What instrument did you assign to it...as in, is it to a soundcard, or are you triggering a VSTi, etc?

  6. Red Diesel Engine

    Red Diesel Engine Active Member

    Are you going out an ASIO compatible audio interface, or out your PC's sound card? If it's out the basic pc sound card using direct sound, then you'll get a lot of lag. I found that when I first starting playing about with a midi keyboard. Switched the output to my audio interface and the lag went from 100 ms (or greater) to about 3-5 ms.

Share This Page