1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

Sonar 2XL a Xtra Large headache

Discussion in 'Sonar' started by Decco, May 13, 2004.

  1. Decco

    Decco Guest

    Hello

    I am currently using Sonar 2 XL and when I import tracks of audio to record my vocals I get a pop up *Low Virtual Memory*. I currently have 256MB RAM and a 1.8 Ghz percessor. I fixed that problem I adjusted the vvisual memry settings in the properties. The recommended Memory to run Sonar is 256 but my Sonar STILL runs choppy and keeps breaking up all the time having drop outs when I import the audio tracks to start laying down my vocals. Its like 7 audio tracks I import then the computer begins to freeze. Is there something I have to adjust in Sonar Options to get it to run smoothly? When I import audio in Adobe audition I don't have this problem. I even record vocals in Audition with the imported tracks and it runs smoothly. My friend also has 256MB RAM and runs this same version of Sonar and we both run them on XP with the smae precessor speeds.

    Is it something I did wrong or doing wrong? Is there a setting to adjust the virtual memory in Sonar? Or am I doomed to using Adobe Audition for my mixing?

    Can anyone help me. Its really important cause I have a deadline to finish the track and I rather mix in Sonar than Adobe Audition.

    Thank you in advance :)
     
  2. stickjam

    stickjam Guest

    You may need to bump the buffering up--make sure your audio drivers are current too.

    IMO, I usually take "recommended memory" not to mean how much total memory in the machine, but the amount of free memory left before you run the application. I've got a 2GHZ machine for home use that runs Windows XP in 256MB and the operating system itself barely runs smoothly. Virtual memory only makes it seem like there's more RAM than actually exists, but for time-intensive applications like Sonar, it comes at a great cost since it has to swap chunks of data to the disk (usually the C: drive) and back.

    Three universal recommendations: 1.) put as much RAM in the machine as will fit and you can afford, since it's pretty cheap. 2.) If you're using the C: drive for any audio files or Sonar temporary files, get another drive (preferrably on its own controller port--not slaved to another drive) and move all your A/V and temporary folders there. 3.) If you possibly can afford it, dedicate that machine only to A/V tools such as Sonar. Run games, Office and other applications on a completely separate box. Network them together if you must share files & stuff from the "business side" of your operation (or use a USB flash key to sneaker-net files) but resist the temptation to even briefly run other stuff on your DAW, lest it install a bunch of resource hogging services. With a peer-to-peer network, you can even use XP's remote control to access your non-audio computer's desktop while working at your DAW.

    My DAW is a 2.4GHz P4 with 2GB of RAM--the only applications I have installed on it are Sonar, SoundForge, Adobe Premiere, CD Architect and a bunch of plugins. I actually have virtual memory turned off. I've never run out of memory and Windows actually seems to be more conservative on how much it chews up when it realizes it doesn't have VM to gorge on.

    There are a bunch of other things you can do to tune up a DAW, like disabling unnecessary services, but these seem to have had the biggest impact for me.

    Hope this helps.

    --Bob
     
  3. heinz

    heinz Guest

    right-click My Computer

    select Properties

    go to the Advanced Tab

    click on Settings in the Performance section

    go to the Advanced Tab

    click the button called Change at the bottom


    What are your settings for Virtual Memory? They could be insufficient for Sonar

    Try setting "Custom" to Min & Max = 2048, then click OK all the way back out and reboot.


    I have run Sonar on 1/4 the machine you have, and had no problem doing what you describe (7+ audio tracks). Something must be up.
     
  4. jonyoung

    jonyoung Well-Known Member

    I agree with stickjam, put another drive in your box for the audio files. An extra advantage is if your primary drive crashes, you won't lose your work. More RAM is also good. I run 3.0 Studio Edition with 512M and a 2.53GHz processor, never had a burp. Still, I know someone who tracks and mixes on a much smaller, much slower machine and has no problems. You might check for how your system resources are prioritized (System tab in Control Panel) and make sure memory is set to run open programs, not background stuff. You can also run the BIOS menu before Windows opens and set up a discreet bootup for your C drive so it's only running your DAW applications, not all the other stuff.
     
  5. jonyoung

    jonyoung Well-Known Member

    BTW, have you checked your soundcard's driver files for Sonar compatability?
     
  6. bgavin

    bgavin Guest

    You mention Sonar 2XL, but say nothing about having the patches installed, to bring it up to v2.2XL. They release patches for a good reason (read: bug fixes).

    Get your system and Cakewalk up to current maintenance level first, then look for solutions to problems. Often you will find the problems disappear with the latest maintenance installed.

    As for low virtual memory, check these settings yourself.
    My Computer | Properties | Advanced | Performance

    XP will recommend a minimum swap file size which is approximately 1.5x your RAM size. Based on 33 years experience in the computer industry, I recommend you set a fixed size (i.e. 384) and not a variable size (i.e. 384 ~ 768). There are good reasons for using a fixed swap file size. If you are low on virtual memory, your disk is getting full and you have a variable swap file size.

    I encourage your to increase your RAM size. Crucial (http://www.crucial.com) is what I install in all my client's machines because it works flawlessly. You can get 512mb DDR for $111 as of this writing.
     

Share This Page