1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

Sound delays (latency) with midi interfaces

Discussion in 'Converters / Interfaces' started by caboosekk08, Mar 21, 2009.

  1. caboosekk08

    caboosekk08 Guest

    Hello everyone,
    i have a midi keyboard, the M audio keystation 49e. im using it with Cubase SX on a vista computer. the keystation is working, but there is a realy bad delay on the notesreaching the computer, making it nearly impossible to record along with music on the keystation. does anyone know how i can deal with this latency problem?? help would be much apprecitated,
    thanks, keik
  2. jammster

    jammster Active Member

    I believe you need to find the buffer setting in your Audio Devices page. When in doubt use the manual for your software. Sometimes the manuals are in the help menu on the software.
  3. caboosekk08

    caboosekk08 Guest

    i cannot find any buffer setting. ive looked through the manual and there doesnt seem to be anything there! any suggestions?
  4. Greener

    Greener Guest

    Are you using the ASIO driver?
    "go to the Control Panel and lower the latency settings by adjusting the "Buffer Size Samples" settings until happy."

    All this I got from typing "Cubase SX buffer settings" into Google and clicking the third link...

    Google is your friend.
  5. jammster

    jammster Active Member

    Yes, you want to lower your buffer as low as you can. You will have to spend some quality time tracking and lowering your buffer till you get it low without glitches and pops.

    I hope this helps.
  6. jammster

    jammster Active Member

    By the way, sometimes the driver buffer is able to be accessed from the DAW menu. I use a Mac, thats the way it works for me.

    Sometimes that is not how it works. You may have to check your system settings under my computer for PC.
  7. Space

    Space Well-Known Member


    It will help everyone who tries to help if they had more information, specifically what sound interface you are using.

    Ah, nevermind. it's a usb right? And your using the Vista built in sound card, right?

    Read the manual.

    The issue is most likely not the pulse coming from the keyboard. You can do a test. Plug a pair of headphones into the keyboard output and plug a pair into the computer audio output. Maybe you can guess the rest ;)

Share This Page