1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

Stereo mix not showing up on Vista + mic hiss problem

Discussion in 'Recording' started by smiffytheninja, Jan 18, 2008.

  1. I have Windows Vista and I tried recording from the stereo mix on audacity and fruity loops. I tried looking around different websites and none of them have seem to have found a solution to my problem. I right clicked the volume icon and selected recording devices then I right clicked and selected "Show disconnected and disabled devices" still nothing shows up except the microphone. :(

    I have a built in mic and whenever I plug in another mic through the microphone jack, it records the built in mic and the mic I plug in. It's really annoying because the built in mic has a hiss. It doesn't show up as a separate microphone device either.

    Here's a screenshot:
    stereosoundproblemok9.jpg

    :shock: So many problems with Vista... the specs on this laptop are amazing for audio recording too! :(
     
  2. Could it be that you've choosen to record a stereo track and to do this you require 2 mics?

    Try it with a mono track and see if you still get the same problem.

    I've used Audacity before for recording a mix from my decks and mixer by connecting my mixer output to the mic port on my laptop and it recorded it with no problems. My laptop also has a built in mic.

    Have you tried right clicking on the mic in the above pic and choosing disable?
     
  3. I tried recording a track on Audacity with both stereo and mono. Whenever I play back the recording, I get a really loud hiss for a second, then when the vocals come in, the hiss volume goes down a little bit, but it's still loud to the point where it interferes with the recording. =/

    I tried disabling the microphone device and the stereo mix still won't show up.
     
  4. aristjohn

    aristjohn Guest

    Have you checked to see if your card supports stereo mix? I had a similar problem with both Audacity and CamPro, and I realized after trying to enable stereo mix through Vista that my card didn't have stereo mix.

    This may not be the problem, but I thought I would throw it out there. Never know.

    Good luck!
     
  5. bent

    bent No Bad Vibes! Well-Known Member

    OK, guys, back the truck up.

    On top of the other miscellaneous problems in this thread, it sounds like the main problem here is that the ninja is trying to record via his soundcard's mic input.

    This is what external ADC's are for, fellas.
    Built in soundcards are not meant for this type of work.

    Smiffy, what mic are you plugging into your soundcard, and why?
     
  6. hueseph

    hueseph Well-Known Member

    Smiffy :lol:

    Sorry. It just sounds funny. Bent is on top of the real issue. I'm just here to try and get you going for now. If you can find where the volume control panel is(it used to be a right click or double click on the speaker icon in the bottom right hand corner of the screen in XP), you should be able to select record sources. Make sure that stereo out, aux, phone, what u hear, or anything else for that matter is disabled. You should be recording from mic in only.
     
  7. aristjohn

    aristjohn Guest

    Sorry, smiffy, apparently I didn't make myself clear on what I was addressing. My thinking here is is that you were using Audacity and some of its plugins (that use the feature to inline) because the microphone is not providing a quality sound to whatever you are trying to record. That's my understanding of this, and that's what I'm basing what I'm saying on. First off... I completely agree with what another poster (bent) said, there's other ways to do this, but if you definitely want to use the stereo mix off the sound card, I think it's going to be difficult at this point. You probably will need to find an alternative way to do it.

    But, I was just answering the question on the original post that was put forth about the stereo mix issue itself. I agree, stereo mix is not the best idea for inline recording assuming that's what it is being used for, considering the fact you also tried the microphone too. Stereo mix is great to use when trying to do audio capture... it's a great solution if you don't have an alternative means. Because the mic (trying to record from speakers, I'm thinking that's what you're doing) WILL provide very, very low quality. E.g. hissing sounds. Which is why I'm thinking you tried to use the stereo mix, which many people do (I do at times) when wanting to inline something back through the sound card via audio capturing instead of using an alternate form from external equipment.

    Last few things I'll say on the "stereo mix" issue: Another thing to think about is what kind of comp you have... Sounds funny, but NONE of the Dell computers can use stereo mix via the sound cards if they are running on Vista.

    Smiffy, IF you happen to have a Dell you can go to http://www.dellcommunity.com and keyword 'stereo mix and vista'

    There's an article Dell has placed there just for this problem. According to Dell, it is a Vista issue where it does not enable features such as stereo mix on the sound cards if they have that function. so it can't be ran at all as long as you use Vista.

    On my desktop the card doesn't support it period. On my laptop, the card does support it, but it's a Dell, and there are ALOT of users that are complaining about this issue. My desktop that was used solely for mixing before the 2 I have now was able to run stereo mix just fine through the sound card if I needed it to be done that way.

    The print screen shot that you showed in your original post is absolutely the correct way to enable stereo mix IN Vista IF your comp or sound card has it and you are able to enable it. By trying to show the disabled features and none comes up on the list, really makes me believe one of the following: 1) your card doesn't support (not likely if it is a newer version) 2) You're running a Dell or have a manufacturer that is having the exact same problem as Dell is with MS 3) Your drivers need to be updated (but I think you've probably tried that since your last post). If you haven't updated the drivers for your sound card and you still want to try and use stereo mix through it, try that first before anything else. Go to the manufacturer NOT MS as they don't always provide good drivers. If you don't know what kind you have you can use CPUID... here's the link >>>>>> Google 3 to 1 rule

    Good luck... you're not the only one having this problem. There are mass amounts of forums, websites, and blogs talking about this exact problem and it's the same thing every time. Majority of people can no longer use the stereo mix from their sound cards when running on Vista. But, Dell is the only company so far (that I know of) that has actually notified customers (because it effects all Dell customers) via their website about the issue.

    Bent is right in saying you need to go in a different direction with this, but I was simply trying to answer your question on the stereo mix issue that you posted. If nothing else you take from my post, you can possibly stop scratching your head on why the stereo mix is not working, and you can focus on finding whatever is in your means and power to get, so you can get the job done.

    *Check your the sound card manufacturer too about any info regarding this. I have a high end sound card in one computer and a low end in the other. The low end is a SigmaTel HD card and they actually have a notification about this issue on their Support site as well and they state it is an OEM issue that cannot be modified. ::shrug::
     
  8. Wheew, it's been a while. :D Thanks for the replies. I got myself a pre-amp for personal recording. As for the mic hiss, any time i record just for fun with my webcam like a short video clip or whatever, the built in mic still has a hiss. I have a HP, and this is my second laptop with the same exact model number. I'm getting the feeling that the audio enhancements are causing the hiss for the built-in mic, but I turn them off and the hiss is still there. aaaah!
     
  9. TheJackAttack

    TheJackAttack Distinguished Member

    On my laptop (Dell) and on my wife's laptop (HP) the mic jack is not trs mini but is ts mini. Also, since it has a built in mic/camera for web meetings there might be an auto gain feature which you need to turn off.

    Also, when you use your new pre (firewire or usb) then disable the onboard sound completely. If you are going from your pre into your onboard mic jack you aren't any better off than before.

    Just some thoughts.
     

Share This Page