1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

TC Helicon on the Front End (help!)

Discussion in 'Pro Audio Equipment' started by LeroyGodspeed, Mar 2, 2006.

  1. Greetings,

    I recently purchased a TC Helicon VoiceWorks for use in our live show. We mostly play at smaller clubs and venues that rarely have a top notch PA, but all the same, we are obsesive about our sound/clarity/tone. We wanted a solid vocal sound that we could take with us where ever we play...
    If your not familiar with the Voice Works, its a vocal effects unit that has a mic pre/compressor/eq/chorus/delay-reverb as its chaing (among other features).

    The deal is: the outs are BALANCED 1/4... (aka TRS) and its a Low-Z output (40 ohms).

    HOW can i get that to work with a PA so all i have to do is take the mic line given by the club, and plug it in???

    I've tried a balanced 1/4 to XLR adapter... but i get TONS of fuzz and hum (its because the signal coming out of the TC Helicon is pre-amped... and going into the 'standard' power mixer is also pre-amped). I've tried using a standard instrument cable into a DI box and sending that to the PA... it works, but with a very quite signal... plus, DI's convert High Z to Low Z... this is already low Z... so i dont know if that is problematic.

    i'm at a loss here. any technical minded people have any clues on how to do this?
    The most logical thing is to use this for an insert into a board, but we dont always play at those types of venues... and i'm looking for a static solution that will work wherever. is it even possible?

  2. moonbaby

    moonbaby Mmmmmm Moderator

    Feb 23, 2005
    Can you say "ground loop"?
    I am not intimately familiar with THAT particular unit, so I will have to ask a couple of silly questions. Like, doesn't it have an XLR output like "pro" audio gear is supposed to? No? Hmmmm (pun intended). No "lift" switch on the balanced out? Guess not. As far as the noise is concerned, this is because the ground on the AC power to the clubs' PA is different than the ground path that the AC outlet you have the TC plugged into. The safest way to correct this is to run an AC extension cord to from where the PA mixer/amp is plugged to where the TC is and have it plugged into that.
    MANY people will tell you to simply use one of those 3prong-to 2prong AC adapter plugs on the TC's power cord....NO, NO, NO! THIS CAN POTENTIALLY KILL YOU!!! People have been known to die from this! Especially if a mic that touches ones' lips is involved!
    So, the other alternative is to break ("lift") the ground connection on the mic cable. I surmise that this is why you tried the DI box,eh? But the DI is loading the line out of the TC in a way that attenuates the level too much.Hmmmmmm (intended again). What you will need to do is "break" the audio ground connection between the TC and the PA. You can do this by making up a "special" mic cable that has the shield clipped off the connection to the XLR pin at ONE END only of the cable. Mark the cable so you don't use it for anything else.I haven't done that in soooo long, I forget, but I think that you want to break the connection at the "mixer end", but someone like Kev may have a different view. Good Luck!

    Jim "Humming is for the Groupies" Mooney
  3. Scannear

    Scannear Guest

    I had a similar problem with a "whineing" noise in the output of my VoiceWorks The noise varied with the blinking LEDs on the front panel of the VW. For live performances, I use the VW's Balanced 1/4" stereo outputs with a PA that only has 1/4" non-balanced mic inputs.

    I called TCH and we experimented with various connections, grounds, XLR etc, etc. They couldnt solve it.

    I had in my junk kit, a Radio Shack Ground-Loop Isolator # 270-054, and tried that in the VW's 1/4 " ouput lines to my PA. It removed the whine, although there still is some white noise in the background that continues until about 10 seconds after the VW is swithched off.

    Not sure if there is a better way to solve this, but this solved the major problem.


Share This Page