1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

Timing Problems - Logic Audio 4.8

Discussion in 'Logic' started by simonjbinks, Aug 3, 2002.

  1. simonjbinks

    simonjbinks Guest

    I'm getting timing problems when sequencing a shaker in sixteenths.

    I am using:
    Mac G4
    Mac OS 9.292
    Logic Audiuo 4.8.1,
    Pro Tools 5.2.1
    MT4,
    Digi001
    OMS 2.3.8

    + all the latest drivers and software for LA 4.8.1.

    I've been using Logic/Pro Tools in this particular incarnation, for two years.

    I've just initialised and reinstalled for the 5th time (hard drive problems).

    In Logic, under - Options-Settings-Midi Communication, what out of the following should I have on or off?

    'Use Unified Virtual and Classic Engine'
    Use OMS if available'
    'Use OMS in addition to built in midi driver'

    I had another response on the Logic Users Group advising me to take the Unitor driver out of the system-OMS folder.

    I've done that, and every conceivable combination of the above options, but the timing issue remains, even when I disable all other track; both midi and audio.

    I have been using OMS because I have Reaktor, which requires the IAC facility, but is also giving me trouble. If that further complicates matters, I'll leave it for another time.

    As far as I am aware, I have the latest of all softwAre and drivers required for Logic 4.8.1.

    What about AMT? I don't have any additional software that I am aware of named AMT.

    Could it be something else?

    Really appreciate any help.

    Simon Binks
     
  2. Nate Tschetter

    Nate Tschetter Active Member

    Hi Simon

    I work with a friend who has the AMT8 connected to a Quicksilver Mac via USB and I am underwhelmed by the timing. Then again, I'm underwhelmed by my MTPAV and MTP2 connected to my Sawtooth via Stealth serial port. It always feels "late".

    For settings, I would attempt to use "Classic Engine" and "OMS if available" (not "in addition to built-in")

    I have a few farfetched ideas:

    - filter out any incoming sync from external MIDI instruments. Synths with sequencers in them can send out shitloads of timing clock and other crap.

    - check the sequence to see if there's extraneous channel pressure or other controller events that bog down the MIDI stream.

    - turn "Auto-Sync In" off

    - make sure your sequenced part is quantized (just for the sake of troublshooting)

    - check your tempo list for multiple tempi

    - if you haven't already tried, make a new song and try sequencing the part. Perhaps there's some oddity in your Environment that is causing the problem.

    I saw your post on the LUG mailing list. I really suspect _something_ in the MIDI stream between Logic and the E6400. That something could be another MIDI keyboard's output "thru-ing" to the E6400, the aforementioned channel pressure or other data (active sensing out of Yamaha keyboards, for example), etc. Try playing back with the only connection of the interface being MT4 to E6400.

    Let us know how it works out.
     
  3. pan

    pan Guest

    Remove OMS from the Systemfolder, set logic to its internal MIDI-drivers and report if the problem persists. AMT should be on. It is the protocol for emagic-interfaces, we are talking about emagic's MT4,? or is it opcode MidiTimePiece4???
    Unified MIDI engine is important for softsynth's timing only.
    New Phase Timing ControlModel or such is the right one.

    I have a bad vibe going on with OMS and try to avoid it by any means.

    ..call me hysteric!
     
  4. Nate Tschetter

    Nate Tschetter Active Member

    Hi Pan

    I may be foggy on this but doesn't one _have_ to use OMS with that version of Logic and a USB interface? Or was the stipulation to use OMS in place if you had a non-Emagic interface?

    You're certainly not hysterical about OMS, the only worse alternative is the dreaded *shudder* Apple MIDI Manager!
     
  5. pan

    pan Guest

    Not at all, logic's own MIDI drivers are the way to go.
    But ... if you have internal Instruments or such software as Protools(that NEEDS OMS, btw)accessed via the IAC-Bus you HAVE to use it.

    Another thought on your problem, Simon - is Apple Talk activated? Back in the times that used to be one culprit, but nowadays, over USB???
     

Share This Page