1. Register NOW and become part of this fantastic knowledge base forum! This message will go away once you have registered.

Understanding Latency

Discussion in 'Recording' started by RobertPhilbeck, Oct 9, 2003.

  1. So if I'm mixing in Samplitude, and I bus track 1 out of the computer and into an outboard reverb, and out of the reverb back to the track 2 in the computer, track 2 will be out of sink with the rest of the tracks?

    What causes this phenomenon? A/D D/A conversion? Does latency also occur with onboard software plug-ins?

  2. mjones4th

    mjones4th Active Member

    Aug 15, 2003
    Short answer: yes it'll be out of sync. You should be able to realign it though, after you record the reverbbed signal, just scoot it back a little until it sounds right.

    Each step in the process applies a bit of delay.

    To bus track 1 to the sound card takes time, since it goes across the PCI bus, or Firewire controller.

    To convert that signal to analog takes time.

    Does the reverb have an analog or digital signal path? If digital than it has its own A/D process, then it must calculate the effect, and then a D/A conversion process. If its analog, its instant (i think).

    Then you gotta convert the signal back to digital and pipe it back across the PCI or Firewire or USB bus to the processor.

    Some of these latencies are accounted for by the sequencer, which is what happens with software synths and effects. But the sequencer has no way of knowing what sort of delay the outboard processor creates, and it doesn't even know that you are sending track 1 out and bringing it back, so there's no way for it to account for that delay.

    Most sequencers account for A/D/A conversion latency by lining up newly recorded tracks with other tracks. Some have global latency compensation (hint emagic) and some don't, but I don't think any can account for your specific scenario.

  3. maxmex

    maxmex Guest

    Working with samplitude, I've noticed that maybe you are having this kind of problems because of the "automatic latency compensation" feature. Certain plug ins works fine, but there are others that run better with this feature turned off i.e. "waves renaissance compressor".

    Why don't you try to turn it off and see if it works for you.

    To disable it, press "I" and go to the "mixer/track setup" and uncheck the "automatic latency compensation" feature.

    Let me know if it worked !

Share This Page