Skip to main content

Soundcraft Ghost console /power supply noise

Hi there,
I was wondering if anyone had trouble with excessive noise from their Ghost Power Supply ? Mine is 5 years old now and it's started making strange sounds ...a bit like wind whistling through an alley ..but far away umm? ... It's quite disturbing when you live on the moors :?

:( David with LoVE.

Comments

billblues Wed, 12/06/2006 - 13:32
uh..........n.s.s. Soundcraft ghost power supplies have had many problems with earlier power supplies(300,290 switching)the newer power supplies 250,275 linear are more beefy especially if your runnig 32 ch meterbr.+autom.I have a le-24 with meterbridge and a ps275 pwr supply which is also noisey.Sounds like breathing when the cooling fan kicks in. I don't care how much compressed air and tube cleaner you apply.It won't correct a design flaw, which are the intake holes in the case.The fan is also a p.o.s .I mistakingly thought you had some tech insight other than stating the obvious :roll:

bluesdudeo Wed, 11/15/2006 - 09:37
thanks for input.

Hi there,
just installed the ghost after 18 months in storage. THERE was noise coming from the actual power supplyunit not via console and speakers . The fan was kicking in and out but has settled down now. I will keep an eye on it.

Thanks to you both , I have Soundcraft techs on hold 8)

Davedog Wed, 12/06/2006 - 21:02
Sorry to hear about your problems. I own a Ghost myself. I also have a PS275 power supply with my board and have not had these kind of problems. My point was to give ANY console that has
been stored for over a year a good cleaning prior to powering it up . Ya got a problem with that? Or isnt this techy enough advice?

If you're having problems with your Soundcraft , then a visit or some correspondence with Jim Williams is probably your best bet.

Davedog Thu, 12/07/2006 - 21:48
Maybe you should not try to read more into something thats simply not there. Now kindly not hijack this nice persons thread simply because you have a beef about Soundcrafts engineering gaffs with their power supplys.....which I agree there are several.

Ya wanna get personal then be a man and email me. But not here.

billblues Fri, 12/08/2006 - 15:58
Your right remy I don't get it either."Be a man email me".C'mon DD, surely you jest.(sandbox getting to crowed?)Hijack the thread?......I thought my post is quite relevant,and at least informing bluesdudeo (orig.poster, remember?)that it's a quite common problem.I think at this point a simple google search for "soundcraft ghost power supply noise"will certainly serve him much better.

RemyRAD Tue, 11/14/2006 - 01:46
Geez David, that sounds like a regulator that's dying? It can also be a power supply filter capacitor, which like batteries, do go bad with time. I would encourage you to contact Soundcraft (?) and ship that supply off, before it can do any damage to your console. I'm not sure where you are in the UK but you need to address this problem now.

No user serviceable parts inside
Ms. Remy Ann David
x