Skip to main content
Connecting the recording world together...

At2035+ Scarlett 2i2 combination not working! help!!

Hi ! I am newbie to recording equipments. I just bought At2035 and scarlett 2i2 , and I am not able to get them working.
I tried scarlett on Dynamic mic, and worked like a charm. But when I tried AT2035, i cant see any led signals. its not even lighting up as green.

1. I am supplying phantom power.
2. I am using xlr to xlr cable (not 1/4 one).

Thinking that mic could be defective, I sent it back for replacement. so they checked the mic and told me that mic is working fine.
I have also tried Powered Usb hub, no sucess.

Is it possible that XLR TO XLR cable or Scarlett2i2 could be a problem, because I have checked them both with dynamic mic, both are working fine.
THanks in advance.

Comments

Profile picture for user Boswell

Boswell Fri, 04/12/2013 - 03:26

There are several things that could be wrong. The XLR cable could have a ground (screen) fault that allows a dynamic mic to work using the signal conductors but does not give circuit continuity via ground for phantom power on your AT2035. The 2i2 could be not actually supplying +48V PP to the XLR connectors (I'm assuming you have tried both inputs) despite you having switched the phantom power on by pressing the front-panel red button and observing that the light comes on.

What do you mean when you say you have tried a Powered USB hub? Do you mean you plugged the 2i2 in via that?

Profile picture for user CoyoteTrax

CoyoteTrax Fri, 04/12/2013 - 09:54

I just saw this post and am glad everything worked out for you.

A few months ago I bought a 2i2 purely on spec and to use with a new laptop I'd just purchased. I'm used to working on a dedicated desktop in a studio/bedio I've had set up for years. The 2i2 has continued to really surprise me, capturing beautiful tracks so I'm a big fan of the Scarlett series.

x