Amp or speaker problem.

Mike Speed

Member
Joined
Aug 31, 2020
Location
sc
Hello Everyone,
I'm brand new to the forum so be gentle. I hope I'm in the correct area to asked this question.
I have a powered monitor and it powers up, and sound comes out, but the volume is very low and it is distorted. How can I determine if the problem is the speaker or the amp?
If it's the amp, what would be the most logical problem.
I have an electronic background, but it's been 30 years since I've used it.
Thanks in advance.
Mike
 

bouldersound

Real guitars are for old people.
Well-Known Member
Joined
Jan 23, 2010
Location
Boulder, Colorado
You could check the LF driver for a rubbing coil. If you put fingers and thumbs evenly around the cone and gently push in, it should move smoothly on the suspension without any scratchy feeling resistance. If it passes that test there's a good chance the problem is in the electronics. If you can detach the drivers from the amp and connect them to another amp, that would also help diagnose the source of the problem. Be sure to cut the lows and/or keep the level way down if you are testing the tweeter.

Take a look at the circuit board(s) to see if there's any obvious burnt components, puffy caps or cracked solder joints. If it's SMT it makes it kind of challenging to diagnose or repair. If you think you're up to it, you could feed some signal to the input and check various points in the circuit to try to identify the location of the problem. A scope is handy for this kind of thing.
 

Mike Speed

Member
Joined
Aug 31, 2020
Location
sc
You could check the LF driver for a rubbing coil. If you put fingers and thumbs evenly around the cone and gently push in, it should move smoothly on the suspension without any scratchy feeling resistance. If it passes that test there's a good chance the problem is in the electronics. If you can detach the drivers from the amp and connect them to another amp, that would also help diagnose the source of the problem. Be sure to cut the lows and/or keep the level way down if you are testing the tweeter.

Take a look at the circuit board(s) to see if there's any obvious burnt components, puffy caps or cracked solder joints. If it's SMT it makes it kind of challenging to diagnose or repair. If you think you're up to it, you could feed some signal to the input and check various points in the circuit to try to identify the location of the problem. A scope is handy for this kind of thing.
Thanks for the response.
I will try your suggestions. Sadly I do not have a scope only a multimeter. I will let you know what the verdict is.
 

Boswell

Moderator
Joined
Apr 19, 2006
Location
UK
Most of the lower end powered monitors have class-D (PWM) amplifiers, which are not easy to trace signals around. The first place to start looking is the power supply, and then the amplifier output drivers (or switchers if class-D).

Try using your multimeter to look at the d.c. voltage at the speaker terminals when no audio is going through. If it is more than a few tens of mV, that's a sign that you may have a blown output driver.

What make and model are the monitors? Do you have a pair of them, one with the fault but the other one working normally?
 

bouldersound

Real guitars are for old people.
Well-Known Member
Joined
Jan 23, 2010
Location
Boulder, Colorado
Yeah, my "puffy caps" comment was at least partly about power supply, though I'd expect a hum to be a more likely symptom if a PS cap was bad. Then again, I'm not really a tech.
 

pcrecord

Quality recording seeker !
Well-Known Member
Joined
Feb 21, 2013
Location
Quebec, Canada
If we go back to basic, it could be the cable. Is it from an interface to the monitors. Do the output of the interface Line level, so does the monitor's input ?
What about plugging it to another AC outlet ?
When you turn the volume on the monitors do you hear scratch noises. Do they both make the same sound.
What happen if you plug a mp3 player or a cellphone to it ?(start with volume down and up slowly)
 

Mike Speed

Member
Joined
Aug 31, 2020
Location
sc
Ah... Brand new.

This one?
https://www.guitarcenter.com/Kustom-PA/KPM4-50W-4-2-way-Compact-Powered-Monitor.gc

No schematics found. No warranty, I presume?
Yes. That is the one. Just out of warranty naturally.
I've tested the woofer with another amp, and the seems to be ok. I hooked another speaker to the woofer leads, and still very low volume completely maxed out.
Then I decided to try hooking the original speaker back up so I could poke around with the electronics, and the woofer started working????
The tweeter was real low, but the woofer worked. Really I did nothing.
Any idea why it would start working?
 

Boswell

Moderator
Joined
Apr 19, 2006
Location
UK
The manufacturer's description of this monitor does not mention that it has separate internal amplifiers for the woofer and the tweeter, so one must assume that there is only one 50W amplifier inside and a speaker-level crossover network. If this is the case (an internal inspection would show that), then the suspicion falls on either the network itself or the tweeter. It could yet be something as simple as a dry solder joint or other bad connection, and this could explain why the woofer suddenly started working again.

You could try clipping a multimeter on about 10V A.C. range to the terminals of each of the two loudspeakers in turn and seeing what sort of readings you get when playing an electric guitar or a keyboard through the monitor. The guitar on a crunch tone played high up the neck would activate the tweeter, and should show an instantaneous reading of several volts AC on the meter.
 

Mike Speed

Member
Joined
Aug 31, 2020
Location
sc
Not sure what the reason is, but I had it playing for most of a day and it never wavered.
So for now... if it ain't broke don't fix it.
I really appreciate all the responses though, which gave me the confidence to at least tear it apart and look inside.
Thanks all!
 
Top