help installing delta 1010lt

Joined
Jan 31, 2010
OK Im just about ready to receive a M-audio delta 1010lt pci sound card and i'm going to install it Ive got a Compaq windows xp home edition desktop 2002, 32bit processor,but i have no idea where to begin. Ive done sum research on installing new pci sound cards and read so many forums,and most of them say,that i have to disable my old sound card in bios settings before i install the new one,and Ive also read that some people have had popping and crackling sounds with there delta 1010lt and the solution was to configure and tune the bios operating system chip but i have no clue on how to do any of that,and i just want the pci card to run smoothly.so can anybody help me on how to configure the bios settings before i install the card thk you for your help.
 

TheJackAttack

Well-Known Member
Joined
Mar 20, 2008
Location
currently Billings
Chances are that you won't have any problems. First, download the latest drivers from M-Audio and also the user manual. Simply follow the instructions in the manual. Turn the computer off and unplug it. Open the case. Install the 1010lt into an unused PCI slot. Close it up, plug it back in, and turn it on. Plug in a mic or whatever and start recording in your DAW of choice. You may have to set a buffer but that will be described in the manual. Don't get your panties twisted about the bios until you need to. The bios are simple and easy and there just aren't that many things you even can tweak in them. You'd be better off just diabling the onboard sound from the Device Manager but only if there is a legit problem.
 

Kapt.Krunch

Well-Known Member
Joined
Nov 21, 2005
Another small bit of advice. If you have any other PCI cards (or a video card) installed, try to install that one as far away from any others as possible. That may help minimize possible interference noises radiating from other cards.

Also, make sure you have a second hard drive to record to, other than your OS drive...and then set it up so that it uses it.

Kapt.Krunch
 
R

RiF

Guest
Nice card, I had it for years. Solid as a rock. Install the drivers and then install the card or vice versa, doesn't matter or the software will tell you. Don't fear anything. And it's always a good advice to use non-USB (in this case: PCI) audio cards. Good choice!
 

Space

Well-Known Member
Joined
Jun 26, 2007
"Two basic settings are possible, one for a microphone line level compatible with
low impedance dynamic microphones, and the other is an operating line level of +4dBu"


Reads like the difference between consumer and prosumer levels to me...
 
R

robbmatrix

Guest
"Ive also read that some people have had popping and crackling sounds..."

The Delta 1010 is a piece of rubbish; it'll barely pull 16/44 without making "the (random) noise".

My friend contacted M-Audio directly late last year about his Delta 1010's inadequate performance. The contact gave him the option to ship in the unit and -- with $180 -- he'd replace it. Once the new unit arrived it performed identically to the other one. The 1010 was tested on his older computer and also a new pimped quad-core machine.

24/96 8-channel recording was the goal so the 1010 was tossed and upgraded to a MOTU 2408mk3 PCIe unit. My friend now records flawlessly at 24/96 on a daily basis without drop-outs or noises. The only way to consistently get 24/96 and dispel "the noise" was to get rid of the Delta 1010.

[Edit]: New machine uses Windows 7 64-bit; old machine was dual-core on 32-bit XP. The 1010 was unreliable on both systems.
 
Last edited by a moderator:

Space

Well-Known Member
Joined
Jun 26, 2007
Pretty bossy when speaking about what experience your friend may have had...And the topic was the LT...not the 1010 ;)
 

blaumph2cool

Well-Known Member
Joined
May 2, 2005
Location
Portland, OR
The delta 1010LT was my first Real audio card (SB Live doesn't count).
It was good as a starter but man that thing was noisy as heck. I had the best results when i hooked it up to my Makie mixer. another bad thing is all the RCA plugs are un balanced and have to get adaptors for 1/4" and XLR use (except for the mic 1 & 2)

Be sure to disable all other sound cards on-board or otherwise.
 

Space

Well-Known Member
Joined
Jun 26, 2007
Recently I have had issue >with< the 1010lt driver updates so I revert back to the previous version...but that's just me, as well ;) Seems to be the difference between Win7, xp sp2 and xp sp3.
 
Top