Mac G5 PCI-bus

M

Marcus Black

Guest
Heard something about the pci-slots in the new G5 macs, that they are of a new standard and that "older" pci-cards (audiointerfaces, UAD-1, powercore...) won´t work and have to be replaced/updated. Anyone know if this is true ?
 
I

idiophone

Guest
I know for a fact that the UAD-1 will fit. My MOTU PCI-424 won't fit, though.
 
R

rikard

Guest
HI!
Yes it's true that some cards needs to bee sent in for modification. I just had to send my Rme Hammerfall 9652 for modification. Uad will work and the've just relased a betaversion of the osx driver.
 

mjones4th

Well-Known Member
Joined
Aug 15, 2003
Its a new standard. PCI-X is used in the G5 1.8 and up models.

Some regular PCi models will work and some won't. Most manufacturers will publish whether or not their card works in due time. Supposedly my Delta66 will work, but I dunno, b/c I don't have a G5!

The PCI bus could support cards that needed a 3.3V or 5V power supply, while PCI-X supports only 3.3V cards. I don't know if that's the only niggle, but that is one of them.

mitz
 
Top