Subwoofer issues

Mattias

Member
Joined
Jan 6, 2020
Location
arvika
So ive had this issue with my subbwoofer that its randomly stops sending out any sound.

it can be dead for a day or two and then suddenly just starts working again.

Something strange that ive discovered is that it often dies when it gets alot of bas thru the input. even stranger is when i put on some music with much bass and crank the volume it can make it start again. like a defibrillator can both kill and start a heart.

its blue sky monitors 2.1
tested with different soundcards & computers.

Best Regards Mattias
 

paulears

Well-Known Member
Joined
Feb 7, 2014
Location
Lowestoft - UK
Dry joint if you're lucky and I have a channel on a Soundcraft mixer that does exactly this. dead channel, shove the fader up and suddenly it works and then it dies again by next day. Has the subwoofer got a crossover of filter in it? If you can get to the board, tao the PCB with a plastic lump - like the handle of a screwdriver and if you hit the dry joint you can start the thing working or stop it. Reflowing the solder will probably cure it. Could be the thin wires to the speaker coil, but that's rarer. It could be an overheated voice coil and the wire has parted in the coil, and it randomly makes contact.
 

Mattias

Member
Joined
Jan 6, 2020
Location
arvika
thanks for response. yes the sub got a crossover filter to the satelite speakers connected thru it. what do you mean bu "tao the PCB"?
 

Boswell

Moderator
Joined
Apr 19, 2006
Location
UK
thanks for response. yes the sub got a crossover filter to the satelite speakers connected thru it. what do you mean bu "tao the PCB"?
I think he means "tap". What do you mean "bu"? Same adjacent key problem, opposite directions.

If the mid/highs do not resume full bass response when the sub cuts out, then it's most likely to be an intermittent connection in the power amplifier inside the sub. If the full-range signal is passed to the mid/highs when the sub cuts out, it's more likely to be a power supply problem in the sub.

However, if your sub has a by-pass switch, check the contacts on that. Some subs (like the KRK 10S that I use) have a jack for plugging in a footswitch to give you dynamic foot control of sub in/out without changing your head position. This is useful for judging the level of kick drum or bass guitar in a mix for playing on systems that might not have full-range bass. The normalling spring contact on these jacks can go dirty, as I found once.
 

Mattias

Member
Joined
Jan 6, 2020
Location
arvika
the standby switch is measured ok.

the satelite speakers remains low cut though sub when its not working.

Scenario:
sub is out. i gain low frequencies thru sub and it starts with a pop.
a strange dissonant noise comes from it.
when i gain the volume it continues but when i then lower the volume, the noise dissapears.
 

Boswell

Moderator
Joined
Apr 19, 2006
Location
UK
This could be mechanical rather than electrical: the speaker voice coil jamming against the magnet. Can the front of your sub be taken off so you can get at the speaker cone? If so, switch off the power to the sub and gently push the cone backwards using several fingers by a few mm. If it resists movement and then you hear a scraping sound when it does move, you have suspension damage in the loudspeaker, and it will either have to be re-coned or the whole driver unit replaced.

If the cone moves freely, then the problem is almost certainly a dry joint or faulty component in the amplifier internal to the cabinet.
 

Mattias

Member
Joined
Jan 6, 2020
Location
arvika
ive checked the cone, it doens have one and is just round (blu sky 12 sub) but i understand what you mean and it moves freely.

there is PCB:s in the cabinet. by my guess the amplifier is the one with all the big condensators and transistors with heatpipes.
 

Boswell

Moderator
Joined
Apr 19, 2006
Location
UK
...there is PCB:s in the cabinet. by my guess the amplifier is the one with all the big condensators and transistors with heatpipes.
Possibly. It depends on whether the power supply is on the same board as the amplifier. You should be able to trace the output leads back from the speaker to the amplifier board.

If you have the facility of monitoring the sub out signal from the sub rear-panel XLR, you could check to see that the crossover network continues to work correctly when the power amp + speaker cuts out. If it does, that may say that the power supply is also not the source of your problem.

I forgot to ask: is there a LED or other indicator light to show that power is applied to the sub? If so, does the indicator stay lit during the time you have the cutting out problem?
 
Top