Skip to main content

Echo Audiofire firmware corrupted?

Hi all. I was just wondering if anyone else has had this problem.

On a whim I decided to see if there was a newer driver for my Audiofire 8. There was. Upon downloading and launching, I got a dialog saying "your firmware is out of date, do you want to update, y/n". On clicking yes, it did some 'erasing' with a nice little progress bar, and started 'writing' with another nice progress bar, then it stopped, saying "flash could not be read". Several times I tried, with the same result. Now my Audiofire 8 is not recognized by my computer - preferences>sound doesn't see it, System Profiler sees only "unknown device". The new version "Audiofire Console" driver/interface/router doesn't do anything, no mixer-looking window pops up.

The device itself produces an awful racket from the outputs, and the metering LEDs on the front are all lit up as if a continuous peak-level signal were being applied to inputs 1 and 2. I wonder if it is damaging itself.

I gather this "flash" is a memory location inside the Audiofire 8, and my best guess is that by some bad stroke of fate it got messed up. bad luck? gremlins? full moon? who knows. It was working fine since I got it, along with this here MacBook Pro, in December. In other words, my setup is basically new, the OS has been kept up-to-date, etc.

If anyone else has experienced such a thing, do let me know how it was resolved. I expect I'll have to send it back to Echo Audio, but just maybe there is some clever-ass way to address the memory location directly, and wipe it? or something?